From: Jeff King Date: Wed, 10 Dec 2008 09:02:22 GMT Subject: Re: [PATCH 2/2] diff: respect textconv in rewrite diffs Message-ID: <20081210090221.GA11367@coredump.intra.peff.net> In-Reply-To: <7v3agw2zu5.fsf@gitster.siamese.dyndns.org> On Wed, Dec 10, 2008 at 12:34:26AM -0800, Junio C Hamano wrote: > > +cat >dump <<'EOF' > > +#!/bin/sh > > +perl -e '$/ = undef; $_ = <>; s/./ord($&)/ge; print $_' < "$1" > > +EOF > > I'll squash in a change to make this part use $SHELL_PATH for > consistency. Thanks. It was cut-and-paste from t4030, so if we care, it might be worth changing there, too (and naming it "dump" instead of "hexdump", because it actually dumps in decimal :) ). But more importantly, the fixup you just pushed seems to have an extra ">dump": > +{ > + echo "#!$SHELL_PATH" > + cat >dump <<'EOF' > +perl -e '$/ = undef; $_ = <>; s/./ord($&)/ge; print $_' < "$1" > +EOF > +} >dump > +chmod +x dump -Peff