From: Jeff King Date: Fri, 14 Nov 2008 06:24:34 GMT Subject: Re: [PATCH] revision.c: use proper data type in call to sizeof() within xrealloc Message-ID: <20081114062434.GA11907@coredump.intra.peff.net> In-Reply-To: <2NXgsahhUCpkej6JukLNJjebzyoAQgZ4ptQMMrR2j_iWS5yEqKYn0kxHsUBpiY6bkpfbTjxlSn0@cipher.nrlssc.navy.mil> On Thu, Nov 13, 2008 at 02:20:37PM -0600, Brandon Casey wrote: > int num = ++revs->num_ignore_packed; > > revs->ignore_packed = xrealloc(revs->ignore_packed, > - sizeof(const char **) * (num + 1)); > + sizeof(const char *) * (num + 1)); Maybe it would be even nicer as "sizeof(*revs->ignore_packed)"? -Peff