From: Shawn O. Pearce Date: Wed, 03 Sep 2008 15:18:29 GMT Subject: Re: [PATCH v3] for-each-ref: `:short` format for `refname` Message-ID: <20080903151829.GB27682@spearce.org> In-Reply-To: <1220431352-30605-1-git-send-email-bert.wesarg@googlemail.com> Bert Wesarg wrote: > Try to shorten the refname to a non-ambiguous name. > > Changes in v3: > * don't compare sha1's, its ambiguous if the short name > resovles to more than one ref > * use xstrdup() > * use indexes for the loops to clarify backward/forward > direction > > > Signed-off-by: Bert Wesarg > Cc: git@vger.kernel.org > Cc: szeder@ira.uka.de > Cc: Shawn O. Pearce > --- Looks good. But the commit messages shouldn't have the "Changes in v3" section or probably the "Cc:" lines. The changes in v3 part usually goes below the ---. I don't usually work on for-each-ref, but I'll toss an ack in anyway: Acked-by: Shawn O. Pearce -- Shawn.