From: Jakub Narebski Date: Tue, 24 Jun 2008 18:58:13 GMT Subject: Re: git-clone works with ssh but not with http/https/git Message-ID: <200806242058.13721.jnareb@gmail.com> In-Reply-To: <20080624135429.GA6905@atn.sw.ru> On Tue, 24 Jun 2008, Anton Gladkov wrote: > On Tue, Jun 24, 2008 at 05:42:14PM +0400, Erez Zilber wrote: > > > > I guess that the problem is that no proper mapping exists. That's why > > I see the following in /var/log/httpd/error_log: > > > > [Tue Jun 24 16:31:52 2008] [error] [client 172.16.0.7] File does not > > exist: /var/www/html/pub > > > > What do I need to add in /etc/httpd/conf.d/ in order to set the > > mapping to /pub/git instead of /var/www/html/pub ? Is there an example > > that shows how to map? > > IMO the simplest way is to create a symlink 'pub' in /var/www/html directory > pointing to /pub and to add 'Options FollowSymLinks' to in httpd.conf. Another solution (not necessary simplest, but it might be preferred from the security point of view) is to do some URL rewriting / redirection. See your web server documentation for details... -- Jakub Narebski Poland