From: Karl Hasselström Date: Sat, 07 Jun 2008 09:09:51 GMT Subject: Re: [StGIT PATCH 1/5] Rename Repository.head to Repository.head_ref Message-ID: <20080607090951.GC32647@diana.vm.bytemark.co.uk> In-Reply-To: <20080606204537.8805.12051.stgit@localhost.localdomain> On 2008-06-06 21:45:37 +0100, Catalin Marinas wrote: > This is to avoid confusion with the Stack.head function which > returns a commit object rather than a file name. The patch also > changes the "new" function to use stack.head directly rather than > via the Repository.refs... object. > > Signed-off-by: Catalin Marinas Acked-by: Karl Hasselström -- Karl Hasselström, kha@treskal.com www.treskal.com/kalle