From: Robin Rosenberg Date: Fri, 06 Jun 2008 00:22:51 GMT Subject: Re: [JGIT PATCH v3 05/23] Added the iterface Rules. Message-ID: <200806060222.51928.robin.rosenberg.lists@dewire.com> In-Reply-To: <1211574872-23676-6-git-send-email-florianskarten@web.de> s/Iterface/Interface/ fredagen den 23 maj 2008 22.34.14 skrev Florian Koeberle: > Signed-off-by: Florian Koeberle > --- > .../src/org/spearce/jgit/treewalk/rules/Rules.java | 99 ++++++++++++++++++++ > 1 files changed, 99 insertions(+), 0 deletions(-) > create mode 100644 org.spearce.jgit/src/org/spearce/jgit/treewalk/rules/Rules.java > > diff --git a/org.spearce.jgit/src/org/spearce/jgit/treewalk/rules/Rules.java b/org.spearce.jgit/src/org/spearce/jgit/treewalk/rules/Rules.java > + public abstract boolean toIgnore(String fileName, boolean fileIsDirectory); Shouldn't this be shouldIgnore instead? toXXXX is a name of a converter as e.g. toString > + @Override > + public String toString() { > + return "ignore all rules"; Probably better with something like "Rules[IGNOREALL]" to distinguish it from other strings. The bracketed toString is common for method intended for debugging.