From: Bryan Donlan Date: Wed, 09 Apr 2008 14:16:16 GMT Subject: Re: [PATCH 7/8] Use test_set_editor in t9001-send-email.sh Message-ID: <20080409141616.GB24402@shion.is.fushizen.net> In-Reply-To: <47FC69CB.1080400@viscovery.net> On Wed, Apr 09, 2008 at 09:01:31AM +0200, Johannes Sixt wrote: > Bryan Donlan schrieb: > > diff --git a/t/t9001-send-email.sh b/t/t9001-send-email.sh > > index 030f66c..0a65785 100755 > > --- a/t/t9001-send-email.sh > > +++ b/t/t9001-send-email.sh > > @@ -144,10 +144,7 @@ test_expect_success 'setup fake editor' ' > > chmod +x fake-editor > > ' > > > > -FAKE_EDITOR="$(pwd)/fake-editor" > > -export FAKE_EDITOR > > -GIT_EDITOR='"$FAKE_EDITOR"' > > -export GIT_EDITOR > > +test_set_editor "$(pwd)/fake-editor" > > > > test_expect_success '--compose works' ' > > clean_fake_sendmail && > > I'd squash this into 5/8 or 8/8. Dunno. I split it out as it's not really related to the goals of 5/8 or 8/8, but is rather pure elimination of code duplication. However if it's considered better to squash it into 5/8 I'd be happy to do so. Thanks, Bryan