From: Martin Koegler Date: Mon, 25 Feb 2008 07:26:58 GMT Subject: Re: [PATCH 1/4] add generic, type aware object chain walker Message-ID: <20080225072658.GB15761@auto.tuwien.ac.at> In-Reply-To: <20080225030404.GL8410@spearce.org> On Sun, Feb 24, 2008 at 10:04:04PM -0500, Shawn O. Pearce wrote: > Martin Koegler wrote: > Hmm. Don't you need to get commit->parenst *after* it is parsed, > and not before? Thanks, fixed. > > @@ -0,0 +1,10 @@ > > +#ifndef GIT_FSCK_H > > +#define GIT_FSCK_H > > + > > +#define OBJ_ANY OBJ_BAD > > Its unclear why this macro is necessary. There are cases (eg. a tag->tagged), where the object type does not matter. In this case, the callback gets this value for the expected type. The value of OBJ_BAD (-1) is not used anywhere in git, so its free. OBJ_ANY is just a better name. If somebody has a better idea, please tell me.