From: Jakub Narebski Date: Mon, 19 Nov 2007 15:08:45 GMT Subject: Re: [PATCH 1/2] gitweb: Style all tables using CSS Message-ID: <200711191608.46955.jnareb@gmail.com> In-Reply-To: <87d4u671kx.fsf@gollum.intra.norang.ca> Bernt Hansen wrote: > Jakub Narebski writes: > > > - print "\n" . > > + print "
\n" . > > Should this class be "project_list" instead? I don't see a definition > of "projects_list" (plural) anywhere. Now that you mentioned it, I have checked and... we have a bit of inconsistency in gitweb here. There are $projects_list and $projects_list_description_width variables (plural), git_get_projects_list subroutine (also plural), but view is called 'project_list', it is generated by git_project_list subroutine using git_get_project_list_from_file and git_project_lis_body subroutines. I am not native English speaker: gitweb mean here "list of projects". We should probably uniqueify number to either plural or singular, and not mixed as it is now. But this is a bit of nitpicking/paintshed... Changing action name from 'project_list' would be hard because of backward compatibility... _if_ we officially used this action; it is default action when no project is selected, and all links use this form. -- Jakub Narebski Poland