From: Scott Parish Date: Tue, 30 Oct 2007 03:00:24 GMT Subject: Re: [PATCH 6/7] include $PATH in generating list of commands for "help -a" Message-ID: <20071030030022.GA2906@srparish.net> In-Reply-To: <7vir4ptyc9.fsf@gitster.siamese.dyndns.org> On Mon, Oct 29, 2007 at 02:17:26PM -0700, Junio C Hamano wrote: > It's easier to read if you briefly describe the differences > between the replacement patch and the previous version of the > patch below the three-dash lines. See for example Lars Knoll's > patch from today <200710290959.32538.lars@trolltech.com>. Oh, that's useful information! For the above patch, were basically what Johannes Schindelin suggested: + add_cmdname() now uses ALLOC_GROW and has its lines reordered to be somewhat cleanre + uniq() has lost the curly brackets + s/subtract_cmds/exclude_cmds/ + exclude_cmds() uses an arg name of "path" instead of "dir" + exclude_cmd() no longer renames "dir" to "dirp" + exclude_cmds() an earlier patch moved the "struct stat" declaration for no-longer relevant reasons. change removed. sRp -- Scott Parish http://srparish.net/