From: Scott Parish Date: Thu, 25 Oct 2007 04:53:50 GMT Subject: Re: [PATCH 2/7] s/pattern/prefix/ in help's list_commands Message-ID: <20071025045349.GF759@srparish.net> In-Reply-To: <7v640v3ix1.fsf@gitster.siamese.dyndns.org> On Wed, Oct 24, 2007 at 09:41:30PM -0700, Junio C Hamano wrote: > Scott R Parish writes: > > > list_commands() currently accepts and ignores a "pattern" argument, > > and then hard codes a prefix as well as some magic numbers. > > Correct observation. > > Personally, I find this static function should not pretend to be > as flexible --- it is to list git subcommands anyway (and it > even knows about ".exe"), so rather than renaming the pattern > and using it, it might be simpler and cleaner to just drop the > parameter and be done with it. Nice, i like that even better sRp -- Scott Parish http://srparish.net/