From: Frank Lichtenheld Date: Fri, 04 May 2007 21:03:40 GMT Subject: Re: [PATCH 2/5] git-config: add --remote option for reading config from remote repo Message-ID: <20070504210339.GB30324@planck.djpig.de> In-Reply-To: <1178276203127-git-send-email-skimo@liacs.nl> Some comments on the documentation: On Fri, May 04, 2007 at 12:56:40PM +0200, Sven Verdoolaege wrote: > +'git-config' [--system | --global | --remote=[:] + [type] name [value [value_regex]] maybe something more like 'git-config' [ scope ] where you mention later that scope can be --system | --global | --remote would be more readable... > +'git-config' [--system | --global | --remote=[:] + [type] --add name value > +'git-config' [--system | --global | --remote=[:] + [type] --replace-all name [value [value_regex]] > +'git-config' [--system | --global | --remote=[:] + [type] --get name [value_regex] > +'git-config' [--system | --global | --remote=[:] + [type] --get-all name [value_regex] > +'git-config' [--system | --global | --remote=[:] + [type] --unset name [value_regex] > +'git-config' [--system | --global | --remote=[:] + [type] --unset-all name [value_regex] > +'git-config' [--system | --global | --remote=[:] + [type] --rename-section old_name new_name > +'git-config' [--system | --global | --remote=[:] + [type] --remove-section name > +'git-config' [--system | --global | --remote=[:] > DESCRIPTION > ----------- > @@ -80,6 +89,10 @@ OPTIONS > Use system-wide $(prefix)/etc/gitconfig rather than the repository > .git/config. > > +--remote=[:] + Use remote config instead of the repository .git/config. > + Only available for reading options. Why did you add it to all options in the SYNOPSYS then? Gruesse, -- Frank Lichtenheld www: http://www.djpig.de/