From: Robin Rosenberg Date: Fri, 09 Mar 2007 19:47:54 GMT Subject: Re: Diff output from a rewrite of a function Message-ID: <200703092047.54799.robin.rosenberg.lists@dewire.com> In-Reply-To: <7vbqj38gkp.fsf@assigned-by-dhcp.cox.net> fredag 09 mars 2007 00:24 skrev Junio C Hamano: > Robin Rosenberg writes: > > > Increase the context size from the default three lines. Something like > > diff -U 7 old new will require larger chunks of unchanged code for diff > > break up a hunk. With git you can do > > > > GIT_DIFF_OPTS=-u7 git-diff-.... > > I think you can say "git diff -U7" to do what you are > describing, but I do not think that does what you want. True, it's not exactly what I want, but it is easier to read than a diff split up in many small hunks with misleading context. With larger hunks I can ignore the misleading matching lines in the middle without thinking too much, so it kind-o alleviates my problems a little. -- robin