From: Ralph Corderoy Date: Wed, 20 Apr 2005 17:11:55 GMT Subject: Re: [darcs-devel] Darcs and git: plan of action Message-ID: <200504201711.j3KHBtn22691@blake.inputplus.co.uk> In-Reply-To: <1113951972.29444.42.camel@orca.madrabbit.org> Hi Ray, > Give me a case where assuming it's a replace will do the wrong thing, > for C code, where it's a variable or function name. How about two patches. 1. s/foo/bar/ throughout file because foo() has been decided upon as the name of a new globally visible forthcoming function but was already in use as a static function. 2. Add definition of new foo(). Patch 1 mustn't be a `darcs replace' despite it changing every occurence of the C token foo into bar. Cheers, Ralph.