From: René Scharfe Date: Fri, 30 Jul 2021 20:22:38 GMT Subject: Re: [PATCH] use fspathhash() everywhere Message-ID: <14653a9b-8999-78bc-03f7-b9f21954b873@web.de> In-Reply-To: Am 30.07.21 um 21:27 schrieb Junio C Hamano: > René Scharfe writes: > >> cf2dc1c238 (speed up alt_odb_usable() with many alternates, 2021-07-07) >> introduced the function fspathhash() for calculating path hashes while >> respecting the configuration option core.ignorecase. Call it instead of >> open-coding it; the resulting code is shorter and less repetitive. >> >> Signed-off-by: René Scharfe >> --- >> builtin/sparse-checkout.c | 10 ++-------- >> dir.c | 13 +++---------- >> merge-recursive.c | 11 +++-------- >> 3 files changed, 8 insertions(+), 26 deletions(-) > > I love this kind of "now we have this thing available, let's use it > at more places" clean-up patch. > > Was coccinelle involved in finding these places? Just git grep this time; there were not enough hits for me to consider writing a semantic patch. René