From: tboegi@web.de Date: Thu, 19 May 2016 14:21:15 GMT Subject: [PATCH v5 0/2] CRLF: ce_compare_data() checks for a sha1 of a path Message-ID: <1463667675-25930-1-git-send-email-tboegi@web.de> In-Reply-To: <573A993F.8020205@web.de> From: Torsten Bögershausen Break up the old 10/10 series about CLRF handling into smaller series. This is a small bugfix, when merge.renormalize is used with core.autocrlf (and no attributes are set). Prepare the refactoring to use the streaming interface. Changes since v4: - Rename #define in cache.h into HASH_USE_SHA_NOT_PATH - convert.c: Rename has_cr_in_index into blob_has_cr() Better logic when sha1 != NULL, Adjusted the commit message Torsten Bögershausen (2): read-cache: factor out get_sha1_from_index() helper convert: ce_compare_data() checks for a sha1 of a path cache.h | 4 ++++ convert.c | 34 ++++++++++++++++++++++------------ convert.h | 23 +++++++++++++++++++---- read-cache.c | 33 +++++++++++++++++++++------------ sha1_file.c | 17 +++++++++++++---- 5 files changed, 79 insertions(+), 32 deletions(-) -- 2.0.0.rc1.6318.g0c2c796