From: Pranit Bauva Date: Fri, 06 May 2016 14:49:25 GMT Subject: [PATCH v5 0/2] bisect--helper: rewrite of check-term-format() Message-ID: <1462546167-1125-1-git-send-email-pranit.bauva@gmail.com> In-Reply-To: <1462338472-3581-1-git-send-email-pranit.bauva@gmail.com> A very interesting fact to note: I made a mistake by dropping of the first argument 'term' in the function one_of() and compiled and the test suite passed fully (which was pointed out by Christian). This shows that the test coverage is incomplete. I am currently writing tests to improve on that coverage. It will be included separately. Link to v4: http://thread.gmane.org/gmane.comp.version-control.git/293488 Changes wrt v4: * Stick with 'subcommand' in the commit message. * Rename enum as 'subcommand' to make it singular. * s/bug/BUG/g * Drop _() in the default of switch case * Use some suggestions for commit message no. 2 and also include why I am using subcommand. * Drop of the latter part in the comment of one_of() * Remove flag from check_term_format() * Use return error() instead of die() * Drop '\n' from the localization strings * Include localization for a missed string * A comment in function check_term_format() is re-wrapped to fit in 80 columns * Use 'term' instead of 'ref' * Reword the string in the default of switch case * I have kept the commit message same as previous for commit no. 1 except for addressing the minor nits. Pranit Bauva (2): bisect--helper: use OPT_CMDMODE instead of OPT_BOOL bisect: rewrite `check_term_format` shell function in C builtin/bisect--helper.c | 76 ++++++++++++++++++++++++++++++++++++++++++++---- git-bisect.sh | 31 ++------------------ 2 files changed, 72 insertions(+), 35 deletions(-) -- 2.8.1