From: David Turner Date: Thu, 24 Mar 2016 18:04:55 GMT Subject: Re: [PATCH v7 14/33] refs: add methods to init refs db Message-ID: <1458842695.28595.11.camel@twopensource.com> In-Reply-To: <56F3972C.7020901@alum.mit.edu> On Thu, 2016-03-24 at 08:28 +0100, Michael Haggerty wrote: > > if (shared_repository) { > > adjust_shared_perm(get_git_dir()); > > - adjust_shared_perm(git_path_buf(&buf, "refs")); > > Given that this function is creating the "refs" directory, it seems > like > adjust_shared_perm() should be called for it here, too (rather than > in > the backend-specific code). Good point.