From: larsxschneider@gmail.com Date: Fri, 19 Feb 2016 09:15:58 GMT Subject: [PATCH v6 0/4] config: add '--sources' option to print the source of a config value Message-ID: <1455873362-66998-1-git-send-email-larsxschneider@gmail.com> From: Lars Schneider diff to v5: * rename 'type' to 'origin_type' as 'type' is too broad a word in the context of configuration file (Thanks to the reviewers Junio and Dscho) * add dedicated patch to rename git_config_from_buf to git_config_from_mem (this change was part of the series since v4 as suggested by Junio but hidden in the "config: add 'origin_type'" patch) Thanks, Lars Lars Schneider (4): t: do not hide Git's exit code in tests using 'nul_to_q' rename git_config_from_buf to git_config_from_mem config: add 'origin_type' to config_source struct config: add '--show-origin' option to print the origin of a config value Documentation/git-config.txt | 15 ++-- builtin/config.c | 33 +++++++++ cache.h | 6 +- config.c | 36 +++++++--- submodule-config.c | 4 +- t/t1300-repo-config.sh | 161 ++++++++++++++++++++++++++++++++++++++++++- t/t1308-config-set.sh | 4 +- t/t7008-grep-binary.sh | 3 +- 8 files changed, 236 insertions(+), 26 deletions(-) -- 2.5.1