From: David Turner Date: Wed, 09 Jul 2014 01:18:22 GMT Subject: Re: t5150-request-pull.sh fails on newest master in Debian Message-ID: <1404868702.3775.2.camel@stross> In-Reply-To: On Wed, 2014-07-09 at 02:52 +0200, Øyvind A. Holm wrote: > On 3 July 2014 23:55, Øyvind A. Holm wrote: > > When compiling newest master (v2.0.1-472-g6f92e5f) on Debian 7.5 > > (64-bit), t5150-request-pull.sh fails when compiling with > > > > $ make configure > > $ ./configure --prefix=/usr/local/varprg/git.master.v2.0.1-472-g6f92e5f > > $ make prefix=/usr/local/varprg/git.master.v2.0.1-472-g6f92e5f > > $ cd t > > $ ./t5150-request-pull.sh > > FYI, t5150-request-pull.sh passes all tests now on newest master > (v2.0.1-474-g72c7794) in Debian. There are two new commits on master > since I wrote this, and the commit that makes things work again is > 4602f1a ("diff-tree: call free_commit_list() instead of duplicating > its code"). Reverting this commit brings the failure back. > > The whole thing is still a mystery to me, though. I can't see why this > should have anything to do with the use of ./configure --prefix. The problem only happens when a ref with an allowed wildcard winds up on a page boundary (with the wildcard before the page boundary). This depends intricately on the details of memory allocation, so pretty much anything could make it come and go. Does the fix I posted work for you? If not, let me know and I'll look into it more.