From: Siddharth Asthana Date: Sat, 30 Jul 2022 07:50:49 GMT Subject: Re: [PATCH v6 0/4] Add support for mailmap in cat-file Message-ID: <1396d611-970f-d11a-ac35-3bf7d03469d8@gmail.com> In-Reply-To: On 29/07/22 01:02, Junio C Hamano wrote: > Christian Couder writes: > >> On Mon, Jul 25, 2022 at 8:58 PM Junio C Hamano wrote: >>> Siddharth Asthana writes: >>> >>>> Changes in v6: >>>> - The function rewrite_ident_line() returns the difference between the >>>> new and the old length of the ident line. We were not using this >>>> information and instead parsing the buffer again to look for the line >>>> ending. This patch set starts using that information to update the >>>> buf_offset value in commit_rewrite_person(). >>>> - This patch set also tweaks the commit_rewrite_person() so that it is >>>> easier to understand and avoids unnecessary parsing of the buffer >>>> wherever possible. >>>> >>>> Siddharth Asthana (4): >>>> revision: improve commit_rewrite_person() >>>> ident: move commit_rewrite_person() to ident.c >>>> ident: rename commit_rewrite_person() to apply_mailmap_to_header() >>>> cat-file: add mailmap support >>>> >>>> Documentation/git-cat-file.txt | 6 +++ >>>> builtin/cat-file.c | 43 +++++++++++++++++++- >>>> cache.h | 6 +++ >>>> ident.c | 74 ++++++++++++++++++++++++++++++++++ >>>> revision.c | 50 ++--------------------- >>>> t/t4203-mailmap.sh | 59 +++++++++++++++++++++++++++ >>>> 6 files changed, 190 insertions(+), 48 deletions(-) >>> >>> I haven't seen any comments or objections to this round. Are people >>> happy about it going forward? I am planning to merge it to 'next' >>> and down to 'master' soonish. >> >> I am biased, but I am happy with the current state of this patch >> series. During the last versions of this patch series there were only >> comments related to the first patch in the series (revision: improve >> commit_rewrite_person()). It seems to me that they were all properly >> taken into account, and that the code in that patch is now correct and >> relatively simple to understand. > > Thanks, let's move it forward. Thanks a lot Junio, Phillip, Đoàn, Ævar, Johannes, Christian and John for helping me with the reviews and making this patch better. Thanks a lot for accepting it :)