From: Steffen Prohaska Date: Tue, 30 Oct 2007 08:49:23 GMT Subject: Re: [PATCH 07/10] push: use same rules as git-rev-parse to resolve refspecs Message-ID: <13414001-D708-41E2-A35B-FDBB1103F1AC@zib.de> In-Reply-To: <7v3avtngzc.fsf@gitster.siamese.dyndns.org> On Oct 30, 2007, at 9:28 AM, Junio C Hamano wrote: > Steffen Prohaska writes: > >> This commit changes the rules for resolving refspecs to match the >> rules for resolving refs in rev-parse. git-rev-parse uses clear rules >> to resolve a short ref to its full name, which are well documented. >> The rules for resolving refspecs documented in git-send-pack were >> less strict and harder to understand. This commit replaces them by >> the rules of git-rev-parse. >> >> The unified rules are easier to understand and better resolve >> ambiguous >> cases. You can now push from a repository containing several branches >> ending on the same short name. > > As you introduced long names around 5/10 to have two different > ones for clarity with the goal of unifying them, so once you > unified the rules, it probably is a good idea to rename the long > "do_this_with_X_rule()" and "do_this_with_Y_rule()" functions > back to "do_this()", isn't it? Absolutely. But I'm not sure if I'm the one who unifies them. Steffen