From: Lucian Poston Date: Mon, 16 Apr 2012 10:44:48 GMT Subject: [PATCH v3 0/7] diff stat calculation adjustments Message-ID: <1334573095-32286-1-git-send-email-lucian.poston@gmail.com> I broke the patch series up into smaller patches. Hopefully this makes the intent of the changes easier to follow. Zbigniew's tests were added as PATCH 1/7. The order of the options->stat_graph_width test was reverted back to the original order as per Zbigniew's feedback. There remains an issue where name_width (or graph_width) could be set to a value greater than stat_name_width (or stat_graph_width). This patch doesn't address the issue -- v2 had a partial fix, but it resulted in other problems anyway. Lucian Poston (6): Add output_prefix_length to diff_options Adjust stat width calculations to take --graph output into account t4052: Adjust --graph --stat output for prefixes t4052: Add tests to illustrate issues with restrictive COLUMNS Prevent graph_width of stat width from falling below min t4052: Adjust --stat output for minimum graph_width Zbigniew Jędrzejewski-Szmek (1): t4052: test --stat output with --graph diff.c | 8 ++- diff.h | 1 + graph.c | 3 + t/t4052-stat-output.sh | 122 ++++++++++++++++++++++++++++++++++++++++++++++-- 4 files changed, 128 insertions(+), 6 deletions(-) -- 1.7.3.4