From: Jared Hance Date: Wed, 09 Feb 2011 00:23:45 GMT Subject: [PATCH v3 0/3] Updated patch series for default upstream merge Message-ID: <1297211028-14382-1-git-send-email-jaredhance@gmail.com> In-Reply-To: <1297198129-3403-1-git-send-email-jaredhance@gmail.com> This patch series allows for `git merge` to default to the upstream branch of the current branch. Notes/Complications: - I'm not sure whether the option should be merge.defaultUpstream or merge.defaultToUpstream - Should [remotes] be changed to [branches]? I felt like it was a completely different change and didn't belong in the patch series. - I left one of the ifs with unnecessary braces for clarity because of a nested if-else: is this the preferred style? Jared Hance (3): Add setup_merge_commit function to merge/builtin.c. Add function per_branch_config. Add support for merging from upstream by default. Documentation/config.txt | 6 +++ builtin/merge.c | 87 ++++++++++++++++++++++++++++++++------------- 2 files changed, 68 insertions(+), 25 deletions(-) -- 1.7.4