From: Junio C Hamano Date: Sun, 20 Sep 2009 05:06:10 GMT Subject: [WIP PATCH 1/6] diff-lib.c: fix misleading comments on oneway_diff() Message-ID: <1253423175-6339-2-git-send-email-gitster@pobox.com> In-Reply-To: <1253423175-6339-1-git-send-email-gitster@pobox.com> 20a16eb (unpack_trees(): fix diff-index regression., 2008-03-10) adjusted diff-index to the new world order since 34110cd (Make 'unpack_trees()' have a separate source and destination index, 2008-03-06). Callbacks are expected to return anything non-negative as "success", and instead of reporting how many index entries they have processed, they are expected to advance o->pos themselves. The code did so, but a stale comment was left behind. Signed-off-by: Junio C Hamano --- diff-lib.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/diff-lib.c b/diff-lib.c index 0c74ef5..adf1c5f 100644 --- a/diff-lib.c +++ b/diff-lib.c @@ -383,7 +383,7 @@ static inline void skip_same_name(struct cache_entry *ce, struct unpack_trees_op * For diffing, the index is more important, and we only have a * single tree. * - * We're supposed to return how many index entries we want to skip. + * We're supposed to advance o->pos to skip what we have already processed. * * This wrapper makes it all more readable, and takes care of all * the fairly complex unpack_trees() semantic requirements, including -- 1.6.5.rc1.90.ga3b1b