From: Matthias Kestenholz Date: Tue, 24 Jun 2008 11:21:57 GMT Subject: Re: git-clone works with ssh but not with http/https/git Message-ID: <1214306517.6441.10.camel@localhost> In-Reply-To: On Tue, 2008-06-24 at 14:15 +0300, Erez Zilber wrote: > Hi, > > I'm able to git-clone a tree using ssh: > > [root@kd001 t]# git-clone > ssh://erez.zilber@kites/pub/git/erez.zilber/my_test.git > Initialized empty Git repository in /home/erez.zilber/work/tmp/t/my_test/.git/ > erez.zilber@kites's password: > remote: Counting objects: 9, done. > remote: Compressing objects: 100% (5/5), done. > remote: Total 9 (delta 0), reused 0 (delta 0) > Receiving objects: 100% (9/9), done. > > However, it doesn't work with http/https/git: > > [root@kd001 t]# git-clone http://kites/pub/git/erez.zilber/my_test.git > Initialized empty Git repository in /home/erez.zilber/work/tmp/t/my_test/.git/ > Cannot get remote repository information. > Perhaps git-update-server-info needs to be run there? > Maybe you should run git-update-server-info in the repository on the server? > [root@kd001 t]# git-clone https://kites/pub/git/erez.zilber/my_test.git > Initialized empty Git repository in /home/erez.zilber/work/tmp/t/my_test/.git/ > Cannot get remote repository information. > Perhaps git-update-server-info needs to be run there? Maybe you should run git-update-server-info in the repository on the server? By the way, try enabling the post-update hook -- it runs update-server-info for you automatically after pushing to your server (make the script $GIT_DIR/hooks/post-update executable) > [root@kd001 t]# git-clone git://kites/pub/git/erez.zilber/my_test.git > Initialized empty Git repository in /home/erez.zilber/work/tmp/t/my_test/.git/ > kites[0: 172.16.1.11]: errno=Connection refused > fatal: unable to connect a socket (Connection refused) > fetch-pack from 'git://kites/pub/git/erez.zilber/my_test.git' failed. > Is the git daemon running on your server? You need to configure inetd or git-daemon yourself, that is not done automatically for you. -- http://spinlock.ch/blog/