From: Jeff Hostetler Date: Thu, 06 Oct 2022 16:28:02 GMT Subject: Re: [PATCH 6/9] trace2: convert ctx.thread_name to flex array Message-ID: <0a4e7f45-6697-2b75-005e-676e9ba444ab@jeffhostetler.com> In-Reply-To: <221005.86y1tus9ps.gmgdl@evledraar.gmail.com> On 10/5/22 7:14 AM, Ævar Arnfjörð Bjarmason wrote: > > On Tue, Oct 04 2022, Jeff Hostetler via GitGitGadget wrote: > >> From: Jeff Hostetler >> >> Convert the `tr2tls_thread_ctx.thread_name` field from a `strbuf` >> to a "flex array" at the end of the context structure. >> >> The `thread_name` field is a constant string that is constructed when >> the context is created. Using a (non-const) `strbuf` structure for it >> caused some confusion in the past because it implied that someone >> could rename a thread after it was created. > > I think it's been long enough that we could use a reminder about the > "some confusion", i.e. if it was a bug report or something else. > >> That usage was not intended. Changing it to a "flex array" will >> hopefully make the intent more clear. > > I see we had some back & forth back in the original submission, although > honestly I skimmed this this time around, had forgetten about that, and > had this pop out at me, and then found my earlier comments. > > I see that exchange didn't end as well as I'd hoped[1], and hopefully we > can avoid that here. So having looked at this with fresh eyes maybe > these comments/questions help: Yeah, those conversations went rather poorly. And yes, I'd like to avoid all of that. There's a lot in your note here and it'll take a little while to digest and respond. But I did want to ACK, sooner rather than later, that we agree on that. And yes, I could split out the truncation into a separate commit. And then revisit the storage change. Thanks Jeff