From: Kaartic Sivaraam Date: Wed, 28 Jul 2021 19:51:05 GMT Subject: Re: [GSoC] [PATCH v2] submodule--helper: introduce add-config subcommand Message-ID: <07070c45-5761-b67e-59b1-aa90f8cd877b@gmail.com> In-Reply-To: <20210728115304.80643-1-raykar.ath@gmail.com> Hi Atharva, On 28/07/21 5:23 pm, Atharva Raykar wrote: > Add a new "add-config" subcommand to `git submodule--helper` with the > goal of converting part of the shell code in git-submodule.sh related to > `git submodule add` into C code. This new subcommand sets the > configuration variables of a newly added submodule, by registering the > url in local git config, as well as the submodule name and path in the > .gitmodules file. It also sets 'submodule..active' to "true" if > the submodule path has not already been covered by any pathspec > specified in 'submodule.active'. > > This is meant to be a faithful conversion from shell to C, with only one > minor change: A warning is emitted if no value is specified in > 'submodule.active', ie, the config looks like: "[submodule] active\n", > because it is an invalid configuration. It would be helpful to let the > user know that the pathspec is unset, and the value of > 'submodule..active' might be set to 'true' so that they can > rectify their configuration and prevent future surprises (especially > given that the latter variable has a higher priority than the former). > v2 doesn't have the warning that this paragraph describes. So, this could be dropped. > [ snip ] > > A comment has been > added to explain that only one value of 'submodule.active' is obtained > to check if we need to call is_submodule_active() at all. > This could be me likely not understanding this properly. Anyways, where is this comment in the code? I only see a comment about how 'is_submodule_active' iterates over all values. I couldn't find any "one value" reference in it. > Signed-off-by: Atharva Raykar > Mentored-by: Christian Couder > Mentored-by: Shourya Shukla > Based-on-patch-by: Shourya Shukla > Based-on-patch-by: Prathamesh Chavan > --- > > Changes since v1: > > * Remove the extra handling for the case where submodule.active is valueless, as > Junio pointed out that it is better dealt with in a cleanup patch. > > * Do not discard error returns from 'config_submodule_in_gitmodules()', and also > ensure that any calls to it in 'configure_added_submodule()' die on failure, > like with the original shell porcelain. > > * Style fixes. > > builtin/submodule--helper.c | 120 ++++++++++++++++++++++++++++++++++++ > git-submodule.sh | 28 +-------- > 2 files changed, 121 insertions(+), 27 deletions(-) > > diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c > index 862053c9f2..60b47492cb 100644 > --- a/builtin/submodule--helper.c > +++ b/builtin/submodule--helper.c > @@ -2936,6 +2936,125 @@ static int add_clone(int argc, const char **argv, const char *prefix) > return 0; > } > > +static int config_submodule_in_gitmodules(const char *name, const char *var, const char *value) > +{ > + char *key; > + int ret; > + > + if (!is_writing_gitmodules_ok()) > + die(_("please make sure that the .gitmodules file is in the working tree")); > + > + key = xstrfmt("submodule.%s.%s", name, var); > + ret = config_set_in_gitmodules_file_gently(key, value); > + free(key); > + > + return ret; > +} > + > +static void configure_added_submodule(struct add_data *add_data) > +{ > + char *key; > + char *val = NULL; > + struct child_process add_submod = CHILD_PROCESS_INIT; > + struct child_process add_gitmodules = CHILD_PROCESS_INIT; > + > + key = xstrfmt("submodule.%s.url", add_data->sm_name); > + git_config_set_gently(key, add_data->realrepo); > + free(key); > + > + add_submod.git_cmd = 1; > + strvec_pushl(&add_submod.args, "add", > + "--no-warn-embedded-repo", NULL); > + if (add_data->force) > + strvec_push(&add_submod.args, "--force"); > + strvec_pushl(&add_submod.args, "--", add_data->sm_path, NULL); > + > + if (run_command(&add_submod)) > + die(_("Failed to add submodule '%s'"), add_data->sm_path); > + > + if (config_submodule_in_gitmodules(add_data->sm_name, "path", add_data->sm_path) || > + config_submodule_in_gitmodules(add_data->sm_name, "url", add_data->repo)) > + die(_("Failed to register submodule '%s'"), add_data->sm_path); > + > + if (add_data->branch) > + if (config_submodule_in_gitmodules(add_data->sm_name, > + "branch", add_data->branch)) > + die(_("Failed to register submodule '%s'"), add_data->sm_path); > + > + add_gitmodules.git_cmd = 1; > + strvec_pushl(&add_gitmodules.args, > + "add", "--force", "--", ".gitmodules", NULL); > + > + if (run_command(&add_gitmodules)) > + die(_("Failed to register submodule '%s'"), add_data->sm_path); > + We could restructure this portion like so ... -- 8< -- add_gitmodules.git_cmd = 1; strvec_pushl(&add_gitmodules.args, "add", "--force", "--", ".gitmodules", NULL); if (config_submodule_in_gitmodules(add_data->sm_name, "path", add_data->sm_path) || config_submodule_in_gitmodules(add_data->sm_name, "url", add_data->repo) || (add_data->branch && config_submodule_in_gitmodules(add_data->sm_name, "branch", add_data->branch)) || run_command(&add_gitmodules)) die(_("Failed to register submodule '%s'"), add_data->sm_path); -- >8 -- .. to avoid the redundant "Failed to register submodule ..." error message. Whether the restructured version has poor readability or not is debatable, though. > + /* > + * NEEDSWORK: In a multi-working-tree world this needs to be > + * set in the per-worktree config. > + * It might be a good idea to differentiate the NEEDSWORK comment from an informative comment about the code snippet. Also, you could add another NEEDSWORK/TODO comment regarding the change to 'is_submodule_active' which you mention before[1]. [1]: https://public-inbox.org/git/a6de518a-d4a2-5a2b-28e2-ca8b62f2c85b@gmail.com/ > + * If submodule.active does not exist, or if the pathspec was unset, > + * we will activate this module unconditionally. > + * > + * Otherwise, we ask is_submodule_active(), which iterates > + * through all the values of 'submodule.active' to determine > + * if this module is already active. > + */ > + if (git_config_get_string("submodule.active", &val) || > + !is_submodule_active(the_repository, add_data->sm_path)) { > + key = xstrfmt("submodule.%s.active", add_data->sm_name); > + git_config_set_gently(key, "true"); > + free(key); > + } It might be a good idea to expand this condition similar to the scripted version, to retain the following comment which seems like a useful one to keep. > [ snip ] > > - if git config --get submodule.active >/dev/null > - then > - # If the submodule being adding isn't already covered by the > - # current configured pathspec, set the submodule's active flag > - if ! git submodule--helper is-active "$sm_path" > - then > - git config submodule."$sm_name".active "true" > - fi > - else > - git config submodule."$sm_name".active "true" > - fi > + git submodule--helper add-config ${force:+--force} ${branch:+--branch "$branch"} --url "$repo" --resolved-url "$realrepo" --path "$sm_path" --name "$sm_name" > } > > # > -- Sivaraam