From: Guillaume Galeazzi Date: Fri, 15 May 2020 16:29:52 GMT Subject: Re: [PATCH] submodule--helper.c: add only-active to foreach Message-ID: <037991cd-d6ed-e55a-72ed-f49041460ea2@gmail.com> In-Reply-To: Le 11.05.2020 à 00:42, Eric Sunshine a écrit : > On Sun, May 10, 2020 at 5:53 PM Guillaume Galeazzi > wrote: >>> Yes, maybe renaming the flag to `--is-active` would make it a tad bit >>> simpler? >> is-active sound more like a question to me but I can change it. > > I'm not a submodule user nor have I been following this discussion, > but perhaps the name --active-only would be better? > To flow up on that topic, the flag can be `--[no-]active`. It simplify code and allow the optional negation. On the source, the variable will be renamed active_only.