From: Lucas Werkmeister Date: Sun, 04 Feb 2018 18:58:57 GMT Subject: Re: [PATCH v4] daemon: add --log-destination=(stderr|syslog|none) Message-ID: <0306739c-3fba-2528-f08f-831a31c202b0@lucaswerkmeister.de> In-Reply-To: <871si0mvo0.fsf@evledraar.gmail.com> On 04.02.2018 19:55, Ævar Arnfjörð Bjarmason wrote: > > On Sun, Feb 04 2018, Lucas Werkmeister jotted: > >> [--inetd | >> [--listen=] [--port=] >> [--user= [--group=]]] >> + [--log-destination=(stderr|syslog|none)] > > I micronit, but maybe worthwhile to have a preceeding commit to fix up > that indentation of --listen and --user. I thought the indentation here is intentional, since we’re still inside the [] pair (either --inetd or --listen, --port, …). > >> +--log-destination=:: >> + Send log messages to the specified destination. >> + Note that this option does not imply --verbose, > > Should `` quote --verbose, although I see similar to the WS change I > noted above there's plenty of existing stuff in that doc doing it wrong. I could send a follow-up to consistently ``-quote all options in git-daemon.txt… or would that be rejected as unnecessarily cluttering the history or the `git blame`? >> + } else >> + die("unknown log destination '%s'", v); > > Should be die(_("unknown..., i.e. use the _() macro. > > Anyway, this looks fine to be with our without these proposed > bikeshedding changes above. Thanks. >