From: Wesley Date: Sat, 28 Mar 2026 02:01:16 GMT Subject: Re: [PATCH 1/3] connect: Rename name to command in connect_git() Message-ID: <01ca1166-c3ad-48a9-8edf-be82d380e110@opperschaap.net> In-Reply-To: <20260328014426.GA621762@coredump.intra.peff.net> On 3/27/26 21:44, Jeff King wrote: > On Fri, Mar 27, 2026 at 08:58:22PM -0400, Wesley wrote: > >>> So probably "op" or "type" is a more accurate description. This >>> conceptually ought to be an enum, too, since it is selecting from a >>> limited set of operations we know about. >> >> That's a fair take on it, "name" is really a not the best name for this >> variable. I think "op" covers what you describe here best, it reflects also >> why I named it command. When you check what is sent via ssh, it looks like >> the command: >> >> ssh -o SendEnv=GIT_PROTOCOL git@gitlab.com git-upload-pack >> 'waterkip/git.git' > > Right, but it's necessarily what is sent via ssh. E.g.: > > $ GIT_TRACE=1 git ls-remote example.com:repo.git > [...] > trace: start_command: /usr/bin/ssh -o SendEnv=GIT_PROTOCOL example.com 'git-upload-pack '\''repo.git'\''' > > $ GIT_TRACE=1 git ls-remote --upload-pack=foobar example.com:repo.git > [...] > trace: start_command: /usr/bin/ssh -o SendEnv=GIT_PROTOCOL example.com 'foobar '\''repo.git'\''' > > That's why I think "command" is actively misleading, because between > "prog" and "command" it is not clear which one is going to be sent to > the remote. Ha! Interesting. I see the confusion :) I'm not really sure what to call it. I see the manpage calls it 'exec': --upload-pack= Specify the full path of git-upload-pack on the remote host. This allows listing references from repositories accessed via SSH and where the SSH daemon does not use the PATH configured by the user. and it's the full path of the git-upload-pack command if the remote doesn't use the PATH. So it is command, just.. I'm not sure what to call it. It executable, binary, program, operation, script. I feel they all cover the same concept. remote-command? It could be any of them iyam. Cheers, Wesley -- Wesley Why not both?