{"thread":{"id":"61838","subject":"What's cooking in git.git (Jul 2024, #08; Wed, 24)","startedAt":"2024-07-24T18:01:59Z","lastAt":"2024-07-24T18:01:59Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"499291","messageId":"xmqqfrryu0ru.fsf@gitster.g","threadId":"61838","inReplyTo":null,"subject":"What's cooking in git.git (Jul 2024, #08; Wed, 24)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2024-07-24T18:01:57Z","receivedAt":"2024-07-24T18:01:59Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking in my tree.  Commits\nprefixed with '+' are in 'next' (being in 'next' is a sign that a\ntopic is stable enough to be used and are candidate to be in a\nfuture release).  Commits prefixed with '-' are only in 'seen', and\naren't considered \"accepted\" at all and may be annotated with an URL\nto a message that raises issues but they are no means exhaustive.  A\ntopic without enough support may be discarded after a long period of\nno activity (of course they can be resubmit when new interests\narise).\n\nGit 2.46-rc2 has been tagged.  From now on until the final release,\nwhich is planned to happen near the end of this month, please make\nsure you place priorities on finding and fixing new regressions\nintroduced during this cycle over finding and fixing old bugs, over\nany shiny new features.\n\nCopies of the source code to Git live in many repositories, and the\nfollowing is a list of the ones I push into or their mirrors.  Some\nrepositories have only a subset of branches.\n\nWith maint, master, next, seen, todo:\n\n\tgit://git.kernel.org/pub/scm/git/git.git/\n\tgit://repo.or.cz/alt-git.git/\n\thttps://kernel.googlesource.com/pub/scm/git/git/\n\thttps://github.com/git/git/\n\thttps://gitlab.com/git-scm/git/\n\nWith all the integration branches and topics broken out:\n\n\thttps://github.com/gitster/git/\n\nEven though the preformatted documentation in HTML and man format\nare not sources, they are published in these repositories for\nconvenience (replace \"htmldocs\" with \"manpages\" for the manual\npages):\n\n\tgit://git.kernel.org/pub/scm/git/git-htmldocs.git/\n\thttps://github.com/gitster/git-htmldocs.git/\n\nRelease tarballs are available at:\n\n\thttps://www.kernel.org/pub/software/scm/git/\n\n--------------------------------------------------\n[Graduated to 'master']\n\n* ds/midx-write-repack-fix (2024-07-19) 2 commits\n  (merged to 'next' on 2024-07-22 at 0a64b3ed42)\n + midx-write: revert use of --stdin-packs\n + t5319: add failing test case for repack/expire\n\n Repacking a repository with multi-pack index started making stupid\n pack selections in Git 2.45, which has been corrected.\n source: <pull.1764.git.1721332546.gitgitgadget@gmail.com>\n\n\n* ja/doc-markup-updates-fix (2024-07-20) 1 commit\n  (merged to 'next' on 2024-07-23 at eedc41259a)\n + doc: git-clone fix discrepancy between asciidoc and asciidoctor\n\n Fix documentation mark-up regression in 2.45.\n cf. <xmqqv80w0zrx.fsf@gitster.g>\n source: <pull.1765.git.1721496853517.gitgitgadget@gmail.com>\n\n\n* js/doc-markup-updates-fix (2024-07-23) 2 commits\n  (merged to 'next' on 2024-07-23 at 9a4fa8f9d0)\n + Doc: fix Asciidoctor css workaround\n + asciidoctor: fix `synopsis` rendering\n\n Work around asciidoctor's css that renders `monospace` material\n in the SYNOPSIS section of manual pages as block elements.\n cf. <xmqqv80w0zrx.fsf@gitster.g>\n source: <pull.1749.v2.git.git.1721679949618.gitgitgadget@gmail.com>\n\n\n* ps/ref-storage-migration-fix (2024-07-23) 1 commit\n  (merged to 'next' on 2024-07-23 at ebf4e7c214)\n + refs: fix format migration on Cygwin\n\n Hotfix for a topic already in -rc.\n source: <d031aef5552d894784650a8c6580925e877df794.1721731179.git.ps@pks.im>\n\n--------------------------------------------------\n[New Topics]\n\n* ps/p4-tests-updates (2024-07-23) 3 commits\n - t98xx: mark Perforce tests as memory-leak free\n - ci: update Perforce version to r23.2\n - t98xx: fix Perforce tests with p4d r23 and newer\n\n Perforce tests have been updated.\n\n Needs review.\n source: <cover.1721740612.git.ps@pks.im>\n\n\n* jc/doc-one-shot-export-with-shell-func (2024-07-23) 1 commit\n  (merged to 'next' on 2024-07-23 at 621c29e4f6)\n + CodingGuidelines: document a shell that \"fails\" \"VAR=VAL shell_func\"\n\n It has been documented that we avoid \"VAR=VAL shell_func\" and why.\n\n Will cook in 'next'.\n source: <xmqqwmld55y1.fsf@gitster.g>\n\n--------------------------------------------------\n[Stalled]\n\n* sj/ref-fsck (2024-07-15) 10 commits\n - fsck: add ref content check for files backend\n - fsck: add ref name check for files backend\n - files-backend: add unified interface for refs scanning\n - builtin/fsck: add `git-refs verify` child process\n - git refs: add verify subcommand\n - refs: set up ref consistency check infrastructure\n - fsck: add refs-related error report function\n - fsck: rename objects-related fsck error functions\n - fsck: add a unified interface for reporting fsck messages\n - fsck: rename \"skiplist\" to \"skip_oids\"\n\n \"git fsck\" infrastructure has been taught to also check the sanity\n of the ref database, in addition to the object database.\n\n Needs review.\n source: <ZpPEdmUN1Z5tqbK3@ArchLinux>\n\n\n* cp/unit-test-reftable-pq (2024-07-23) 7 commits\n - t-reftable-pq: add tests for merged_iter_pqueue_top()\n - t-reftable-pq: add test for index based comparison\n - t-reftable-pq: make merged_iter_pqueue_check() callable by reference\n - t-reftable-pq: make merged_iter_pqueue_check() static\n - t: move reftable/pq_test.c to the unit testing framework\n - reftable: change the type of array indices to 'size_t' in reftable/pq.c\n - reftable: remove unncessary curly braces in reftable/pq.c\n\n The tests for \"pq\" part of reftable library got rewritten to use\n the unit test framework.\n\n Needs review.\n source: <20240723143032.4261-1-chandrapratap3519@gmail.com>\n\n\n* tb/incremental-midx-part-1 (2024-07-17) 19 commits\n - midx: implement support for writing incremental MIDX chains\n - t/t5313-pack-bounds-checks.sh: prepare for sub-directories\n - t: retire 'GIT_TEST_MULTI_PACK_INDEX_WRITE_BITMAP'\n - midx: implement verification support for incremental MIDXs\n - midx: support reading incremental MIDX chains\n - midx: teach `midx_fanout_add_midx_fanout()` about incremental MIDXs\n - midx: teach `midx_preferred_pack()` about incremental MIDXs\n - midx: teach `midx_contains_pack()` about incremental MIDXs\n - midx: remove unused `midx_locate_pack()`\n - midx: teach `fill_midx_entry()` about incremental MIDXs\n - midx: teach `nth_midxed_offset()` about incremental MIDXs\n - midx: teach `bsearch_midx()` about incremental MIDXs\n - midx: introduce `bsearch_one_midx()`\n - midx: teach `nth_bitmapped_pack()` about incremental MIDXs\n - midx: teach `nth_midxed_object_oid()` about incremental MIDXs\n - midx: teach `prepare_midx_pack()` about incremental MIDXs\n - midx: teach `nth_midxed_pack_int_id()` about incremental MIDXs\n - midx: add new fields for incremental MIDX chains\n - Documentation: describe incremental MIDX format\n\n Incremental updates of multi-pack index files.\n\n Needs review.\n source: <cover.1721250704.git.me@ttaylorr.com>\n\n\n* pp/add-parse-range-unit-test (2024-05-27) 1 commit\n - apply: add unit tests for parse_range\n\n A unit test for code that parses the hunk offset and length from a\n patch fragment header as been added.\n\n Expecting a reroll.\n cf. <b7eca313-9ea8-4132-ba1d-ed9236e07095@gmail.com>\n source: <pull.1677.v2.git.git.1716710073910.gitgitgadget@gmail.com>\n\n\n* cw/git-std-lib (2024-02-28) 4 commits\n . SQUASH??? get rid of apparent debugging crufts\n . test-stdlib: show that git-std-lib is independent\n . git-std-lib: introduce Git Standard Library\n . pager: include stdint.h because uintmax_t is used\n\n Split libgit.a out to a separate git-std-lib tor easier reuse.\n\n Expecting a reroll.\n source: <cover.1696021277.git.jonathantanmy@google.com>\n\n--------------------------------------------------\n[Cooking]\n\n* ag/git-svn-global-ignores (2024-07-18) 2 commits\n - git-svn: use `svn:global-ignores` to create .gitignore\n - git-svn: add public property `svn:global-ignores`\n\n \"git svn\" has been taught about svn:global-ignores property\n recent versions of Subversion has.\n\n Needs review.\n source: <pull.1747.v2.git.git.1721335657.gitgitgadget@gmail.com>\n\n\n* jc/how-to-maintain-updates (2024-07-19) 2 commits\n - howto-maintain: update daily tasks\n - howto-maintain: cover a whole development cycle\n\n Doc update.\n\n Will merge to 'next'?\n source: <xmqq1q3phzpi.fsf@gitster.g>\n\n\n* es/shell-check-updates (2024-07-22) 4 commits\n - check-non-portable-shell: suggest alternative for `VAR=val shell-func`\n - check-non-portable-shell: improve `VAR=val shell-func` detection\n - t4034: fix use of one-shot variable assignment with shell function\n - t3430: modernize one-shot \"VAR=val shell-func\" invocation\n\n Test script linter has been updated to catch an attempt to use\n one-shot export construct \"VAR=VAL func\" for shell functions (which\n does not work for some shells) better.\n\n Will merge to 'next'?\n source: <20240722065915.80760-1-ericsunshine@charter.net>\n\n\n* jc/safe-directory (2024-07-22) 3 commits\n - safe.directory: setting safe.directory=\".\" allows the \"current\" directory\n - safe.directory: normalize the configured path\n - safe.directory: normalize the checked path\n\n Follow-up on 2.45.1 regression fix.\n\n Needs review.\n source: <20240723021900.388020-1-gitster@pobox.com>\n\n\n* pw/add-patch-with-suppress-blank-empty (2024-07-20) 2 commits\n  (merged to 'next' on 2024-07-22 at 5437b7dee3)\n + add-patch: use normalize_marker() when recounting edited hunk\n + add-patch: handle splitting hunks with diff.suppressBlankEmpty\n\n \"git add -p\" by users with diff.suppressBlankEmpty set to true\n failed to parse the patch that represents an unmodified empty line\n with an empty line (not a line with a single space on it), which\n has been corrected.\n\n Will cook in 'next'.\n source: <pull.1763.v2.git.1721491320.gitgitgadget@gmail.com>\n\n\n* tn/doc-commit-fix (2024-07-22) 1 commit\n  (merged to 'next' on 2024-07-23 at eb73e04ee4)\n + doc: remove dangling closing parenthesis\n\n Docfix.\n\n Will cook in 'next'.\n source: <20240722225302.124356-1-tomasn@posteo.net>\n\n\n* cp/unit-test-reftable-tree (2024-07-22) 5 commits\n - t-reftable-tree: improve the test for infix_walk()\n - t-reftable-tree: add test for non-existent key\n - t-reftable-tree: split test_tree() into two sub-test functions\n - t: move reftable/tree_test.c to the unit testing framework\n - reftable: remove unnecessary curly braces in reftable/tree.c\n\n A test in reftable library has been rewritten using the unit test\n framework.\n\n Needs review.\n source: <20240722061836.4176-1-chandrapratap3519@gmail.com>\n\n\n* rj/make-cleanup (2024-07-18) 2 commits\n  (merged to 'next' on 2024-07-22 at bf3991f70f)\n + config.mak.uname: remove unused uname_P variable\n + Makefile: drop -Wno-universal-initializer from SP_EXTRA_FLAGS\n\n A build tweak knob has been simplified by not setting the value\n that is already the default; another unused one has been removed.\n\n Will cook in 'next'.\n source: <0d132370-3e07-4332-bcfb-c4450100d736@ramsayjones.plus.com>\n\n\n* ew/cat-file-optim (2024-07-15) 10 commits\n - cat-file: use writev(2) if available\n - cat-file: batch_write: use size_t for length\n - cat-file: batch-command uses content_limit\n - object_info: content_limit only applies to blobs\n - packfile: packed_object_info avoids packed_to_object_type\n - cat-file: use delta_base_cache entries directly\n - packfile: inline cache_or_unpack_entry\n - packfile: fix off-by-one in content_limit comparison\n - packfile: allow content-limit for cat-file\n - packfile: move sizep computation\n\n \"git cat-file --batch\" has been optimized.\n\n Needs review.\n source: <20240715003519.2671385-1-e@80x24.org>\n\n\n* jc/document-use-of-local (2024-07-15) 1 commit\n - doc: note that AT&T ksh does not work with our test suite\n\n Doc update.\n\n Needs review.\n source: <xmqq1q3u8zmr.fsf@gitster.g>\n\n\n* jt/doc-post-receive-hook-update (2024-07-15) 1 commit\n  (merged to 'next' on 2024-07-17 at 624ac4ebe2)\n + doc: clarify post-receive hook behavior\n\n Doc update.\n\n Will cook in 'next'.\n source: <20240715183739.7808-1-jltobler@gmail.com>\n\n\n* jc/reflog-expire-lookup-commit-fix (2024-07-16) 1 commit\n - Revert \"reflog expire: don't use lookup_commit_reference_gently()\"\n\n \"git reflog expire\" failed to honor annotated tags when computing\n reachable commits.\n\n Needs review.\n source: <xmqqv8156rh2.fsf@gitster.g>\n\n\n* es/doc-platform-support-policy (2024-07-18) 2 commits\n - SQUASH???\n - Documentation: add platform support policy\n\n A policy document that describes platform support levels and\n expectation on platform stakeholders has been introduced.\n source: <20240718173843.2411415-1-emilyshaffer@google.com>\n\n\n* kn/ci-clang-format (2024-07-23) 6 commits\n  (merged to 'next' on 2024-07-23 at 3aca45d08a)\n + ci/style-check: add `RemoveBracesLLVM` in CI job\n + check-whitespace: detect if no base_commit is provided\n + ci: run style check on GitHub and GitLab\n + clang-format: formalize some of the spacing rules\n + clang-format: avoid spacing around bitfield colon\n + clang-format: indent preprocessor directives after hash\n\n A CI job that use clang-format to check coding style issues in new\n code has been added.\n\n Will cook in 'next'.\n source: <20240723082111.874382-1-karthik.188@gmail.com>\n\n\n* rj/add-p-pager (2024-07-22) 6 commits\n - pager: make wait_for_pager a no-op for \"cat\"\n - t3701: avoid one-shot export for shell functions\n - add-patch: render hunks through the pager\n - pager: introduce wait_for_pager\n - pager: do not close fd 2 unnecessarily\n - add-patch: test for 'p' command\n\n A 'P' command to \"git add -p\" that passes the patch hunk to the\n pager has been added.\n source: <efa98aec-f117-4cfe-a7c2-e8c0adbdb399@gmail.com>\n source: <c37f0d54-4ead-422c-8193-f0c2ec84ca4a@gmail.com>\n source: <5536b336-5122-47fd-be57-42c299abe60c@gmail.com>\n\n\n* ad/merge-with-diff-algorithm (2024-07-13) 1 commit\n  (merged to 'next' on 2024-07-16 at 90fe5aff4d)\n + merge-recursive: honor diff.algorithm\n\n Many Porcelain commands that internally use the merge machinery\n were taught to consistently honor the diff.algorithm configuration.\n\n Will cook in 'next'.\n source: <pull.1743.v3.git.git.1720889507066.gitgitgadget@gmail.com>\n\n\n* jc/checkout-no-op-switch-errors (2024-07-02) 1 commit\n  (merged to 'next' on 2024-07-22 at 9573259db9)\n + checkout: special case error messages during noop switching\n\n \"git checkout --ours\" (no other arguments) complained that the\n option is incompatible with branch switching, which is technically\n correct, but found confusing by some users.  It now says that the\n user needs to give pathspec to specify what paths to checkout.\n\n Will cook in 'next'.\n source: <xmqqikxnqzz4.fsf@gitster.g>\n\n\n* cp/unit-test-reftable-merged (2024-07-12) 7 commits\n  (merged to 'next' on 2024-07-23 at 88d2a9ee28)\n + t-reftable-merged: add test for REFTABLE_FORMAT_ERROR\n + t-reftable-merged: use reftable_ref_record_equal to compare ref records\n + t-reftable-merged: add tests for reftable_merged_table_max_update_index\n + t-reftable-merged: improve the const-correctness of helper functions\n + t-reftable-merged: improve the test t_merged_single_record()\n + t: harmonize t-reftable-merged.c with coding guidelines\n + t: move reftable/merged_test.c to the unit testing framework\n\n Another reftable test has been ported to use the unit test framework.\n\n Will cook in 'next'.\n source: <20240712055041.6476-1-chandrapratap3519@gmail.com>\n\n\n* rs/t-strvec-use-test-msg (2024-07-16) 3 commits\n  (merged to 'next' on 2024-07-16 at 3e860b3f12)\n + t-strvec: fix type mismatch in check_strvec\n  (merged to 'next' on 2024-07-15 at f26e434515)\n + t-strvec: improve check_strvec() output\n  (merged to 'next' on 2024-07-08 at c28c2553de)\n + t-strvec: use test_msg()\n\n Unit test clean-up.\n\n Will cook in 'next'.\n source: <35b0ba6b-d485-44f2-a19f-3ce816f8b435@web.de>\n source: <983be396-f47c-4573-8c33-af8367f8ddbe@web.de>\n source: <1521ed89-989e-452b-b7fc-9e73672e0764@web.de>\n\n\n* gt/unit-test-hashmap (2024-07-12) 1 commit\n - t: port helper/test-hashmap.c to unit-tests/t-hashmap.c\n\n An existing test of hashmap API has been rewritten with the\n unit-test framework.\n\n What's the doneness of this one?\n source: <20240711235159.5320-1-shyamthakkar001@gmail.com>\n\n\n* rs/unit-tests-test-run (2024-07-23) 7 commits\n - unit-tests: show location of checks outside of tests\n - t-strbuf: use for_test\n - t-strvec: use for_test\n - t-reftable-basics: use for_test\n - t-ctype: use for_test\n - unit-tests: add for_test\n - t0080: move expected output to a file\n\n Unit-test framework clean-up.\n\n Still under discussion.\n source: <da7ed537-1c8e-42ec-aa91-49e1319e8c68@web.de>\n\n\n* jc/patch-id (2024-06-21) 5 commits\n - patch-id: tighten code to detect the patch header\n - patch-id: rewrite code that detects the beginning of a patch\n - patch-id: make get_one_patchid() more extensible\n - patch-id: call flush_current_id() only when needed\n - t4204: patch-id supports various input format\n\n The patch parser in \"git patch-id\" has been tightened to avoid\n getting confused by lines that look like a patch header in the log\n message.\n\n Needs review.\n source: <20240621231826.3280338-1-gitster@pobox.com>\n\n--------------------------------------------------\n[Discarded]\n\n* jk/add-patch-with-suppress-blank-empty (2024-07-10) 1 commit\n  (merged to 'next' on 2024-07-11 at cec8ebb668)\n + add-patch: handle splitting hunks with diff.suppressBlankEmpty\n\n When the diff.suppressBlankEmpty configuration variable is set,\n \"git add -p\" failed to process a patch with an unmodified empty\n line, which has been corrected.\n\n Reverted out of 'next'.\n source: <20240710093610.GA2076910@coredump.intra.peff.net>\n"}]}