{"thread":{"id":"6110","subject":"What's in git.git (stable) and announcing GIT 1.5.0 preview","startedAt":"2006-12-26T03:22:04Z","lastAt":"2006-12-29T05:44:25Z","messageCount":5,"participants":["Junio C Hamano","Jakub Narebski","Robert Fitzsimons"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"30288","messageId":"7v3b73gx43.fsf@assigned-by-dhcp.cox.net","threadId":"6110","inReplyTo":null,"subject":"What's in git.git (stable) and announcing GIT 1.5.0 preview","fromName":"Junio C Hamano","fromEmail":"junkio@cox.net","sentAt":"2006-12-26T03:22:04Z","receivedAt":"2006-12-26T03:22:04Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"GIT v1.5.0 preview\n\nThis is not yet -rc1 where all new topics close, but I think it\nis getting pretty closer.  I'd still want to merge updates to\nfsck/prune to honor reflog entries before -rc1.\n\nI think there are quite a lot of documentation updates remaining\nafter that.  There is no patch for \"fixed HEAD\" yet, and while I\nwould not object people to try to get it working in time, it is\npurely a feature enhancement and does not have backward\ncompatibility issues, so it does not have to block v1.5.0; it\ncan wait for later releases.  So is sliding mmap().\n\n\n* The 'master' branch has these since the last announcement.\n\n   Alexandre Julliard (1):\n      vc-git: Ignore errors caused by a non-existent directory\n          in vc-git-registered.\n\n   Brian Gernhardt (2):\n      Keep \"git --git-dir\" from causing a bus error.\n      Make git-show-branch options similar to git-branch.\n\n   Eric Wong (3):\n      Remove NO_ACCURATE_DIFF options from build systems\n      git-svn: enable common fetch/commit options for dcommit\n      Makefile: add quick-install-doc for installing pre-built manpages\n\n   Johannes Schindelin (4):\n      move read_mmfile() into xdiff-interface\n      Add a test for git-rerere\n      Make git-rerere a builtin\n      commit-tree: encourage UTF-8 commit messages.\n\n   Junio C Hamano (19):\n      git-add --interactive\n      git-add --interactive: hunk splitting\n      revision: --skip=<n>\n      merge and reset: adjust for \"reset --hard\" messages\n      default pull: forget about \"newbie protection\" for now.\n      Do not support \"partial URL shorthand\" anymore.\n      Really fix headers for __FreeBSD__\n      git-tag: lose exit after die\n      Allow branch.*.merge to talk about remote tracking branches.\n      git-add --interactive: add documentation\n      match_pathspec() -- return how well the spec matched\n      git-rm: update to saner semantics\n      t3600: update the test for updated git rm\n      git-rm: Documentation\n      read_directory: show_both option.\n      git-add: add ignored files when asked explicitly.\n      git-add: warn when adding an ignored file with an explicit request.\n      git-add -f: allow adding otherwise ignored files.\n      GIT v1.5.0 preview\n\n   Nicolas Pitre (1):\n      checkout: make the message about the need for a new branch a bit clearer\n\n   Robert Fitzsimons (16):\n      gitweb: Add missing show '...' links change.\n      gitweb: optimize git_get_last_activity.\n      gitweb: optimize git_shortlog_body.\n      gitweb: optimize git_summary.\n      gitweb: Use rev-list pattern search options.\n      gitweb: Require a minimum of two character for the search text.\n      gitweb: Allow search to be disabled from the config file.\n      gitweb: Paginate commit/author/committer search output\n      gitweb: Add parse_commits, used to bulk load commit objects.\n      gitweb: We do longer need the --parents flag in rev-list.\n      gitweb: Change summary, shortlog actions to use parse_commits.\n      gitweb: Change log action to use parse_commits.\n      gitweb: Change header search action to use parse_commits.\n      gitweb: Change atom, rss actions to use parse_commits.\n      gitweb: Change history action to use parse_commits.\n      gitweb: Use rev-list --skip option.\n\n   Shawn Pearce (4):\n      Use extended SHA1 syntax in merge-recursive conflicts.\n      Display 'theirs' branch name when possible in merge.\n      Rename gitfakemmap to git_mmap.\n      Switch git_mmap to use pread.\n"},{"id":"30297","messageId":"emr01i$hcb$1@sea.gmane.org","threadId":"6110","inReplyTo":"7v3b73gx43.fsf@assigned-by-dhcp.cox.net","subject":"Re: What's in git.git (stable) and announcing GIT 1.5.0 preview","fromName":"Jakub Narebski","fromEmail":"jnareb@gmail.com","sentAt":"2006-12-26T11:14:36Z","receivedAt":"2006-12-26T11:14:36Z","isPatch":false,"sender":{"key":"jnareb@gmail.com","avatar":"https://avatars.githubusercontent.com/u/2706?v=4"},"body":"Junio C Hamano wrote:\n\n>    Robert Fitzsimons (16):\n[...]\n>       gitweb: Allow search to be disabled from the config file.\n\nHmmmm... IIRC this did not removed the search form. Besides it is not like\nthe basic search is expensive...\n-- \nJakub Narebski\nWarsaw, Poland\nShadeHawk on #git\n"},{"id":"30300","messageId":"20061226132204.GB6558@localhost","threadId":"6110","inReplyTo":"emr01i$hcb$1@sea.gmane.org","subject":"Re: What's in git.git (stable) and announcing GIT 1.5.0 preview","fromName":"Robert Fitzsimons","fromEmail":"robfitz@273k.net","sentAt":"2006-12-26T13:22:04Z","receivedAt":"2006-12-26T13:22:04Z","isPatch":false,"sender":{"key":"robfitz@273k.net","avatar":null},"body":"> >       gitweb: Allow search to be disabled from the config file.\n> \n> Hmmmm... IIRC this did not removed the search form. Besides it is not like\n> the basic search is expensive...\n\nI just double checked.  The search feature is enabled by default, when\nthe feature is disable the search form isn't shown.\n\nI don't mind if this change is reverted.\n\nRobert\n"},{"id":"30307","messageId":"200612262002.08862.jnareb@gmail.com","threadId":"6110","inReplyTo":"20061226132204.GB6558@localhost","subject":"Re: What's in git.git (stable) and announcing GIT 1.5.0 preview","fromName":"Jakub Narebski","fromEmail":"jnareb@gmail.com","sentAt":"2006-12-26T19:02:08Z","receivedAt":"2006-12-26T19:02:08Z","isPatch":false,"sender":{"key":"jnareb@gmail.com","avatar":"https://avatars.githubusercontent.com/u/2706?v=4"},"body":"Robert Fitzsimons wrote:\n>>>       gitweb: Allow search to be disabled from the config file.\n>> \n>> Hmmmm... IIRC this did not removed the search form. Besides it is not like\n>> the basic search is expensive...\n> \n> I just double checked.  The search feature is enabled by default, when\n> the feature is disable the search form isn't shown.\n> \n> I don't mind if this change is reverted.\n\nI'm sorry. My mistake. And it is turned on by default, and not overridable\nby default (checking overridable feature is one call to git-repo-config,\nat least now), and I have nothing against this feature.\n\n-- \nJakub Narebski\nPoland\n"},{"id":"30464","messageId":"7vvejvp87a.fsf@assigned-by-dhcp.cox.net","threadId":"6110","inReplyTo":"7v3b73gx43.fsf@assigned-by-dhcp.cox.net","subject":"What's in git.git (stable)","fromName":"Junio C Hamano","fromEmail":"junkio@cox.net","sentAt":"2006-12-29T05:44:25Z","receivedAt":"2006-12-29T05:44:25Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"I've merged a handful topics since v1.5.0-rc0.\n\n - reflog is now integral part of the data tracked by git, as\n   far as local repository is concerned.  You do not have to end\n   your sentence with \"... but only if you haven't pruned\" when\n   you tell your users \"don't worry, you can get it back with\n   master@{2.hours.ago}\" anymore.\n\n - a single command \"git gc\" would help your repository\n   housekeeping chores.\n\n - shallow-clone capable upload-pack/fetch-pack pair is in.\n   Although I think the way they cauterize the ancestry graph\n   during the want-have exchange is basically sound, I haven't\n   used it extensively and suspect not many people have.  The\n   additional code, however, does not seem to harm the normal,\n   non-shallow operation in any way; this is to give them wider\n   exposure.\n\n - recording the commit encoding in the new \"encoding\" header\n   and using it together with i18n.{logoutput,commit}encoding\n   upon output is also in.  I think Nico's suggestion to use\n   LANG also makes sense (perhaps with LC_CTYPE), but haven't\n   done that myself yet.\n\n - git-svn got a handful improvements.\n\n - segfaulting bug in xdl_merge was fixed.\n\nI'm waiting for ack's to my workaround for http-fetch breakage\nwhen built with cURL 7.16.0, which I would like to resolve\nbefore v1.5.0-rc1.  Also I have a reproducible problem which I\nsuspect is with Shawn's sliding mmap(), and am hoping we can\nship the sliding mmap() as part of the v1.5.0 after resolving\nit.\n\n----------------------------------------------------------------\n* The 'master' branch has these since the last announcement.\n\n   Alexandre Julliard (6):\n      Shallow clone: do not ignore shallowness when following tags\n      fetch-pack: Properly remove the shallow file when it becomes empty.\n      upload-pack: Check for NOT_SHALLOW flag before sending a shallow to\n        the client.\n      git-fetch: Reset shallow_depth before auto-following tags.\n      get_shallow_commits: Avoid memory leak if a commit has been reached\n\talready.\n      fetch-pack: Do not fetch tags for shallow clones.\n\n   Andy Parkins (1):\n      hooks/commit-msg: add example to add Signed-off-by line to message\n\n   Eric Wong (9):\n      git-svn: quiet down tests and fix some unportable shell constructs\n      git-svn: dcommit should diff against the current HEAD after committing\n      t6024-recursive-merge: quiet down this test\n      test-lib: quiet down init-db output for tests\n      t9200-git-cvsexportcommit.sh: quiet down commit\n      git-svn: remove non-delta fetch code paths\n      git-svn: print out the SVN library version in --version, too\n      git-svn: verify_ref() should actually --verify\n      git-svn: sort multi-init output\n\n   Jakub Narebski (2):\n      gitweb: Add mod_perl version string to \"generator\" meta header\n      gitweb: Precompile CGI routines for mod_perl\n\n   Jim Meyering (1):\n      update hook: redirect _both_ diagnostic lines to stderr upon tag failure\n\n   Johannes Schindelin (6):\n      upload-pack: no longer call rev-list\n      support fetching into a shallow repository\n      allow cloning a repository \"shallowly\"\n      allow deepening of a shallow repository\n      add tests for shallow stuff\n      xdl_merge(): fix a segmentation fault when refining conflicts\n\n   Junio C Hamano (32):\n      We should make sure that the protocol is still extensible.\n      Why does it mean we do not have to register shallow if we have one?\n      Why didn't we mark want_obj as ~UNINTERESTING in the old code?\n      shallow clone: unparse and reparse an unshallowed commit\n      add for_each_reflog_ent() iterator\n      Protect commits recorded in reflog from pruning.\n      Teach git-repack to preserve objects referred to by reflog entries.\n      reflog: fix warning message.\n      Move in_merge_bases() to commit.c\n      git reflog expire\n      reflog expire: prune commits that are not incomplete\n      reflog expire: do not punt on tags that point at non commits.\n      show-branch --reflog: add documentation.\n      Document --numstat in git-apply and git-diff\n      Document git-reset <commit> -- <paths>...\n      Move encoding conversion routine out of mailinfo to utf8.c\n      i18n.logToUTF8: convert commit log message to UTF-8\n      Teach log family --encoding\n      everyday: update for v1.5.0\n      count-objects -v: show number of packs as well.\n      rerere gc: honor configuration and document it\n      git-reflog: gc.* configuration and documentation.\n      everyday: replace a few 'prune' and 'repack' with 'gc'\n      Use 'repack -a -d -l' instead of 'repack -a -d' in git-gc\n      Set NO_MMAP for Cygwin by default\n      UTF-8: introduce i18n.logoutputencoding.\n      gcc does not necessarily pass runtime libpath with -R\n      Rename t3900 test vector file\n      t3900: test conversion to non UTF-8 as well\n      GIT_SKIP_TESTS: allow users to omit tests that are known to break\n      core.logallrefupdates: log remotes/ tracking branches.\n      Allow non-fast-forward of remote tracking branches in default clone\n\n   Nicolas Pitre (3):\n      add .mailmap for git-shortlog output with the git repository\n      Add git-reflog to .gitignore\n      move git-blame to its place in .gitignore\n\n   Quy Tonthat (1):\n      git-send-email: default value for \"From:\" field.\n\n   Robert Fitzsimons (1):\n      gitweb: Re-enable rev-list --parents for parse_commit.\n\n   Shawn O. Pearce (8):\n      Don't crash during repack of a reflog with pruned commits.\n      Create 'git gc' to perform common maintenance operations.\n      Use GIT_REFLOG_ACTION environment variable instead.\n      Honor GIT_REFLOG_ACTION in git-rebase.\n      Use branch names in 'git-rebase -m' conflict hunks.\n      Ensure `git-pull` fails if `git-merge` fails.\n      Honor pull.{twohead,octopus} in git-merge.\n      Allow git-merge to select the default strategy.\n"}]}