{"thread":{"id":"59674","subject":"[PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file","startedAt":"2023-04-30T10:00:45Z","lastAt":"2023-05-01T15:24:39Z","messageCount":3,"participants":["Oswald Buddenhagen","Junio C Hamano"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"476318","messageId":"20230430100034.1889796-1-oswald.buddenhagen@gmx.de","threadId":"59674","inReplyTo":null,"subject":"[PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file","fromName":"Oswald Buddenhagen","fromEmail":"oswald.buddenhagen@gmx.de","sentAt":"2023-04-30T10:00:34Z","receivedAt":"2023-04-30T10:00:45Z","isPatch":true,"sender":{"key":"oswald.buddenhagen@gmx.de","avatar":"https://avatars.githubusercontent.com/u/812380?v=4"},"body":"The file started out as a test for picks and reverts with renames, but\nhas been subsequently populated will all kinds of basic tests, in\naccordance with its generic name. Adjust the description to reflect\nthat.\n\nSigned-off-by: Oswald Buddenhagen <oswald.buddenhagen@gmx.de>\n---\nCc: Junio C Hamano <gitster@pobox.com>\n---\n t/t3501-revert-cherry-pick.sh | 18 +++++++++---------\n 1 file changed, 9 insertions(+), 9 deletions(-)\n\ndiff --git a/t/t3501-revert-cherry-pick.sh b/t/t3501-revert-cherry-pick.sh\nindex 2f3e3e2416..e2ef619323 100755\n--- a/t/t3501-revert-cherry-pick.sh\n+++ b/t/t3501-revert-cherry-pick.sh\n@@ -1,14 +1,6 @@\n #!/bin/sh\n \n-test_description='test cherry-pick and revert with renames\n-\n-  --\n-   + rename2: renames oops to opos\n-  +  rename1: renames oops to spoo\n-  +  added:   adds extra line to oops\n-  ++ initial: has lines in oops\n-\n-'\n+test_description='miscellaneous basic tests for cherry-pick and revert'\n \n GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME=main\n export GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME\n@@ -63,6 +55,14 @@ test_expect_success 'revert --nonsense' '\n \ttest_i18ngrep \"[Uu]sage:\" msg\n '\n \n+# the following two test cherry-pick and revert with renames\n+#\n+# --\n+#  + rename2: renames oops to opos\n+# +  rename1: renames oops to spoo\n+# +  added:   adds extra line to oops\n+# ++ initial: has lines in oops\n+\n test_expect_success 'cherry-pick after renaming branch' '\n \n \tgit checkout rename2 &&\n-- \n2.40.0.152.g15d061e6df\n\n"},{"id":"476319","messageId":"ZE5WiFr7ChhymlOe@ugly","threadId":"59674","inReplyTo":"20230430100034.1889796-1-oswald.buddenhagen@gmx.de","subject":"Re: [PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file","fromName":"Oswald Buddenhagen","fromEmail":"oswald.buddenhagen@gmx.de","sentAt":"2023-04-30T11:52:40Z","receivedAt":"2023-04-30T11:59:30Z","isPatch":true,"sender":{"key":"oswald.buddenhagen@gmx.de","avatar":"https://avatars.githubusercontent.com/u/812380?v=4"},"body":"On Sun, Apr 30, 2023 at 12:00:34PM +0200, Oswald Buddenhagen wrote:\n>The file started out as a test for picks and reverts with renames, but\n>has been subsequently populated will all kinds of basic tests, in\n\t\t\t\t ^^^^\n\t\t\t\t \"with\", obviously.\n\n>accordance with its generic name. Adjust the description to reflect\n>that.\n>\n"},{"id":"476337","messageId":"xmqqa5yo847q.fsf@gitster.g","threadId":"59674","inReplyTo":"20230430100034.1889796-1-oswald.buddenhagen@gmx.de","subject":"Re: [PATCH] t/t3501-revert-cherry-pick.sh: clarify scope of the file","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2023-05-01T15:24:25Z","receivedAt":"2023-05-01T15:24:39Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Oswald Buddenhagen <oswald.buddenhagen@gmx.de> writes:\n\n> The file started out as a test for picks and reverts with renames, but\n> has been subsequently populated will all kinds of basic tests, in\n> accordance with its generic name. Adjust the description to reflect\n> that.\n>\n> Signed-off-by: Oswald Buddenhagen <oswald.buddenhagen@gmx.de>\n> ---\n\n> -test_description='test cherry-pick and revert with renames\n> ...\n> +test_description='miscellaneous basic tests for cherry-pick and revert'\n\nLooks good.\n\nWill queue.\n\nThanks.\n"}]}