{"thread":{"id":"56415","subject":"UX suggestion","startedAt":"2021-08-31T13:46:59Z","lastAt":"2021-09-02T17:27:56Z","messageCount":8,"participants":["Jan Judas","Ævar Arnfjörð Bjarmason","Eric Sunshine","Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"434279","messageId":"CAO=eiXzPaRpEV_nsudvvCUbNab+oMxR8b9rsehjdyc4WMHe3OA@mail.gmail.com","threadId":"56415","inReplyTo":null,"subject":"UX suggestion","fromName":"Jan Judas","fromEmail":"snugar.i@gmail.com","sentAt":"2021-08-31T13:46:43Z","receivedAt":"2021-08-31T13:46:59Z","isPatch":false,"sender":{"key":"snugar.i@gmail.com","avatar":null},"body":"Hello,\n\nfirst time posting here, I hope I'm doing it right.\nI'd like to suggest a very minor UX improvement regarding the message:\n\nerror: The last gc run reported the following. Please correct the root cause\nand remove /path/to/repo/.git/gc.log.\n\nCurrently, there is a dot after the file path, so it's impossible to\nselect just the path using double-click. If the dot was removed, or\nseparated from the path by a space, it would be slightly more\nconvenient :-)\n\nThank you\n\nJan Judas\n"},{"id":"434287","messageId":"patch-1.1-27f00a664e6-20210831T143536Z-avarab@gmail.com","threadId":"56415","inReplyTo":"CAO=eiXzPaRpEV_nsudvvCUbNab+oMxR8b9rsehjdyc4WMHe3OA@mail.gmail.com","subject":"[PATCH] gc: remove trailing dot from \"gc.log\" line","fromName":"Ævar Arnfjörð Bjarmason","fromEmail":"avarab@gmail.com","sentAt":"2021-08-31T14:37:29Z","receivedAt":"2021-08-31T14:37:37Z","isPatch":true,"sender":{"key":"avarab@gmail.com","avatar":"https://avatars.githubusercontent.com/u/45301?v=4"},"body":"Remove the trailing dot from the warning we emit about gc.log. It's\ncommon for various terminal UX's to allow the user to select \"words\",\nand by including the trailing dot a user wanting to select the path to\ngc.log will need to manually remove the trailing dot.\n\nSuch a user would also probably need to adjust the path if it e.g. had\nspaces in it, but this should address this very common case.\n\nSigned-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>\nSuggested-by: Jan Judas <snugar.i@gmail.com>\n---\n\nOn Tue, Aug 31 2021, Jan Judas wrote:\n\n> Hello,\n>\n> first time posting here, I hope I'm doing it right.\n> I'd like to suggest a very minor UX improvement regarding the message:\n\nThis is the right place for this request. Thanks!\n\n> error: The last gc run reported the following. Please correct the root cause\n> and remove /path/to/repo/.git/gc.log.\n>\n> Currently, there is a dot after the file path, so it's impossible to\n> select just the path using double-click. If the dot was removed, or\n> separated from the path by a space, it would be slightly more\n> convenient :-)\n>\n> Thank you\n>\n> Jan Judas   \n\nYes that's annoying, here's a proposed patch to fix this.\n\nAs an aside I've also noticed that if you have multiple worktrees\nwe'll trigger \"git gc --auto\" in each one, and then litter various\nper-worktree gc.log, even though the issues being noted are usually\nrepository-global, e.g. too many loose objects.\n\nThat's per-se unrelated to the issue you're noting, but is usually why\nI end up having to manually remove gc.log files...\n\n builtin/gc.c | 2 +-\n 1 file changed, 1 insertion(+), 1 deletion(-)\n\ndiff --git a/builtin/gc.c b/builtin/gc.c\nindex 6ce5ca45126..69c058533ea 100644\n--- a/builtin/gc.c\n+++ b/builtin/gc.c\n@@ -502,7 +502,7 @@ static int report_last_gc_error(void)\n \t\t */\n \t\twarning(_(\"The last gc run reported the following. \"\n \t\t\t       \"Please correct the root cause\\n\"\n-\t\t\t       \"and remove %s.\\n\"\n+\t\t\t       \"and remove %s\\n\"\n \t\t\t       \"Automatic cleanup will not be performed \"\n \t\t\t       \"until the file is removed.\\n\\n\"\n \t\t\t       \"%s\"),\n-- \n2.33.0.805.g739b16c2189\n\n"},{"id":"434295","messageId":"CAPig+cQ1V-sSZzrBwDWZYFEFJY-W8s1aq4igfhg9vPBNdLJusA@mail.gmail.com","threadId":"56415","inReplyTo":"patch-1.1-27f00a664e6-20210831T143536Z-avarab@gmail.com","subject":"Re: [PATCH] gc: remove trailing dot from \"gc.log\" line","fromName":"Eric Sunshine","fromEmail":"sunshine@sunshineco.com","sentAt":"2021-08-31T16:15:04Z","receivedAt":"2021-08-31T16:15:26Z","isPatch":true,"sender":{"key":"sunshine@sunshineco.com","avatar":"https://avatars.githubusercontent.com/u/163641?v=4"},"body":"On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason\n<avarab@gmail.com> wrote:\n> Remove the trailing dot from the warning we emit about gc.log. It's\n> common for various terminal UX's to allow the user to select \"words\",\n> and by including the trailing dot a user wanting to select the path to\n> gc.log will need to manually remove the trailing dot.\n>\n> Such a user would also probably need to adjust the path if it e.g. had\n> spaces in it, but this should address this very common case.\n>\n> Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>\n> Suggested-by: Jan Judas <snugar.i@gmail.com>\n> ---\n> diff --git a/builtin/gc.c b/builtin/gc.c\n> @@ -502,7 +502,7 @@ static int report_last_gc_error(void)\n>                 warning(_(\"The last gc run reported the following. \"\n>                                \"Please correct the root cause\\n\"\n> -                              \"and remove %s.\\n\"\n> +                              \"and remove %s\\n\"\n\nBikeshedding: Adding a colon after \"remove\" would give this a slightly\nmore grammatically-correct feel:\n\n    Please correct the root cause\n    and remove: /path/to/repo/.git/gc.log\n\n>                                \"Automatic cleanup will not be performed \"\n>                                \"until the file is removed.\\n\\n\"\n>                                \"%s\"),\n\nEven more bikeshedding:\n\n    Please correct the root cause and remove\n    /path/to/repo/.git/gc.log\n    to allow automatic cleanup to resume.\n\nor something.\n"},{"id":"434317","messageId":"xmqqpmtttr56.fsf@gitster.g","threadId":"56415","inReplyTo":"CAPig+cQ1V-sSZzrBwDWZYFEFJY-W8s1aq4igfhg9vPBNdLJusA@mail.gmail.com","subject":"Re: [PATCH] gc: remove trailing dot from \"gc.log\" line","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2021-08-31T18:17:57Z","receivedAt":"2021-08-31T18:18:03Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Eric Sunshine <sunshine@sunshineco.com> writes:\n\n> On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason\n> <avarab@gmail.com> wrote:\n>> Remove the trailing dot from the warning we emit about gc.log. It's\n>> common for various terminal UX's to allow the user to select \"words\",\n>> and by including the trailing dot a user wanting to select the path to\n>> gc.log will need to manually remove the trailing dot.\n>>\n>> Such a user would also probably need to adjust the path if it e.g. had\n>> spaces in it, but this should address this very common case.\n>>\n>> Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>\n>> Suggested-by: Jan Judas <snugar.i@gmail.com>\n>> ---\n>> diff --git a/builtin/gc.c b/builtin/gc.c\n>> @@ -502,7 +502,7 @@ static int report_last_gc_error(void)\n>>                 warning(_(\"The last gc run reported the following. \"\n>>                                \"Please correct the root cause\\n\"\n>> -                              \"and remove %s.\\n\"\n>> +                              \"and remove %s\\n\"\n>\n> Bikeshedding: Adding a colon after \"remove\" would give this a slightly\n> more grammatically-correct feel:\n>\n>     Please correct the root cause\n>     and remove: /path/to/repo/.git/gc.log\n>\n>>                                \"Automatic cleanup will not be performed \"\n>>                                \"until the file is removed.\\n\\n\"\n>>                                \"%s\"),\n\nOK.\n\n> Even more bikeshedding:\n>\n>     Please correct the root cause and remove\n>     /path/to/repo/.git/gc.log\n>     to allow automatic cleanup to resume.\n>\n> or something.\n\nI also found the line break before \"and remove\" strange, but I think\nthat is because the \"Please\" is not at the beginning of the\nparagraph, but is a second sentence.  Perhaps unfolding \"and remove\"\nwould make the first line overly long?\n\nTHanks.\n"},{"id":"434318","messageId":"CAPig+cTaJ=xm=K5Y8yn8RiOFHBH-nzhRztYRz3kYsqsyJUTACg@mail.gmail.com","threadId":"56415","inReplyTo":"xmqqpmtttr56.fsf@gitster.g","subject":"Re: [PATCH] gc: remove trailing dot from \"gc.log\" line","fromName":"Eric Sunshine","fromEmail":"sunshine@sunshineco.com","sentAt":"2021-08-31T18:23:55Z","receivedAt":"2021-08-31T18:24:09Z","isPatch":true,"sender":{"key":"sunshine@sunshineco.com","avatar":"https://avatars.githubusercontent.com/u/163641?v=4"},"body":"On Tue, Aug 31, 2021 at 2:18 PM Junio C Hamano <gitster@pobox.com> wrote:\n> Eric Sunshine <sunshine@sunshineco.com> writes:\n> > On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason\n> > <avarab@gmail.com> wrote:\n> >>                 warning(_(\"The last gc run reported the following. \"\n> >>                                \"Please correct the root cause\\n\"\n> >> -                              \"and remove %s.\\n\"\n> >> +                              \"and remove %s\\n\"\n> >\n> > Even more bikeshedding:\n> >\n> >     Please correct the root cause and remove\n> >     /path/to/repo/.git/gc.log\n> >     to allow automatic cleanup to resume.\n> >\n> > or something.\n>\n> I also found the line break before \"and remove\" strange, but I think\n> that is because the \"Please\" is not at the beginning of the\n> paragraph, but is a second sentence.  Perhaps unfolding \"and remove\"\n> would make the first line overly long?\n\nYep, you're right, and perhaps my \"Even more bikeshedding\" didn't\nclearly indicate that I was bikeshedding more about combining the\n\"Please correct...\" and \"Automatic cleanup...\" sentences into a single\nsentence, both as a another way to deal with the punctuation issue\n(thus allowing easy double-click) and to make the whole thing read a\nbit better.\n"},{"id":"434335","messageId":"87eea9wdit.fsf@evledraar.gmail.com","threadId":"56415","inReplyTo":"CAPig+cTaJ=xm=K5Y8yn8RiOFHBH-nzhRztYRz3kYsqsyJUTACg@mail.gmail.com","subject":"Re: [PATCH] gc: remove trailing dot from \"gc.log\" line","fromName":"Ævar Arnfjörð Bjarmason","fromEmail":"avarab@gmail.com","sentAt":"2021-08-31T20:36:01Z","receivedAt":"2021-08-31T20:43:58Z","isPatch":true,"sender":{"key":"avarab@gmail.com","avatar":"https://avatars.githubusercontent.com/u/45301?v=4"},"body":"\nOn Tue, Aug 31 2021, Eric Sunshine wrote:\n\n> On Tue, Aug 31, 2021 at 2:18 PM Junio C Hamano <gitster@pobox.com> wrote:\n>> Eric Sunshine <sunshine@sunshineco.com> writes:\n>> > On Tue, Aug 31, 2021 at 10:37 AM Ævar Arnfjörð Bjarmason\n>> > <avarab@gmail.com> wrote:\n>> >>                 warning(_(\"The last gc run reported the following. \"\n>> >>                                \"Please correct the root cause\\n\"\n>> >> -                              \"and remove %s.\\n\"\n>> >> +                              \"and remove %s\\n\"\n>> >\n>> > Even more bikeshedding:\n>> >\n>> >     Please correct the root cause and remove\n>> >     /path/to/repo/.git/gc.log\n>> >     to allow automatic cleanup to resume.\n>> >\n>> > or something.\n>>\n>> I also found the line break before \"and remove\" strange, but I think\n>> that is because the \"Please\" is not at the beginning of the\n>> paragraph, but is a second sentence.  Perhaps unfolding \"and remove\"\n>> would make the first line overly long?\n>\n> Yep, you're right, and perhaps my \"Even more bikeshedding\" didn't\n> clearly indicate that I was bikeshedding more about combining the\n> \"Please correct...\" and \"Automatic cleanup...\" sentences into a single\n> sentence, both as a another way to deal with the punctuation issue\n> (thus allowing easy double-click) and to make the whole thing read a\n> bit better.\n\nI'm aware that it's not in any formal style guide, but for what it's\nworth I find that something like say:\n\n    Eric sent me an E-Mail with the Message-Id\n    <CAPig+cTaJ=xm=K5Y8yn8RiOFHBH-nzhRztYRz3kYsqsyJUTACg@mail.gmail.com>\n    My E-Mail client is displaying it right now.\n\nReads unambiguously as having an implied full-stop after \"com>\",\nespecially as the next word starts on its own line, and is capitalized\nin a way that it wouldn't be if it weren't the start of a sentence.\n\nIn any case, I do think just removing the dot on the basis of that\nrationale is an improvement, both for the stated ease of copy/pasting,\nand to remove the ambiguity of whether the \".\" is part of the filename\n(yeah *nix filenames can also have \\n, but that's a lot less likely).\n\nI don't think sometihng like your \"Even more bikeshedding\" suggestion is\nbetter, since we're trying to continue a sentence after a potentially\nlong filename that might on some platforms or OS's contain spaces etc.\n\nIn any case, I was hoping to just send a quick fix-as-a-patch to a tiny\nUX suggestion, and was hoping to not get into the much more subjective\ndiscussion of how to better reword \"git gc\"'s error messages in\ngeneral. If that's where this thread is headed I'm afraid I'll need to\ntap out of it :)\n"},{"id":"434379","messageId":"CAPig+cT62CcGW0stAMaK=diMAuWzgmN+y+f-Hjne0UAq91A_Uw@mail.gmail.com","threadId":"56415","inReplyTo":"87eea9wdit.fsf@evledraar.gmail.com","subject":"Re: [PATCH] gc: remove trailing dot from \"gc.log\" line","fromName":"Eric Sunshine","fromEmail":"sunshine@sunshineco.com","sentAt":"2021-09-01T02:10:08Z","receivedAt":"2021-09-01T02:10:26Z","isPatch":true,"sender":{"key":"sunshine@sunshineco.com","avatar":"https://avatars.githubusercontent.com/u/163641?v=4"},"body":"On Tue, Aug 31, 2021 at 4:44 PM Ævar Arnfjörð Bjarmason\n<avarab@gmail.com> wrote:\n> In any case, I was hoping to just send a quick fix-as-a-patch to a tiny\n> UX suggestion, and was hoping to not get into the much more subjective\n> discussion of how to better reword \"git gc\"'s error messages in\n> general. If that's where this thread is headed I'm afraid I'll need to\n> tap out of it :)\n\nFair enough. I hope that my explicit mention of \"bikeshedding\" made it\nclear that my comments weren't expectations of change but rather \"if\nyou plan to pursue it further, maybe try these ideas\".\n"},{"id":"434589","messageId":"CAO=eiXzE5ZjKEBiCnbUW9-JojgPfG1yQuyG+2Pn1O9x08HATgg@mail.gmail.com","threadId":"56415","inReplyTo":"patch-1.1-27f00a664e6-20210831T143536Z-avarab@gmail.com","subject":"Re: [PATCH] gc: remove trailing dot from \"gc.log\" line","fromName":"Jan Judas","fromEmail":"snugar.i@gmail.com","sentAt":"2021-09-02T17:27:41Z","receivedAt":"2021-09-02T17:27:56Z","isPatch":true,"sender":{"key":"snugar.i@gmail.com","avatar":null},"body":"Wow, that was quick!\nIt's awesome to see a project that is alive and welcoming to new\npeople (unlike some others I tried to contribute to).\nThanks again and keep up the great work!\n\nJan\n\nút 31. 8. 2021 v 16:37 odesílatel Ævar Arnfjörð Bjarmason\n<avarab@gmail.com> napsal:\n>\n> Remove the trailing dot from the warning we emit about gc.log. It's\n> common for various terminal UX's to allow the user to select \"words\",\n> and by including the trailing dot a user wanting to select the path to\n> gc.log will need to manually remove the trailing dot.\n>\n> Such a user would also probably need to adjust the path if it e.g. had\n> spaces in it, but this should address this very common case.\n>\n> Signed-off-by: Ævar Arnfjörð Bjarmason <avarab@gmail.com>\n> Suggested-by: Jan Judas <snugar.i@gmail.com>\n> ---\n>\n> On Tue, Aug 31 2021, Jan Judas wrote:\n>\n> > Hello,\n> >\n> > first time posting here, I hope I'm doing it right.\n> > I'd like to suggest a very minor UX improvement regarding the message:\n>\n> This is the right place for this request. Thanks!\n>\n> > error: The last gc run reported the following. Please correct the root cause\n> > and remove /path/to/repo/.git/gc.log.\n> >\n> > Currently, there is a dot after the file path, so it's impossible to\n> > select just the path using double-click. If the dot was removed, or\n> > separated from the path by a space, it would be slightly more\n> > convenient :-)\n> >\n> > Thank you\n> >\n> > Jan Judas\n>\n> Yes that's annoying, here's a proposed patch to fix this.\n>\n> As an aside I've also noticed that if you have multiple worktrees\n> we'll trigger \"git gc --auto\" in each one, and then litter various\n> per-worktree gc.log, even though the issues being noted are usually\n> repository-global, e.g. too many loose objects.\n>\n> That's per-se unrelated to the issue you're noting, but is usually why\n> I end up having to manually remove gc.log files...\n>\n>  builtin/gc.c | 2 +-\n>  1 file changed, 1 insertion(+), 1 deletion(-)\n>\n> diff --git a/builtin/gc.c b/builtin/gc.c\n> index 6ce5ca45126..69c058533ea 100644\n> --- a/builtin/gc.c\n> +++ b/builtin/gc.c\n> @@ -502,7 +502,7 @@ static int report_last_gc_error(void)\n>                  */\n>                 warning(_(\"The last gc run reported the following. \"\n>                                \"Please correct the root cause\\n\"\n> -                              \"and remove %s.\\n\"\n> +                              \"and remove %s\\n\"\n>                                \"Automatic cleanup will not be performed \"\n>                                \"until the file is removed.\\n\\n\"\n>                                \"%s\"),\n> --\n> 2.33.0.805.g739b16c2189\n>\n"}]}