{"thread":{"id":"55933","subject":"A suggestion: more readable human commands","startedAt":"2021-06-15T10:51:45Z","lastAt":"2021-06-15T11:55:13Z","messageCount":3,"participants":["it-developer@abelardolg.com","Bagas Sanjaya","Andreas Schwab"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"427443","messageId":"fa2e886dd03a26c945d9deffe6f96d48@abelardolg.com","threadId":"55933","inReplyTo":null,"subject":"A suggestion: more readable human commands","fromName":"","fromEmail":"it-developer@abelardolg.com","sentAt":"2021-06-15T10:51:36Z","receivedAt":"2021-06-15T10:51:45Z","isPatch":false,"sender":{"key":"it-developer@abelardolg.com","avatar":null},"body":"Hi there,\n\nI would like to suggest you a new improvement.\n\nWhy not adding a new layer of abstraction for commands or to make more \nexplicitly the commands?\n\nFor instance:\n\nTo merge a single file from one branch to another:\n\ngit checkout <branch_name> <path_to_file> --patch\n\nwould be like more readable human like this:\n\ngit merge <path_file> to <dst_branch>\n\nIt uses a more natural language.\n\nBest regards.\n"},{"id":"427446","messageId":"c3855aea-6cbd-af30-7791-07c212c52bbd@gmail.com","threadId":"55933","inReplyTo":"fa2e886dd03a26c945d9deffe6f96d48@abelardolg.com","subject":"Re: A suggestion: more readable human commands","fromName":"Bagas Sanjaya","fromEmail":"bagasdotme@gmail.com","sentAt":"2021-06-15T10:59:04Z","receivedAt":"2021-06-15T10:59:16Z","isPatch":false,"sender":{"key":"bagasdotme@gmail.com","avatar":"https://avatars.githubusercontent.com/u/40219486?v=4"},"body":"On 15/06/21 17.51, it-developer@abelardolg.com wrote:\n> Hi there,\n> \n> I would like to suggest you a new improvement.\n> \n> Why not adding a new layer of abstraction for commands or to make more \n> explicitly the commands?\n> \n> For instance:\n> \n> To merge a single file from one branch to another:\n> \n> git checkout <branch_name> <path_to_file> --patch\n> \n> would be like more readable human like this:\n> \n> git merge <path_file> to <dst_branch>\n> \n> It uses a more natural language.\n> \n> Best regards.\n\nWhat workflow you do so that you need to merge single file?\n\n-- \nAn old man doll... just what I always wanted! - Clara\n"},{"id":"427456","messageId":"87o8c7wdes.fsf@igel.home","threadId":"55933","inReplyTo":"fa2e886dd03a26c945d9deffe6f96d48@abelardolg.com","subject":"Re: A suggestion: more readable human commands","fromName":"Andreas Schwab","fromEmail":"schwab@linux-m68k.org","sentAt":"2021-06-15T11:55:07Z","receivedAt":"2021-06-15T11:55:13Z","isPatch":false,"sender":{"key":"schwab@linux-m68k.org","avatar":"https://avatars.githubusercontent.com/u/2175493?v=4"},"body":"On Jun 15 2021, it-developer@abelardolg.com wrote:\n\n> To merge a single file from one branch to another:\n>\n> git checkout <branch_name> <path_to_file> --patch\n>\n> would be like more readable human like this:\n>\n> git merge <path_file> to <dst_branch>\n\nThis is ambigous if a branch or tag named <path_file> or to exists, and\nthe usual disambiguation using -- will not work.\n\nAndreas.\n\n-- \nAndreas Schwab, schwab@linux-m68k.org\nGPG Key fingerprint = 7578 EB47 D4E5 4D69 2510  2552 DF73 E780 A9DA AEC1\n\"And now for something completely different.\"\n"}]}