{"thread":{"id":"53709","subject":"[PATCH] tests: do not use \"slave branch\" nomenclature","startedAt":"2020-06-18T16:38:50Z","lastAt":"2020-06-19T09:23:41Z","messageCount":5,"participants":["Paolo Bonzini","Jeff King","Junio C Hamano","Michal Suchánek"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"400064","messageId":"20200618163843.22181-1-bonzini@gnu.org","threadId":"53709","inReplyTo":null,"subject":"[PATCH] tests: do not use \"slave branch\" nomenclature","fromName":"Paolo Bonzini","fromEmail":"bonzini@gnu.org","sentAt":"2020-06-18T16:38:43Z","receivedAt":"2020-06-18T16:38:50Z","isPatch":true,"sender":{"key":"bonzini@gnu.org","avatar":"https://avatars.githubusercontent.com/u/42082?v=4"},"body":"From: Paolo Bonzini <pbonzini@redhat.com>\n\nGit does not have slave branches and has never had.  Independent\nof any future change to the naming of branches, remove the sole\nappearance of the term.\n\nSigned-off-by: Paolo Bonzini <pbonzini@redhat.com>\n---\n t/t4014-format-patch.sh | 8 ++++----\n 1 file changed, 4 insertions(+), 4 deletions(-)\n\ndiff --git a/t/t4014-format-patch.sh b/t/t4014-format-patch.sh\nindex 575e079cc2..3e5b921b0f 100755\n--- a/t/t4014-format-patch.sh\n+++ b/t/t4014-format-patch.sh\n@@ -81,16 +81,16 @@ test_expect_success 'format-patch --ignore-if-in-upstream handles tags' '\n '\n \n test_expect_success \"format-patch doesn't consider merge commits\" '\n-\tgit checkout -b slave master &&\n+\tgit checkout -b branch master &&\n \techo \"Another line\" >>file &&\n \ttest_tick &&\n-\tgit commit -am \"Slave change #1\" &&\n+\tgit commit -am \"Branch change #1\" &&\n \techo \"Yet another line\" >>file &&\n \ttest_tick &&\n-\tgit commit -am \"Slave change #2\" &&\n+\tgit commit -am \"Branch change #2\" &&\n \tgit checkout -b merger master &&\n \ttest_tick &&\n-\tgit merge --no-ff slave &&\n+\tgit merge --no-ff branch &&\n \tgit format-patch -3 --stdout >patch &&\n \tgrep \"^From \" patch >from &&\n \ttest_line_count = 3 from\n-- \n2.25.4\n\n"},{"id":"400065","messageId":"20200618164554.GA616157@coredump.intra.peff.net","threadId":"53709","inReplyTo":"20200618163843.22181-1-bonzini@gnu.org","subject":"Re: [PATCH] tests: do not use \"slave branch\" nomenclature","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2020-06-18T16:45:54Z","receivedAt":"2020-06-18T16:45:56Z","isPatch":true,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"On Thu, Jun 18, 2020 at 06:38:43PM +0200, Paolo Bonzini wrote:\n\n> From: Paolo Bonzini <pbonzini@redhat.com>\n> \n> Git does not have slave branches and has never had.  Independent\n> of any future change to the naming of branches, remove the sole\n> appearance of the term.\n\nI think this is a sensible change, though note that something simpler\nwas proposed recently:\n\n  https://lore.kernel.org/git/20200610165441.iktvzuwz44sbytfg@chatter.i7.local/\n\nand the review suggested using a name that is even more meaningful to\nthe test case (so we not just remove the unwanted names, but make the\ntest easier to follow).\n\n-Peff\n"},{"id":"400071","messageId":"xmqqwo44nt6m.fsf@gitster.c.googlers.com","threadId":"53709","inReplyTo":"20200618164554.GA616157@coredump.intra.peff.net","subject":"Re: [PATCH] tests: do not use \"slave branch\" nomenclature","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2020-06-18T18:08:01Z","receivedAt":"2020-06-18T18:08:11Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Jeff King <peff@peff.net> writes:\n\n> On Thu, Jun 18, 2020 at 06:38:43PM +0200, Paolo Bonzini wrote:\n>\n>> From: Paolo Bonzini <pbonzini@redhat.com>\n>> \n>> Git does not have slave branches and has never had.  Independent\n>> of any future change to the naming of branches, remove the sole\n>> appearance of the term.\n>\n> I think this is a sensible change, though note that something simpler\n> was proposed recently:\n>\n>   https://lore.kernel.org/git/20200610165441.iktvzuwz44sbytfg@chatter.i7.local/\n>\n> and the review suggested using a name that is even more meaningful to\n> the test case (so we not just remove the unwanted names, but make the\n> test easier to follow).\n\nThanks for spotting that both versions share the same issue.  We'd\njust need a single one that is fixed up ;-).\n"},{"id":"400104","messageId":"20200619092035.GQ21462@kitsune.suse.cz","threadId":"53709","inReplyTo":"xmqqwo44nt6m.fsf@gitster.c.googlers.com","subject":"Re: [PATCH] tests: do not use \"slave branch\" nomenclature","fromName":"Michal Suchánek","fromEmail":"msuchanek@suse.de","sentAt":"2020-06-19T09:20:35Z","receivedAt":"2020-06-19T09:20:40Z","isPatch":true,"sender":{"key":"msuchanek@suse.de","avatar":"https://avatars.githubusercontent.com/u/787652?v=4"},"body":"On Thu, Jun 18, 2020 at 11:08:01AM -0700, Junio C Hamano wrote:\n> Jeff King <peff@peff.net> writes:\n> \n> > On Thu, Jun 18, 2020 at 06:38:43PM +0200, Paolo Bonzini wrote:\n> >\n> >> From: Paolo Bonzini <pbonzini@redhat.com>\n> >> \n> >> Git does not have slave branches and has never had.  Independent\n> >> of any future change to the naming of branches, remove the sole\n> >> appearance of the term.\n> >\n> > I think this is a sensible change, though note that something simpler\n> > was proposed recently:\n> >\n> >   https://lore.kernel.org/git/20200610165441.iktvzuwz44sbytfg@chatter.i7.local/\n> >\n> > and the review suggested using a name that is even more meaningful to\n> > the test case (so we not just remove the unwanted names, but make the\n> > test easier to follow).\n> \n> Thanks for spotting that both versions share the same issue.  We'd\n> just need a single one that is fixed up ;-).\nHow about s/slave/feature/\n\nThis is about simulating some development happening on the new branch so\nthis name looks appropriate.\n\nThanks\n\nMichal\n"},{"id":"400105","messageId":"b4259ac0-9510-8d01-0e71-f11b4a193123@gnu.org","threadId":"53709","inReplyTo":"20200619092035.GQ21462@kitsune.suse.cz","subject":"Re: [PATCH] tests: do not use \"slave branch\" nomenclature","fromName":"Paolo Bonzini","fromEmail":"bonzini@gnu.org","sentAt":"2020-06-19T09:23:34Z","receivedAt":"2020-06-19T09:23:41Z","isPatch":true,"sender":{"key":"bonzini@gnu.org","avatar":"https://avatars.githubusercontent.com/u/42082?v=4"},"body":"On 19/06/20 11:20, Michal Suchánek wrote:\n> On Thu, Jun 18, 2020 at 11:08:01AM -0700, Junio C Hamano wrote:\n>> Jeff King <peff@peff.net> writes:\n>>\n>>> On Thu, Jun 18, 2020 at 06:38:43PM +0200, Paolo Bonzini wrote:\n>>>\n>>>> From: Paolo Bonzini <pbonzini@redhat.com>\n>>>>\n>>>> Git does not have slave branches and has never had.  Independent\n>>>> of any future change to the naming of branches, remove the sole\n>>>> appearance of the term.\n>>>\n>>> I think this is a sensible change, though note that something simpler\n>>> was proposed recently:\n>>>\n>>>   https://lore.kernel.org/git/20200610165441.iktvzuwz44sbytfg@chatter.i7.local/\n>>>\n>>> and the review suggested using a name that is even more meaningful to\n>>> the test case (so we not just remove the unwanted names, but make the\n>>> test easier to follow).\n>>\n>> Thanks for spotting that both versions share the same issue.  We'd\n>> just need a single one that is fixed up ;-).\n> How about s/slave/feature/\n> \n> This is about simulating some development happening on the new branch so\n> this name looks appropriate.\n\nIndeed I was going to send v2 with topic or feature.  Thanks,\n\nPaolo\n\n"}]}