{"thread":{"id":"53015","subject":"[ANNOUNCE] Git v2.25.2","startedAt":"2020-03-18T00:07:18Z","lastAt":"2020-03-18T00:07:18Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"393379","messageId":"xmqqeetqh6fp.fsf@gitster.c.googlers.com","threadId":"53015","inReplyTo":null,"subject":"[ANNOUNCE] Git v2.25.2","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2020-03-18T00:07:06Z","receivedAt":"2020-03-18T00:07:18Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"The latest maintenance release Git v2.25.2 is now available at the\nusual places.  These merge down various fixes that have been merged\nto 'master' and will be part of the upcoming v2.26.0 release.\n\nThe tarballs are found at:\n\n    https://www.kernel.org/pub/software/scm/git/\n\nThe following public repositories all have a copy of the 'v2.25.2'\ntag and the 'maint' branch that the tag points at:\n\n  url = https://kernel.googlesource.com/pub/scm/git/git\n  url = git://repo.or.cz/alt-git.git\n  url = https://github.com/gitster/git\n\n----------------------------------------------------------------\n\nGit 2.25.2 Release Notes\n========================\n\nFixes since v2.25.1\n-------------------\n\n * Minor bugfixes to \"git add -i\" that has recently been rewritten in C.\n\n * An earlier update to show the location of working tree in the error\n   message did not consider the possibility that a git command may be\n   run in a bare repository, which has been corrected.\n\n * The \"--recurse-submodules\" option of various subcommands did not\n   work well when run in an alternate worktree, which has been\n   corrected.\n\n * Running \"git rm\" on a submodule failed unnecessarily when\n   .gitmodules is only cache-dirty, which has been corrected.\n\n * \"git rebase -i\" identifies existing commits in its todo file with\n   their abbreviated object name, which could become ambigous as it\n   goes to create new commits, and has a mechanism to avoid ambiguity\n   in the main part of its execution.  A few other cases however were\n   not covered by the protection against ambiguity, which has been\n   corrected.\n\n * The index-pack code now diagnoses a bad input packstream that\n   records the same object twice when it is used as delta base; the\n   code used to declare a software bug when encountering such an\n   input, but it is an input error.\n\n * The code to automatically shrink the fan-out in the notes tree had\n   an off-by-one bug, which has been killed.\n\n * \"git check-ignore\" did not work when the given path is explicitly\n   marked as not ignored with a negative entry in the .gitignore file.\n\n * The merge-recursive machinery failed to refresh the cache entry for\n   a merge result in a couple of places, resulting in an unnecessary\n   merge failure, which has been fixed.\n\n * Fix for a bug revealed by a recent change to make the protocol v2\n   the default.\n\n * \"git merge signed-tag\" while lacking the public key started to say\n   \"No signature\", which was utterly wrong.  This regression has been\n   reverted.\n\n * MinGW's poll() emulation has been improved.\n\n * \"git show\" and others gave an object name in raw format in its\n   error output, which has been corrected to give it in hex.\n\n * Both \"git ls-remote -h\" and \"git grep -h\" give short usage help,\n   like any other Git subcommand, but it is not unreasonable to expect\n   that the former would behave the same as \"git ls-remote --head\"\n   (there is no other sensible behaviour for the latter).  The\n   documentation has been updated in an attempt to clarify this.\n\nAlso contains various documentation updates, code clean-ups and minor fixups.\n\n----------------------------------------------------------------\n\nChanges since v2.25.1 are as follows:\n\nAlexandr Miloslavskiy (1):\n      mingw: workaround for hangs when sending STDIN\n\nBeat Bolli (1):\n      unicode: update the width tables to Unicode 13.0\n\nDavid Turner (1):\n      git rm submodule: succeed if .gitmodules index stat info is zero\n\nDerrick Stolee (2):\n      partial-clone: demonstrate bugs in partial fetch\n      partial-clone: avoid fetching when looking for objects\n\nElijah Newren (4):\n      unpack-trees: exit check_updates() early if updates are not wanted\n      check-ignore: fix documentation and implementation to match\n      t3433: new rebase testcase documenting a stat-dirty-like failure\n      merge-recursive: fix the refresh logic in update_file_flags\n\nEmily Shaffer (2):\n      prefix_path: show gitdir when arg is outside repo\n      prefix_path: show gitdir if worktree unavailable\n\nHarald van Dijk (1):\n      show_one_mergetag: print non-parent in hex form.\n\nJeff King (9):\n      merge-recursive: silence -Wxor-used-as-pow warning\n      avoid computing zero offsets from NULL pointer\n      xdiff: avoid computing non-zero offset from NULL pointer\n      obstack: avoid computing offsets from NULL pointer\n      index-pack: downgrade twice-resolved REF_DELTA to die()\n      doc: move credential helper info into gitcredentials(7)\n      doc/config/push: use longer \"--\" line for preformatted example\n      doc-diff: use single-colon rule in rendering Makefile\n      run-command.h: fix mis-indented struct member\n\nJohan Herland (2):\n      t3305: check notes fanout more carefully and robustly\n      notes.c: fix off-by-one error when decreasing notes fanout\n\nJohannes Schindelin (11):\n      built-in add -i: do not try to `patch`/`diff` an empty list of files\n      built-in add -i: accept open-ended ranges again\n      parse_insn_line(): improve error message when parsing failed\n      rebase -i: re-fix short SHA-1 collision\n      rebase -i: also avoid SHA-1 collisions with missingCommitsCheck\n      tests: fix --write-junit-xml with subshells\n      t5580: test cloning without file://, test fetching via UNC paths\n      mingw: add a helper function to attach GDB to the current process\n      t/lib-httpd: avoid using macOS' sed\n      ci: prevent `perforce` from being quarantined\n      Azure Pipeline: switch to the latest agent pools\n\nJunio C Hamano (4):\n      merge-recursive: use subtraction to flip stage\n      Documentation: clarify that `-h` alone stands for `help`\n      Revert \"gpg-interface: prefer check_signature() for GPG verification\"\n      Git 2.25.2\n\nPhilippe Blain (4):\n      t7410: rename to t2405-worktree-submodule.sh\n      t2405: use git -C and test_commit -C instead of subshells\n      t2405: clarify test descriptions and simplify test\n      submodule.c: use get_git_dir() instead of get_git_common_dir()\n\n\n"}]}