{"thread":{"id":"45458","subject":"[PATCH] t3600: rename test to describe its functionality","startedAt":"2017-03-21T21:08:23Z","lastAt":"2017-03-22T18:23:37Z","messageCount":4,"participants":["Stefan Beller","Jonathan Nieder"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"314866","messageId":"20170321210802.9675-1-sbeller@google.com","threadId":"45458","inReplyTo":null,"subject":"[PATCH] t3600: rename test to describe its functionality","fromName":"Stefan Beller","fromEmail":"sbeller@google.com","sentAt":"2017-03-21T21:08:02Z","receivedAt":"2017-03-21T21:08:23Z","isPatch":true,"sender":{"key":"stefanbeller@gmail.com","avatar":"https://avatars.githubusercontent.com/u/455868?v=4"},"body":"This was an oversight in 55856a35b2 (rm: absorb a submodules git dir\nbefore deletion, 2016-12-27), as the body of the test changed without\nadapting the test subject.\n\nSigned-off-by: Stefan Beller <sbeller@google.com>\n---\n t/t3600-rm.sh | 2 +-\n 1 file changed, 1 insertion(+), 1 deletion(-)\n\ndiff --git a/t/t3600-rm.sh b/t/t3600-rm.sh\nindex 5aa6db584c..1f87781e94 100755\n--- a/t/t3600-rm.sh\n+++ b/t/t3600-rm.sh\n@@ -658,7 +658,7 @@ test_expect_success 'rm of a populated nested submodule with nested untracked fi\n \ttest_cmp expect actual\n '\n \n-test_expect_success 'rm of a populated nested submodule with a nested .git directory fails even when forced' '\n+test_expect_success 'rm of a populated nested submodule with a nested .git directory absorbs the nested git dir' '\n \tgit reset --hard &&\n \tgit submodule update --recursive &&\n \t(cd submod/subsubmod &&\n-- \n2.12.1.386.gf8442ebc0a.dirty\n\n"},{"id":"314886","messageId":"20170322010058.GA31294@aiede.mtv.corp.google.com","threadId":"45458","inReplyTo":"20170321210802.9675-1-sbeller@google.com","subject":"Re: [PATCH] t3600: rename test to describe its functionality","fromName":"Jonathan Nieder","fromEmail":"jrnieder@gmail.com","sentAt":"2017-03-22T01:00:58Z","receivedAt":"2017-03-22T01:01:38Z","isPatch":true,"sender":{"key":"jrnieder@gmail.com","avatar":"https://avatars.githubusercontent.com/u/281595?v=4"},"body":"Stefan Beller wrote:\n\n> This was an oversight in 55856a35b2 (rm: absorb a submodules git dir\n> before deletion, 2016-12-27), as the body of the test changed without\n> adapting the test subject.\n>\n> Signed-off-by: Stefan Beller <sbeller@google.com>\n> ---\n>  t/t3600-rm.sh | 2 +-\n>  1 file changed, 1 insertion(+), 1 deletion(-)\n>\n> diff --git a/t/t3600-rm.sh b/t/t3600-rm.sh\n> index 5aa6db584c..1f87781e94 100755\n> --- a/t/t3600-rm.sh\n> +++ b/t/t3600-rm.sh\n> @@ -658,7 +658,7 @@ test_expect_success 'rm of a populated nested submodule with nested untracked fi\n>  \ttest_cmp expect actual\n>  '\n>  \n> -test_expect_success 'rm of a populated nested submodule with a nested .git directory fails even when forced' '\n> +test_expect_success 'rm of a populated nested submodule with a nested .git directory absorbs the nested git dir' '\n\nThis title is getting long. How about something like the following for\nsquashing in?\n\nWith or without that change,\nReviewed-by: Jonathan Nieder <jrnieder@gmail.com>\n\ndiff --git i/t/t3600-rm.sh w/t/t3600-rm.sh\nindex 1f87781e94..3c63455729 100755\n--- i/t/t3600-rm.sh\n+++ w/t/t3600-rm.sh\n@@ -658,7 +658,7 @@ test_expect_success 'rm of a populated nested submodule with nested untracked fi\n \ttest_cmp expect actual\n '\n \n-test_expect_success 'rm of a populated nested submodule with a nested .git directory absorbs the nested git dir' '\n+test_expect_success \"rm absorbs submodule's nested .git directory\" '\n \tgit reset --hard &&\n \tgit submodule update --recursive &&\n \t(cd submod/subsubmod &&\n"},{"id":"314915","messageId":"20170322165639.21658-1-sbeller@google.com","threadId":"45458","inReplyTo":"20170322010058.GA31294@aiede.mtv.corp.google.com","subject":"[PATCH] t3600: rename test to describe its functionality","fromName":"Stefan Beller","fromEmail":"sbeller@google.com","sentAt":"2017-03-22T16:56:39Z","receivedAt":"2017-03-22T16:56:53Z","isPatch":true,"sender":{"key":"stefanbeller@gmail.com","avatar":"https://avatars.githubusercontent.com/u/455868?v=4"},"body":"This was an oversight in 55856a35b2 (rm: absorb a submodules git dir\nbefore deletion, 2016-12-27), as the body of the test changed without\nadapting the test subject.\n\nSigned-off-by: Stefan Beller <sbeller@google.com>\nReviewed-by: Jonathan Nieder <jrnieder@gmail.com>\n---\n t/t3600-rm.sh | 2 +-\n 1 file changed, 1 insertion(+), 1 deletion(-)\n\ndiff --git a/t/t3600-rm.sh b/t/t3600-rm.sh\nindex 5aa6db584c..e94da6b5f1 100755\n--- a/t/t3600-rm.sh\n+++ b/t/t3600-rm.sh\n@@ -658,7 +658,7 @@ test_expect_success 'rm of a populated nested submodule with nested untracked fi\n \ttest_cmp expect actual\n '\n \n-test_expect_success 'rm of a populated nested submodule with a nested .git directory fails even when forced' '\n+test_expect_success 'rm absorbs .git directory of nested submodule' '\n \tgit reset --hard &&\n \tgit submodule update --recursive &&\n \t(cd submod/subsubmod &&\n-- \n2.12.0.rc1.47.g25804914fa.dirty\n\n"},{"id":"314938","messageId":"20170322182259.GA26108@aiede.mtv.corp.google.com","threadId":"45458","inReplyTo":"20170322165639.21658-1-sbeller@google.com","subject":"Re: [PATCH] t3600: rename test to describe its functionality","fromName":"Jonathan Nieder","fromEmail":"jrnieder@gmail.com","sentAt":"2017-03-22T18:22:59Z","receivedAt":"2017-03-22T18:23:37Z","isPatch":true,"sender":{"key":"jrnieder@gmail.com","avatar":"https://avatars.githubusercontent.com/u/281595?v=4"},"body":"Stefan Beller wrote:\n\n> This was an oversight in 55856a35b2 (rm: absorb a submodules git dir\n> before deletion, 2016-12-27), as the body of the test changed without\n> adapting the test subject.\n>\n> Signed-off-by: Stefan Beller <sbeller@google.com>\n> Reviewed-by: Jonathan Nieder <jrnieder@gmail.com>\n\nYup.  Thanks for taking care of it.\n\nJonathan\n"}]}