{"thread":{"id":"4419","subject":"[PATCH] Some doc typo fixes","startedAt":"2006-06-07T12:56:45Z","lastAt":"2006-06-08T07:22:57Z","messageCount":5,"participants":["Francis Daly","Junio C Hamano","Andreas Ericsson"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"21376","messageId":"20060607125644.GT29682@craic.sysops.org","threadId":"4419","inReplyTo":null,"subject":"[PATCH] Some doc typo fixes","fromName":"Francis Daly","fromEmail":"francis@daoine.org","sentAt":"2006-06-07T12:56:45Z","receivedAt":"2006-06-07T12:56:45Z","isPatch":true,"sender":{"key":"francis@daoine.org","avatar":null},"body":"\nAll should be clear enough, except perhaps committish / commitish.\nI just kept the more-used one within the current docs.\n\nSigned-off-by: Francis Daly <francis@daoine.org>\n\n\n---\n\n271f459c2fec6898d913bbc040a71be067e0d009\n Documentation/config.txt               |    6 +++---\n Documentation/cvs-migration.txt        |    2 +-\n Documentation/everyday.txt             |    2 +-\n Documentation/git-check-ref-format.txt |    2 +-\n Documentation/git-describe.txt         |    2 +-\n Documentation/git-name-rev.txt         |    2 +-\n Documentation/git-p4import.txt         |    2 +-\n Documentation/git-read-tree.txt        |    2 +-\n Documentation/hooks.txt                |    2 +-\n Documentation/tutorial.txt             |    2 +-\n 10 files changed, 12 insertions(+), 12 deletions(-)\n\n271f459c2fec6898d913bbc040a71be067e0d009\ndiff --git a/Documentation/config.txt b/Documentation/config.txt\nindex c861c6c..4ce7867 100644\n--- a/Documentation/config.txt\n+++ b/Documentation/config.txt\n@@ -113,12 +113,12 @@ gitcvs.logfile::\n \n http.sslVerify::\n \tWhether to verify the SSL certificate when fetching or pushing\n-\tover HTTPS. Can be overriden by the 'GIT_SSL_NO_VERIFY' environment\n+\tover HTTPS. Can be overridden by the 'GIT_SSL_NO_VERIFY' environment\n \tvariable.\n \n http.sslCert::\n \tFile containing the SSL certificate when fetching or pushing\n-\tover HTTPS. Can be overriden by the 'GIT_SSL_CERT' environment\n+\tover HTTPS. Can be overridden by the 'GIT_SSL_CERT' environment\n \tvariable.\n \n http.sslKey::\n@@ -133,7 +133,7 @@ http.sslCAInfo::\n \n http.sslCAPath::\n \tPath containing files with the CA certificates to verify the peer\n-\twith when fetching or pushing over HTTPS. Can be overriden\n+\twith when fetching or pushing over HTTPS. Can be overridden\n \tby the 'GIT_SSL_CAPATH' environment variable.\n \n http.maxRequests::\ndiff --git a/Documentation/cvs-migration.txt b/Documentation/cvs-migration.txt\nindex 826d089..1fbca83 100644\n--- a/Documentation/cvs-migration.txt\n+++ b/Documentation/cvs-migration.txt\n@@ -106,7 +106,7 @@ Make sure committers have a umask of at \n they create are writable and searchable by other group members.\n \n Suppose this repository is now set up in /pub/repo.git on the host\n-foo.com.  Then as an individual commiter you can clone the shared\n+foo.com.  Then as an individual committer you can clone the shared\n repository:\n \n ------------------------------------------------\ndiff --git a/Documentation/everyday.txt b/Documentation/everyday.txt\nindex 6745ab5..b935c18 100644\n--- a/Documentation/everyday.txt\n+++ b/Documentation/everyday.txt\n@@ -45,7 +45,7 @@ Everybody uses these commands to feed an\n \n   * gitlink:git-fsck-objects[1] to validate the repository.\n \n-  * gitlink:git-prune[1] to garbage collect crufts in the\n+  * gitlink:git-prune[1] to garbage collect cruft in the\n     repository.\n \n   * gitlink:git-repack[1] to pack loose objects for efficiency.\ndiff --git a/Documentation/git-check-ref-format.txt b/Documentation/git-check-ref-format.txt\nindex 3ea720d..cb9c162 100644\n--- a/Documentation/git-check-ref-format.txt\n+++ b/Documentation/git-check-ref-format.txt\n@@ -20,7 +20,7 @@ a tag is stored under `$GIT_DIR/refs/tag\n imposes the following rules on how refs are named:\n \n . It could be named hierarchically (i.e. separated with slash\n-  `/`), but each of its component cannot begin with a dot `.`;\n+  `/`), but each of its components cannot begin with a dot `.`;\n \n . It cannot have two consecutive dots `..` anywhere;\n \ndiff --git a/Documentation/git-describe.txt b/Documentation/git-describe.txt\nindex 7a253ea..7cc14b7 100644\n--- a/Documentation/git-describe.txt\n+++ b/Documentation/git-describe.txt\n@@ -21,7 +21,7 @@ object name of the commit.\n OPTIONS\n -------\n <committish>::\n-\tThe object name of the comittish. \n+\tThe object name of the committish. \n \n --all::\n \tInstead of using only the annotated tags, use any ref\ndiff --git a/Documentation/git-name-rev.txt b/Documentation/git-name-rev.txt\nindex ffaa004..39a1434 100644\n--- a/Documentation/git-name-rev.txt\n+++ b/Documentation/git-name-rev.txt\n@@ -8,7 +8,7 @@ git-name-rev - Find symbolic names for g\n \n SYNOPSIS\n --------\n-'git-name-rev' [--tags] ( --all | --stdin | <commitish>... )\n+'git-name-rev' [--tags] ( --all | --stdin | <committish>... )\n \n DESCRIPTION\n -----------\ndiff --git a/Documentation/git-p4import.txt b/Documentation/git-p4import.txt\nindex b8ff1e9..c198ff2 100644\n--- a/Documentation/git-p4import.txt\n+++ b/Documentation/git-p4import.txt\n@@ -128,7 +128,7 @@ Therefore after the import you can use g\n Perforce number, eg. git show p4/327.\n \n The tag associated with the HEAD commit is also how `git-p4import`\n-determines if their are new changes to incrementally import from the\n+determines if there are new changes to incrementally import from the\n Perforce repository.\n \n If you import from a repository with many thousands of changes\ndiff --git a/Documentation/git-read-tree.txt b/Documentation/git-read-tree.txt\nindex 02c7e99..d894f53 100644\n--- a/Documentation/git-read-tree.txt\n+++ b/Documentation/git-read-tree.txt\n@@ -257,7 +257,7 @@ file that does not match stage 2.\n This is done to prevent you from losing your work-in-progress\n changes, and mixing your random changes in an unrelated merge\n commit.  To illustrate, suppose you start from what has been\n-commited last to your repository:\n+committed last to your repository:\n \n ----------------\n $ JC=`git-rev-parse --verify \"HEAD^0\"`\ndiff --git a/Documentation/hooks.txt b/Documentation/hooks.txt\nindex e3dde39..898b4aa 100644\n--- a/Documentation/hooks.txt\n+++ b/Documentation/hooks.txt\n@@ -100,7 +100,7 @@ update\n This hook is invoked by `git-receive-pack` on the remote repository,\n which is happens when a `git push` is done on a local repository.\n Just before updating the ref on the remote repository, the update hook\n-is invoked.  It's exit status determines the success or failure of\n+is invoked.  Its exit status determines the success or failure of\n the ref update.\n \n The hook executes once for each ref to be updated, and takes\ndiff --git a/Documentation/tutorial.txt b/Documentation/tutorial.txt\nindex db56312..554ee0a 100644\n--- a/Documentation/tutorial.txt\n+++ b/Documentation/tutorial.txt\n@@ -357,7 +357,7 @@ names.  For example:\n $ git branch stable v2.5 # start a new branch named \"stable\" based\n \t\t\t # at v2.5\n $ git reset --hard HEAD^ # reset your current branch and working\n-\t\t\t # directory its state at HEAD^\n+\t\t\t # directory to its state at HEAD^\n -------------------------------------\n \n Be careful with that last command: in addition to losing any changes\n-- \n1.3.3.g63df-dirty\n\n-- \nFrancis Daly        francis@daoine.org\n"},{"id":"21383","messageId":"7v1wu0lxnd.fsf@assigned-by-dhcp.cox.net","threadId":"4419","inReplyTo":"20060607125644.GT29682@craic.sysops.org","subject":"Re: [PATCH] Some doc typo fixes","fromName":"Junio C Hamano","fromEmail":"junkio@cox.net","sentAt":"2006-06-07T16:48:38Z","receivedAt":"2006-06-07T16:48:38Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Francis Daly <francis@daoine.org> writes:\n\n> All should be clear enough, except perhaps committish / commitish.\n> I just kept the more-used one within the current docs.\n\nThanks.  I am not a native, and this is very much appreciated.\n\n>  . It could be named hierarchically (i.e. separated with slash\n> -  `/`), but each of its component cannot begin with a dot `.`;\n> +  `/`), but each of its components cannot begin with a dot `.`;\n\nI am not sure; shouldn't the wording be \"each of <plural>\" to mean\n\"there are/can be more than one, and you look at them one by one\nand make sure the condition holds for each of them\" (oops,\nthat's cyclic explanation and I failed to paraphrase it without\nusing \"each of\")???\n\nAll the others look good.  Thanks.\n"},{"id":"21385","messageId":"7vwtbshp3d.fsf@assigned-by-dhcp.cox.net","threadId":"4419","inReplyTo":"7v1wu0lxnd.fsf@assigned-by-dhcp.cox.net","subject":"Re: [PATCH] Some doc typo fixes","fromName":"Junio C Hamano","fromEmail":"junkio@cox.net","sentAt":"2006-06-07T17:07:02Z","receivedAt":"2006-06-07T17:07:02Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Junio C Hamano <junkio@cox.net> writes:\n\n> Francis Daly <francis@daoine.org> writes:\n>\n>> All should be clear enough, except perhaps committish / commitish.\n>> I just kept the more-used one within the current docs.\n>\n> Thanks.  I am not a native, and this is very much appreciated.\n>\n>>  . It could be named hierarchically (i.e. separated with slash\n>> -  `/`), but each of its component cannot begin with a dot `.`;\n>> +  `/`), but each of its components cannot begin with a dot `.`;\n>\n> I am not sure; ...\n\nSheesh, I was reading the diff backwards.  Sorry.\n\n> All the others look good.  Thanks.\n\nAll of them look obviously correct, it wasn't just obvious to me\nwithout enough caffeine.\n\nSorry for the noise.\n"},{"id":"21386","messageId":"20060607174614.GU29682@craic.sysops.org","threadId":"4419","inReplyTo":"7vwtbshp3d.fsf@assigned-by-dhcp.cox.net","subject":"Re: [PATCH] Some doc typo fixes","fromName":"Francis Daly","fromEmail":"francis@daoine.org","sentAt":"2006-06-07T17:46:14Z","receivedAt":"2006-06-07T17:46:14Z","isPatch":true,"sender":{"key":"francis@daoine.org","avatar":null},"body":"On Wed, Jun 07, 2006 at 10:07:02AM -0700, Junio C Hamano wrote:\n> Junio C Hamano <junkio@cox.net> writes:\n> > Francis Daly <francis@daoine.org> writes:\n\n> > Thanks.  I am not a native, and this is very much appreciated.\n\nYou're welcome.\n\n> >>  . It could be named hierarchically (i.e. separated with slash\n> >> -  `/`), but each of its component cannot begin with a dot `.`;\n> >> +  `/`), but each of its components cannot begin with a dot `.`;\n> >\n> > I am not sure; ...\n> \n> Sheesh, I was reading the diff backwards.  Sorry.\n\nNo worries.  I had a head-scratching moment, and suspect that the whole\nstanza could be better phrased.  If only there was someone who didn't\nalready know what it means, they could suggest which phrasing makes\nit clear...\n\nHow about rewriting it as\n\nIt can include slash `/` for hierarchical (directory) grouping, but no\nslash-separated component can begin with a dot `.`;\n\n?\n\n\"can\" instead of \"could\" fits the later parts, and it removes the\npossessive and reverses the negative for something that (to my mind)\nscans better.\n\nCheers,\n\n\tf\n-- \nFrancis Daly        francis@daoine.org\n"},{"id":"21414","messageId":"4487D051.6020802@op5.se","threadId":"4419","inReplyTo":"20060607174614.GU29682@craic.sysops.org","subject":"Re: [PATCH] Some doc typo fixes","fromName":"Andreas Ericsson","fromEmail":"ae@op5.se","sentAt":"2006-06-08T07:22:57Z","receivedAt":"2006-06-08T07:22:57Z","isPatch":true,"sender":{"key":"ae@op5.se","avatar":"https://gravatar.com/avatar/426e89595c75a8f5252dd0c989e5fabe5bcac616e68557427ad9aef6b0ca342a?d=mp&s=160"},"body":"Francis Daly wrote:\n> On Wed, Jun 07, 2006 at 10:07:02AM -0700, Junio C Hamano wrote:\n> \n>>Junio C Hamano <junkio@cox.net> writes:\n>>\n>>>Francis Daly <francis@daoine.org> writes:\n> \n> \n>>>Thanks.  I am not a native, and this is very much appreciated.\n> \n> \n> You're welcome.\n> \n> \n>>>> . It could be named hierarchically (i.e. separated with slash\n>>>>-  `/`), but each of its component cannot begin with a dot `.`;\n>>>>+  `/`), but each of its components cannot begin with a dot `.`;\n>>>\n>>>I am not sure; ...\n>>\n>>Sheesh, I was reading the diff backwards.  Sorry.\n> \n> \n> No worries.  I had a head-scratching moment, and suspect that the whole\n> stanza could be better phrased.  If only there was someone who didn't\n> already know what it means, they could suggest which phrasing makes\n> it clear...\n> \n> How about rewriting it as\n> \n> It can include slash `/` for hierarchical (directory) grouping, but no\n> slash-separated component can begin with a dot `.`;\n> \n> ?\n> \n\nI like it.\n\n-- \nAndreas Ericsson                   andreas.ericsson@op5.se\nOP5 AB                             www.op5.se\nTel: +46 8-230225                  Fax: +46 8-230231\n"}]}