{"thread":{"id":"42548","subject":"[ANNOUNCE] Git v2.8.4","startedAt":"2016-06-07T05:57:53Z","lastAt":"2016-06-07T05:57:53Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"288518","messageId":"xmqq4m95tuam.fsf@gitster.mtv.corp.google.com","threadId":"42548","inReplyTo":null,"subject":"[ANNOUNCE] Git v2.8.4","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2016-06-07T05:57:53Z","receivedAt":"2016-06-07T05:57:53Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"The latest maintenance release Git v2.8.4 is now available at\nthe usual places.\n\nThe tarballs are found at:\n\n    https://www.kernel.org/pub/software/scm/git/\n\nThe following public repositories all have a copy of the 'v2.8.4'\ntag and the 'maint' branch that the tag points at:\n\n  url = https://kernel.googlesource.com/pub/scm/git/git\n  url = git://repo.or.cz/alt-git.git\n  url = git://git.sourceforge.jp/gitroot/git-core/git.git\n  url = git://git-core.git.sourceforge.net/gitroot/git-core/git-core\n  url = https://github.com/gitster/git\n\n----------------------------------------------------------------\n\nGit v2.8.4 Release Notes\n========================\n\nFixes since v2.8.3\n------------------\n\n * Documentation for \"git merge --verify-signatures\" has been updated\n   to clarify that the signature of only the commit at the tip is\n   verified.  Also the phrasing used for signature and key validity is\n   adjusted to align with that used by OpenPGP.\n\n * On Windows, .git and optionally any files whose name starts with a\n   dot are now marked as hidden, with a core.hideDotFiles knob to\n   customize this behaviour.\n\n * Portability enhancement for \"rebase -i\" to help platforms whose\n   shell does not like \"for i in <empty>\" (which is not POSIX-kosher).\n\n * \"git fsck\" learned to catch NUL byte in a commit object as\n   potential error and warn.\n\n * CI test was taught to build documentation pages.\n\n * Many 'linkgit:<git documentation page>' references were broken,\n   which are all fixed with this.\n\n * \"git describe --contains\" often made a hard-to-justify choice of\n   tag to give name to a given commit, because it tried to come up\n   with a name with smallest number of hops from a tag, causing an old\n   commit whose close descendant that is recently tagged were not\n   described with respect to an old tag but with a newer tag.  It did\n   not help that its computation of \"hop\" count was further tweaked to\n   penalize being on a side branch of a merge.  The logic has been\n   updated to favor using the tag with the oldest tagger date, which\n   is a lot easier to explain to the end users: \"We describe a commit\n   in terms of the (chronologically) oldest tag that contains the\n   commit.\"\n\n * Running tests with '-x' option to trace the individual command\n   executions is a useful way to debug test scripts, but some tests\n   that capture the standard error stream and check what the command\n   said can be broken with the trace output mixed in.  When running\n   our tests under \"bash\", however, we can redirect the trace output\n   to another file descriptor to keep the standard error of programs\n   being tested intact.\n\n * \"http.cookieFile\" configuration variable clearly wants a pathname,\n   but we forgot to treat it as such by e.g. applying tilde expansion.\n\n * When de-initialising all submodules, \"git submodule deinit\" gave a\n   faulty recommendation to use \"git submodule deinit .\", which would\n   result in a strange error message in a pathological corner case.\n   This has been corrected to suggest \"submodule deinit --all\" instead.\n\n * Many commands normalize command line arguments from NFD to NFC\n   variant of UTF-8 on OSX, but commands in the \"diff\" family did\n   not, causing \"git diff $path\" to complain that no such path is\n   known to Git.  They have been taught to do the normalization.\n\n * A couple of bugs around core.autocrlf have been fixed.\n\n * \"git difftool\" learned to handle unmerged paths correctly in\n   dir-diff mode.\n\n * The \"are we talking with TTY, doing an interactive session?\"\n   detection has been updated to work better for \"Git for Windows\".\n\n\nAlso contains other minor documentation updates and code clean-ups.\n\n----------------------------------------------------------------\n\nChanges since v2.8.3 are as follows:\n\nAlexander Rinass (1):\n      diff: run arguments through precompose_argv\n\nArmin Kunaschik (1):\n      t4151: make sure argument to 'test -z' is given\n\nBrian Norris (3):\n      Documentation: config: improve word ordering for http.cookieFile\n      http: expand http.cookieFile as a path\n      config: consistently format $variables in monospaced font\n\nDavid Aguilar (2):\n      difftool: initialize variables for readability\n      difftool: handle unmerged files in dir-diff mode\n\nJeff King (3):\n      rebase--interactive: avoid empty list in shell for-loop\n      test-lib: set BASH_XTRACEFD automatically\n      archive-tar: convert snprintf to xsnprintf\n\nJohannes Schindelin (3):\n      name-rev: include taggerdate in considering the best name\n      mingw: introduce the 'core.hideDotFiles' setting\n      mingw: remove unnecessary definition\n\nJunio C Hamano (9):\n      fsck_commit_buffer(): do not special case the last validation\n      config: describe 'pathname' value type\n      test-lib-functions.sh: remove misleading comment on test_seq\n      test-lib-functions.sh: rewrite test_seq without Perl\n      Documentation: fix linkgit references\n      fsck: detect and warn a commit with embedded NUL\n      Start preparing for 2.8.4\n      More topics for 2.8.4\n      Git 2.8.4\n\nKarsten Blees (1):\n      mingw: make isatty() recognize MSYS2's pseudo terminals (/dev/pty*)\n\nKeller Fuchs (1):\n      Documentation: clarify signature verification\n\nLars Schneider (1):\n      travis-ci: build documentation\n\nLi Peng (1):\n      typofix: assorted typofixes in comments, documentation and messages\n\nNguyễn Thái Ngọc Duy (1):\n      remote.c: specify correct plural form in \"commit diverge\" message\n\nStefan Beller (3):\n      submodule deinit: require '--all' instead of '.' for all submodules\n      t3513: do not compress backup tar file\n      t6041: do not compress backup tar file\n\nTorsten Bögershausen (5):\n      t0027: make commit_chk_wrnNNO() reliable\n      convert: allow core.autocrlf=input and core.eol=crlf\n      t0027: test cases for combined attributes\n      convert.c: ident + core.autocrlf didn't work\n      t5601: Remove trailing space in sed expression\n\nVasco Almeida (12):\n      i18n: index-pack: use plural string instead of normal one\n      i18n: builtin/branch.c: mark option for translation\n      i18n: unpack-trees: mark strings for translation\n      i18n: builtin/rm.c: remove a comma ',' from string\n      i18n: branch: unmark string for translation\n      i18n: branch: move comment for translators\n      i18n: git-parse-remote.sh: mark strings for translation\n      i18n: builtin/pull.c: mark placeholders for translation\n      i18n: builtin/pull.c: split strings marked for translation\n      i18n: remote: add comment for translators\n      Documentation/git-mailinfo: fix typo\n      i18n: unpack-trees: avoid substituting only a verb in sentences\n"}]}