{"thread":{"id":"41451","subject":"[PATCH] tests: rename work-tree tests to *work-tree*","startedAt":"2016-02-20T16:18:41Z","lastAt":"2016-02-22T17:57:33Z","messageCount":4,"participants":["Michael J Gruber","Junio C Hamano"],"isPatch":true,"patchVersion":1,"patchTotal":null},"messages":[{"id":"278737","messageId":"2e74b7a8e3dd27ccd225b5278500f8a3e029d245.1455985042.git.git@drmicha.warpmail.net","threadId":"41451","inReplyTo":null,"subject":"[PATCH] tests: rename work-tree tests to *work-tree*","fromName":"Michael J Gruber","fromEmail":"git@drmicha.warpmail.net","sentAt":"2016-02-20T16:18:41Z","receivedAt":"2016-02-20T16:18:41Z","isPatch":true,"sender":{"key":"git@grubix.eu","avatar":"https://avatars.githubusercontent.com/u/233215?v=4"},"body":"\"Work tree\" or \"working tree\" is the name of a checked out tree,\n\"worktree\" the name of the command which manages several working trees.\nThe naming of tests mixes these two, currently:\n\n$ls t/*worktree*\nt/t1501-worktree.sh\nt/t1509-root-worktree.sh\nt/t2025-worktree-add.sh\nt/t2026-worktree-prune.sh\nt/t2027-worktree-list.sh\nt/t2104-update-index-skip-worktree.sh\nt/t3320-notes-merge-worktrees.sh\nt/t7011-skip-worktree-reading.sh\nt/t7012-skip-worktree-writing.sh\nt/t7409-submodule-detached-worktree.sh\n\n$grep -l \"git worktree\" t/*.sh\nt/t0002-gitfile.sh\nt/t1400-update-ref.sh\nt/t2025-worktree-add.sh\nt/t2026-worktree-prune.sh\nt/t2027-worktree-list.sh\nt/t3320-notes-merge-worktrees.sh\nt/t7410-submodule-checkout-to.sh\n\nRename t1501, t1509 and t7409 to make it clear on first glance that they\ntest work tree related behavior, rather than the worktree command.\n\nt2104, t7011 and t7012 are about the \"skip-worktree\" flag so that their\nname should remain unchanged.\n\nSigned-off-by: Michael J Gruber <git@drmicha.warpmail.net>\n---\nJust some housekeeping. Not super necessary, but should make it easier to find\nthe right test to amend, for example.\n\n t/{t1501-worktree.sh => t1501-work-tree.sh}                               | 0\n t/{t1509-root-worktree.sh => t1509-root-work-tree.sh}                     | 0\n ...bmodule-detached-worktree.sh => t7409-submodule-detached-work-tree.sh} | 0\n 3 files changed, 0 insertions(+), 0 deletions(-)\n rename t/{t1501-worktree.sh => t1501-work-tree.sh} (100%)\n rename t/{t1509-root-worktree.sh => t1509-root-work-tree.sh} (100%)\n rename t/{t7409-submodule-detached-worktree.sh => t7409-submodule-detached-work-tree.sh} (100%)\n\ndiff --git a/t/t1501-worktree.sh b/t/t1501-work-tree.sh\nsimilarity index 100%\nrename from t/t1501-worktree.sh\nrename to t/t1501-work-tree.sh\ndiff --git a/t/t1509-root-worktree.sh b/t/t1509-root-work-tree.sh\nsimilarity index 100%\nrename from t/t1509-root-worktree.sh\nrename to t/t1509-root-work-tree.sh\ndiff --git a/t/t7409-submodule-detached-worktree.sh b/t/t7409-submodule-detached-work-tree.sh\nsimilarity index 100%\nrename from t/t7409-submodule-detached-worktree.sh\nrename to t/t7409-submodule-detached-work-tree.sh\n-- \n2.7.1.428.g2de392b\n"},{"id":"278742","messageId":"xmqqfuwn9hyp.fsf@gitster.mtv.corp.google.com","threadId":"41451","inReplyTo":"2e74b7a8e3dd27ccd225b5278500f8a3e029d245.1455985042.git.git@drmicha.warpmail.net","subject":"Re: [PATCH] tests: rename work-tree tests to *work-tree*","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2016-02-20T21:42:38Z","receivedAt":"2016-02-20T21:42:38Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Michael J Gruber <git@drmicha.warpmail.net> writes:\n\n> \"Work tree\" or \"working tree\" is the name of a checked out tree,\n> \"worktree\" the name of the command which manages several working trees.\n> The naming of tests mixes these two, currently:\n>\n> $ls t/*worktree*\n> ...\n> Rename t1501, t1509 and t7409 to make it clear on first glance that they\n> test work tree related behavior, rather than the worktree command.\n>\n> t2104, t7011 and t7012 are about the \"skip-worktree\" flag so that their\n> name should remain unchanged.\n>\n> Signed-off-by: Michael J Gruber <git@drmicha.warpmail.net>\n> ---\n> Just some housekeeping. Not super necessary, but should make it easier to find\n> the right test to amend, for example.\n\nThat is rather unfortunate.  Most of them predate the \"worktree\"\nsubcommand, I think, and having to rename them merely because a\nsubcommand with a confusing name appeared sound somewhat backwards.\n"},{"id":"278858","messageId":"56CAE460.8010405@drmicha.warpmail.net","threadId":"41451","inReplyTo":"xmqqfuwn9hyp.fsf@gitster.mtv.corp.google.com","subject":"Re: [PATCH] tests: rename work-tree tests to *work-tree*","fromName":"Michael J Gruber","fromEmail":"git@drmicha.warpmail.net","sentAt":"2016-02-22T10:35:12Z","receivedAt":"2016-02-22T10:35:12Z","isPatch":true,"sender":{"key":"git@grubix.eu","avatar":"https://avatars.githubusercontent.com/u/233215?v=4"},"body":"Junio C Hamano venit, vidit, dixit 20.02.2016 22:42:\n> Michael J Gruber <git@drmicha.warpmail.net> writes:\n> \n>> \"Work tree\" or \"working tree\" is the name of a checked out tree,\n>> \"worktree\" the name of the command which manages several working trees.\n>> The naming of tests mixes these two, currently:\n>>\n>> $ls t/*worktree*\n>> ...\n>> Rename t1501, t1509 and t7409 to make it clear on first glance that they\n>> test work tree related behavior, rather than the worktree command.\n>>\n>> t2104, t7011 and t7012 are about the \"skip-worktree\" flag so that their\n>> name should remain unchanged.\n>>\n>> Signed-off-by: Michael J Gruber <git@drmicha.warpmail.net>\n>> ---\n>> Just some housekeeping. Not super necessary, but should make it easier to find\n>> the right test to amend, for example.\n> \n> That is rather unfortunate.  Most of them predate the \"worktree\"\n> subcommand, I think, and having to rename them merely because a\n> subcommand with a confusing name appeared sound somewhat backwards.\n\nThe question is: What ist the way forward?\n\nI was looking for a proper place for a \"git worktree\" test and got\nconfused by the status quo. My suggestion is one way to help that\nconfusion, but I'd be happy to learn other ways. \"grep\" is an answer, too.\n\nMaybe it's also time to admit that the numbering and naming scheme in t/\ndon't scale and that we should rather support other means of navigating\nt/, such as standardizing a comment boiler plate in each test or such.\n\nIn fact, giving up on the numbering scheme would allow to regroup tests\nmore easily because there would be no room constraint any more (within a\nfixed finite set of numbers).\n\nMichael\n"},{"id":"278887","messageId":"xmqqzius7hma.fsf@gitster.mtv.corp.google.com","threadId":"41451","inReplyTo":"56CAE460.8010405@drmicha.warpmail.net","subject":"Re: [PATCH] tests: rename work-tree tests to *work-tree*","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2016-02-22T17:57:33Z","receivedAt":"2016-02-22T17:57:33Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Michael J Gruber <git@drmicha.warpmail.net> writes:\n\n>> That is rather unfortunate.  Most of them predate the \"worktree\"\n>> subcommand, I think, and having to rename them merely because a\n>> subcommand with a confusing name appeared sound somewhat backwards.\n>\n> The question is: What ist the way forward?\n\nProbably many.  Take this as-is is one, rename newer ones that are\nabout worktree subcommand to \"s/worktree/worktree-cmd/\" would be\nanother.\n\n> I was looking for a proper place for a \"git worktree\" test and got\n> confused by the status quo. My suggestion is one way to help that\n> confusion, but I'd be happy to learn other ways. \"grep\" is an answer, too.\n>\n> Maybe it's also time to admit that the numbering and naming scheme in t/\n> don't scale and that we should rather support other means of navigating\n> t/, such as standardizing a comment boiler plate in each test or such.\n\nYeah, test_description at the beginning of each test may have been a\nwell meaning attempt, but it is not helping us very much.\n\n> In fact, giving up on the numbering scheme would allow to regroup tests\n> more easily because there would be no room constraint any more (within a\n> fixed finite set of numbers).\n\nI tend to agree that may be an easier way forward in the longer\nterm.\n\nThanks.\n"}]}