{"thread":{"id":"39661","subject":"slash in branch name","startedAt":"2015-06-17T19:16:10Z","lastAt":"2015-06-17T19:38:57Z","messageCount":3,"participants":["KK","Jeff King"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"264058","messageId":"5581C77A.3040703@wp.pl","threadId":"39661","inReplyTo":null,"subject":"slash in branch name","fromName":"KK","fromEmail":"horizn@wp.pl","sentAt":"2015-06-17T19:16:10Z","receivedAt":"2015-06-17T19:16:10Z","isPatch":false,"sender":{"key":"horizn@wp.pl","avatar":null},"body":"Hi,\n\nAfter upgrade GIT from 1.7.2.5-3.1 to 1.7.10.4-1+wheezy1 following error \nappear:\n\ngit push central versions/4.3.2\nCounting objects: 45, done.\nDelta compression using up to 8 threads.\nCompressing objects: 100% (28/28), done.\nWriting objects: 100% (28/28), 13.01 KiB, done.\nTotal 28 (delta 22), reused 0 (delta 0)\nremote: Update script started: Tue Jun 9 13:25:34 BST 2015\nremote: Arguments: refs/heads/versions/4.3.2\n2e5233728aecc6ac337f4d3a9f32281e7c786e27\nae25cc33f6cf745cfa1061cbdfaf445344a60d13\nremote: Warning: using temporary hooks\nremote: error: invalid key: hooks.denypush.branch.versions/4.3.2\nremote: error: invalid key: hooks.allowmerge.versions/4.3.2\nremote: Packages changed by this update:\nremote:   think_3\nremote:   hls_plugin_1\nremote:   hal_av_1\nremote:   rtsp_plugin_1\nremote: Notifying the following package owners of this update:\n\nhooks were downloaded from:\ngit://git.et.redhat.com/ovirt-server.git\n\nMy colleague did some research about that and it seems that this commit \nhas stopped update hook working:\n\ncommit b09c53a3e331211fc0154de8ebb271e48f8c7ee5\nAuthor: Libor Pechacek <lpechacek@suse.cz>\nDate:   Sun Jan 30 20:40:41 2011 +0100\n\n     Sanity-check config variable names\n\n     Sanity-check config variable names when adding and retrieving them. \n  As a side\n     effect code duplication between git_config_set_multivar and \nget_value (in\n     builtin/config.c) was removed and the common functionality was \nplaced in\n     git_config_parse_key.\n\n     This breaks a test in t1300 which used invalid section-less keys in \nthe tests\n     for \"git -c\". However, allowing such names there was useless, since \nthere was\n     no way to set them via config file, and no part of git actually \ntried to use\n     section-less keys. This patch updates the test to use more \nrealistic examples\n     as well as adding its own test.\n\n     Signed-off-by: Libor Pechacek <lpechacek@suse.cz>\n     Acked-by: Jeff King <peff@peff.net>\n     Signed-off-by: Junio C Hamano <gitster@pobox.com>\n\n\nCould you please advise how to fix/revert this?\n\nbrgds,\n"},{"id":"264061","messageId":"20150617192444.GD25304@peff.net","threadId":"39661","inReplyTo":"5581C77A.3040703@wp.pl","subject":"Re: slash in branch name","fromName":"Jeff King","fromEmail":"peff@peff.net","sentAt":"2015-06-17T19:24:45Z","receivedAt":"2015-06-17T19:24:45Z","isPatch":false,"sender":{"key":"peff@peff.net","avatar":"https://avatars.githubusercontent.com/u/45925?v=4"},"body":"On Wed, Jun 17, 2015 at 08:16:10PM +0100, KK wrote:\n\n> remote: error: invalid key: hooks.denypush.branch.versions/4.3.2\n> remote: error: invalid key: hooks.allowmerge.versions/4.3.2\n> [...]\n\nThose are syntactically bogus config keys. Keys should be of the form\n\n  section.subsection.key\n\nand only \"subsection\" can contain arbitrary bytes (and of course the\nvalue can, too). The hooks running on the server are using git's config\nsystem in ways that were not intended.  It should rearrange its\norganization of the data (I cannot comment much further without seeing\nthe hooks themselves).\n\n> My colleague did some research about that and it seems that this commit has\n> stopped update hook working:\n> \n> commit b09c53a3e331211fc0154de8ebb271e48f8c7ee5\n> Author: Libor Pechacek <lpechacek@suse.cz>\n> Date:   Sun Jan 30 20:40:41 2011 +0100\n> \n>     Sanity-check config variable names\n> [...]\n> \n> Could you please advise how to fix/revert this?\n\nI guess we could add a \"--no-really-i-am-abusing-git-config\" option to\ngit-config to let these pass, at least for lookups. I am not sure that\nis a good idea, though. I think your hooks are fundamentally broken for\nbranches with odd characters (right now you are seeing complaints on the\nlookup side, but I suspect that you could not write a\n\"hooks.denypush.branch.versions/4.3.2\" entry if you wanted to, as git\nwould choke on reading the config file).\n\n-Peff\n"},{"id":"264068","messageId":"5581CCD1.4010606@wp.pl","threadId":"39661","inReplyTo":"20150617192444.GD25304@peff.net","subject":"Re: slash in branch name","fromName":"KK","fromEmail":"horizn@wp.pl","sentAt":"2015-06-17T19:38:57Z","receivedAt":"2015-06-17T19:38:57Z","isPatch":false,"sender":{"key":"horizn@wp.pl","avatar":null},"body":"On 17/06/2015 20:24, Jeff King wrote:\n> On Wed, Jun 17, 2015 at 08:16:10PM +0100, KK wrote:\n>\n>> remote: error: invalid key: hooks.denypush.branch.versions/4.3.2\n>> remote: error: invalid key: hooks.allowmerge.versions/4.3.2\n>> [...]\n>\n> Those are syntactically bogus config keys. Keys should be of the form\n>\n>    section.subsection.key\n>\n> and only \"subsection\" can contain arbitrary bytes (and of course the\n> value can, too). The hooks running on the server are using git's config\n> system in ways that were not intended.  It should rearrange its\n> organization of the data (I cannot comment much further without seeing\n> the hooks themselves).\n>\n>> My colleague did some research about that and it seems that this commit has\n>> stopped update hook working:\n>>\n>> commit b09c53a3e331211fc0154de8ebb271e48f8c7ee5\n>> Author: Libor Pechacek <lpechacek@suse.cz>\n>> Date:   Sun Jan 30 20:40:41 2011 +0100\n>>\n>>      Sanity-check config variable names\n>> [...]\n>>\n>> Could you please advise how to fix/revert this?\n>\n> I guess we could add a \"--no-really-i-am-abusing-git-config\" option to\n> git-config to let these pass, at least for lookups. I am not sure that\n> is a good idea, though. I think your hooks are fundamentally broken for\n> branches with odd characters (right now you are seeing complaints on the\n> lookup side, but I suspect that you could not write a\n> \"hooks.denypush.branch.versions/4.3.2\" entry if you wanted to, as git\n> would choke on reading the config file).\n>\n> -Peff\n>\n>\n\nhooks were downloaded from:\ngit://git.et.redhat.com/ovirt-server.git\n"}]}