{"thread":{"id":"39333","subject":"cmd_struct","startedAt":"2015-05-13T23:10:47Z","lastAt":"2015-05-14T07:49:30Z","messageCount":5,"participants":["Thiago Farina","Jonathan Nieder","Junio C Hamano","Johannes Schindelin"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"261211","messageId":"CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com","threadId":"39333","inReplyTo":null,"subject":"cmd_struct","fromName":"Thiago Farina","fromEmail":"tfransosi@gmail.com","sentAt":"2015-05-13T23:10:47Z","receivedAt":"2015-05-13T23:10:47Z","isPatch":false,"sender":{"key":"tfransosi@gmail.com","avatar":"https://avatars.githubusercontent.com/u/970071?v=4"},"body":"Hi,\n\nWould be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?\n\nI know \"Why\" question could come, but I prefer to not answer it if I can.\n\nRegards,\n\n-- \nThiago Farina\n"},{"id":"261212","messageId":"20150513232348.GD5586@google.com","threadId":"39333","inReplyTo":"CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com","subject":"Re: cmd_struct","fromName":"Jonathan Nieder","fromEmail":"jrnieder@gmail.com","sentAt":"2015-05-13T23:23:49Z","receivedAt":"2015-05-13T23:23:49Z","isPatch":false,"sender":{"key":"jrnieder@gmail.com","avatar":"https://avatars.githubusercontent.com/u/281595?v=4"},"body":"Hi,\n\nThiago Farina wrote:\n\n> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?\n>\n> I know \"Why\" question could come, but I prefer to not answer it if I can.\n\nThe answer depends on the \"why\".  (Not \"why do you ask?\", but \"why\nrename --- what benefit would it bring?\")\n\nThanks and hope that helps,\nJonathan\n"},{"id":"261213","messageId":"CAPc5daUF1SaCOqb0iEZ527q-CgQn3YyMSWufOsQx9Lo1+aUBrg@mail.gmail.com","threadId":"39333","inReplyTo":"CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com","subject":"Re: cmd_struct","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2015-05-13T23:24:14Z","receivedAt":"2015-05-13T23:24:14Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"On Wed, May 13, 2015 at 4:10 PM, Thiago Farina <tfransosi@gmail.com> wrote:\n>\n> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?\n\nThe name has served us well, I do not see a compelling reason to change it\nto anything else, and I suspect the name stayed unchanged because nobody\nelse found such a reason, either.\n\nSo... if you are unwilling to make a compelling case telling us why the current\nname does not work, I do not think it is likely that anybody finds such a change\nnecessary, welcome, or even tolerable.\n"},{"id":"261214","messageId":"xmqq617w9hr1.fsf@gitster.dls.corp.google.com","threadId":"39333","inReplyTo":"CAPc5daUF1SaCOqb0iEZ527q-CgQn3YyMSWufOsQx9Lo1+aUBrg@mail.gmail.com","subject":"Re: cmd_struct","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2015-05-13T23:31:46Z","receivedAt":"2015-05-13T23:31:46Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Junio C Hamano <gitster@pobox.com> writes:\n\n> On Wed, May 13, 2015 at 4:10 PM, Thiago Farina <tfransosi@gmail.com> wrote:\n>>\n>> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?\n>\n> The name has served us well, I do not see a compelling reason to change it\n> to anything else, and I suspect the name stayed unchanged because nobody\n> else found such a reason, either.\n>\n> So... if you are unwilling to make a compelling case telling us why the current\n> name does not work, I do not think it is likely that anybody finds such a change\n> necessary, welcome, or even tolerable.\n\nHaving said that, I would agree that if I were writing git.c from\nscratch today, I would have done\n\n\tstatic struct builtin_cmd builtin_cmd[] = { ...\n\ninsead of the current\n\n\tstatic struct cmd_struct commands[] = { ...\n\njust because I think it makes more sense.  But that reason suggests\nit is a mere code churn of no value, after all these years.\n\n\"Because the non-POSIX non-ANSI-C platform I am porting for stomps\non the end-user program's namespace, and cmd_struct is one of the\nvictims\" could be a reason that is better than \"just because I think\nit makes more sense\", but even then, there would probably be a\nbetter ways other than renaming the symbols in end-user code\n(i.e. Git) to solve such a name clash.\n"},{"id":"261223","messageId":"5da49038cab4173e8e11e698aeb3410a@www.dscho.org","threadId":"39333","inReplyTo":"CACnwZYe5i3p0f7cvprya=VdhFnnMW_H=K18BFqjq_Qn86cjXeA@mail.gmail.com","subject":"Re: cmd_struct","fromName":"Johannes Schindelin","fromEmail":"johannes.schindelin@gmx.de","sentAt":"2015-05-14T07:49:30Z","receivedAt":"2015-05-14T07:49:30Z","isPatch":false,"sender":{"key":"johannes.schindelin@gmx.de","avatar":"https://avatars.githubusercontent.com/u/127790?v=4"},"body":"Hi Thiago,\n\nOn 2015-05-14 01:10, Thiago Farina wrote:\n\n> Would be too churn/noise (at this point) to rename cmd_struct to builtin_cmd?\n> \n> I know \"Why\" question could come, but I prefer to not answer it if I can.\n\nIt would be too much churn/noise, but I prefer not to describe why, if I can.\n\n*grins*\n\nCiao,\nDscho\n"}]}