{"thread":{"id":"36044","subject":"Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so","startedAt":"2014-03-03T23:18:46Z","lastAt":"2014-03-03T23:50:19Z","messageCount":3,"participants":["Eric Sunshine","Junio C Hamano","Ilya Bobyr"],"isPatch":true,"patchVersion":1,"patchTotal":2},"messages":[{"id":"235956","messageId":"CAPig+cRnfDta9FofgH2jSdivzKvJiHwnzPZ5PoO4UTpWQLSH4w@mail.gmail.com","threadId":"36044","inReplyTo":null,"subject":"Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so","fromName":"Eric Sunshine","fromEmail":"sunshine@sunshineco.com","sentAt":"2014-03-03T23:18:46Z","receivedAt":"2014-03-03T23:18:46Z","isPatch":true,"sender":{"key":"sunshine@sunshineco.com","avatar":"https://avatars.githubusercontent.com/u/163641?v=4"},"body":"On Mon, Mar 3, 2014 at 6:12 PM, Ilya Bobyr <ilya.bobir@gmail.com> wrote:\n> On 3/3/2014 2:59 PM, Eric Sunshine wrote:\n>>\n>> On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr <ilya.bobyr@gmail.com> wrote:\n>>>\n>>> We used to show \"(missing )\" next to tests skipped because they are\n>>> specified in GIT_SKIP_TESTS.  Use \"(matched by GIT_SKIP_TESTS)\" instead.\n>>\n>> Bikeshedding: That's pretty verbose. Perhaps just say \"(excluded)\"?\n>\n>\n> The next patch adds another reason for the test to be skipped, so it seems\n> reasonable to say why exactly.\n> The patch actually makes it say \"matched GIT_SKIP_TESTS\".\n> It looks OK on the console.\n\nStill just bikeshedding:\n\nThat new message in patch #2 says \"not in GIT_TEST_ONLY\", but isn't\n\"(excluded)\" also applicable to that case? Is it important to be able\nto distinguish between the two \"excluded\" reasons?\n\n(No more bikeshedding for me.)\n"},{"id":"235962","messageId":"xmqqfvmyn97f.fsf@gitster.dls.corp.google.com","threadId":"36044","inReplyTo":"CAPig+cRnfDta9FofgH2jSdivzKvJiHwnzPZ5PoO4UTpWQLSH4w@mail.gmail.com","subject":"Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2014-03-03T23:39:16Z","receivedAt":"2014-03-03T23:39:16Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Eric Sunshine <sunshine@sunshineco.com> writes:\n\n> That new message in patch #2 says \"not in GIT_TEST_ONLY\", but isn't\n> \"(excluded)\" also applicable to that case? Is it important to be able\n> to distinguish between the two \"excluded\" reasons?\n\nAn obvious solution is not to *have* two reasons in the first place\n;-)\n"},{"id":"235965","messageId":"5315153B.5030809@gmail.com","threadId":"36044","inReplyTo":"CAPig+cRnfDta9FofgH2jSdivzKvJiHwnzPZ5PoO4UTpWQLSH4w@mail.gmail.com","subject":"Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so","fromName":"Ilya Bobyr","fromEmail":"ilya.bobir@gmail.com","sentAt":"2014-03-03T23:50:19Z","receivedAt":"2014-03-03T23:50:19Z","isPatch":true,"sender":{"key":"ilya.bobir@gmail.com","avatar":null},"body":"On 3/3/2014 3:18 PM, Eric Sunshine wrote:\n> On Mon, Mar 3, 2014 at 6:12 PM, Ilya Bobyr <ilya.bobir@gmail.com> wrote:\n>> On 3/3/2014 2:59 PM, Eric Sunshine wrote:\n>>> On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr <ilya.bobyr@gmail.com> wrote:\n>>>> We used to show \"(missing )\" next to tests skipped because they are\n>>>> specified in GIT_SKIP_TESTS.  Use \"(matched by GIT_SKIP_TESTS)\" instead.\n>>> Bikeshedding: That's pretty verbose. Perhaps just say \"(excluded)\"?\n>>\n>> The next patch adds another reason for the test to be skipped, so it seems\n>> reasonable to say why exactly.\n>> The patch actually makes it say \"matched GIT_SKIP_TESTS\".\n>> It looks OK on the console.\n> Still just bikeshedding:\n>\n> That new message in patch #2 says \"not in GIT_TEST_ONLY\", but isn't\n> \"(excluded)\" also applicable to that case? Is it important to be able\n> to distinguish between the two \"excluded\" reasons?\n>\n> (No more bikeshedding for me.)\n\nMakes sense.  I guess it is unlikely you would want to use both include \nand exclude filters in one run.\nOn the other hand it seems nice to see the reason why it was skipped.\n\nHere are both options for comparison.  \"Longer\":\n\n     $ GIT_SKIP_TESTS='t0000.[236789] t0001.??' ./t0001-init.sh\n     ok 1 - plain\n     ok 2 # skip plain nested in bare (matched GIT_SKIP_TESTS)\n     ok 3 # skip plain through aliased command, outside any git repo \n(matched GIT_SKIP_TESTS)\n     not ok 4 - plain nested through aliased command # TODO known breakage\n     not ok 5 - plain nested in bare through aliased command # TODO \nknown breakage\n     ok 6 # skip plain with GIT_WORK_TREE (matched GIT_SKIP_TESTS)\n\nand changed to \"excluded\":\n\n     $ GIT_SKIP_TESTS='t0000.[236789] t0001.??' ./t0001-init.sh\n     ok 1 - plain\n     ok 2 # skip plain nested in bare (excluded)\n     ok 3 # skip plain through aliased command, outside any git repo \n(excluded)\n     not ok 4 - plain nested through aliased command # TODO known breakage\n     not ok 5 - plain nested in bare through aliased command # TODO \nknown breakage\n     ok 6 # skip plain with GIT_WORK_TREE (excluded)\n\nP.S. It seems that now the whole interface may change :)\n"}]}