{"thread":{"id":"34486","subject":"Documentation/git-checkout.txt: Inconsistent naming of paths arguments","startedAt":"2013-07-19T07:16:10Z","lastAt":"2013-07-19T14:36:16Z","messageCount":3,"participants":["Adam Brengesjö","Duy Nguyen","Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"223736","messageId":"CAJTcR-1RxLEaUe+c5yXEuKeC5Ert4FGm0=kUi7H-M-a+-Cp9-g@mail.gmail.com","threadId":"34486","inReplyTo":null,"subject":"Documentation/git-checkout.txt: Inconsistent naming of paths arguments","fromName":"Adam Brengesjö","fromEmail":"ca.brengesjo@gmail.com","sentAt":"2013-07-19T07:16:10Z","receivedAt":"2013-07-19T07:16:10Z","isPatch":false,"sender":{"key":"ca.brengesjo@gmail.com","avatar":null},"body":"From SYNOPSIS:\n\ngit checkout [-p|--patch] [<tree-ish>] [--] [<paths>…]\n\n\nFrom DESCRIPTION\n\ngit checkout [-p|--patch] [<tree-ish>] [--] <pathspec>…\n\n\n\n1. Named <paths> in SYNOPSIS, but <pathspec> in DESCRIPTION. (It's\nreferred to as <path> in the body text).\n\n2. <paths> is marked as optional in SYNOPSIS, but <pathspec> is not.\n\nI'm not submitting a patch now, as I'm not sure which is correct.\n"},{"id":"223739","messageId":"CACsJy8DdVxwsf5xyDSDCe97kTPGdjvwQcMEPRNCCGXjF1z4eyw@mail.gmail.com","threadId":"34486","inReplyTo":"CAJTcR-1RxLEaUe+c5yXEuKeC5Ert4FGm0=kUi7H-M-a+-Cp9-g@mail.gmail.com","subject":"Re: Documentation/git-checkout.txt: Inconsistent naming of paths arguments","fromName":"Duy Nguyen","fromEmail":"pclouds@gmail.com","sentAt":"2013-07-19T07:40:18Z","receivedAt":"2013-07-19T07:40:18Z","isPatch":false,"sender":{"key":"pclouds@gmail.com","avatar":"https://avatars.githubusercontent.com/u/720?v=4"},"body":"On Fri, Jul 19, 2013 at 2:16 PM, Adam Brengesjö <ca.brengesjo@gmail.com> wrote:\n> From SYNOPSIS:\n>\n> git checkout [-p|--patch] [<tree-ish>] [--] [<paths>…]\n>\n>\n> From DESCRIPTION\n>\n> git checkout [-p|--patch] [<tree-ish>] [--] <pathspec>…\n>\n>\n>\n> 1. Named <paths> in SYNOPSIS, but <pathspec> in DESCRIPTION. (It's\n> referred to as <path> in the body text).\n>\n> 2. <paths> is marked as optional in SYNOPSIS, but <pathspec> is not.\n>\n> I'm not submitting a patch now, as I'm not sure which is correct.\n\nIf I'm not mistaken, \"git checkout\" takes pathspec in all cases.\n--\nDuy\n"},{"id":"223764","messageId":"7va9lizkf3.fsf@alter.siamese.dyndns.org","threadId":"34486","inReplyTo":"CACsJy8DdVxwsf5xyDSDCe97kTPGdjvwQcMEPRNCCGXjF1z4eyw@mail.gmail.com","subject":"Re: Documentation/git-checkout.txt: Inconsistent naming of paths arguments","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2013-07-19T14:36:16Z","receivedAt":"2013-07-19T14:36:16Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Duy Nguyen <pclouds@gmail.com> writes:\n\n> On Fri, Jul 19, 2013 at 2:16 PM, Adam Brengesjö <ca.brengesjo@gmail.com> wrote:\n>> From SYNOPSIS:\n>>\n>> git checkout [-p|--patch] [<tree-ish>] [--] [<paths>…]\n>>\n>>\n>> From DESCRIPTION\n>>\n>> git checkout [-p|--patch] [<tree-ish>] [--] <pathspec>…\n>>\n>>\n>>\n>> 1. Named <paths> in SYNOPSIS, but <pathspec> in DESCRIPTION. (It's\n>> referred to as <path> in the body text).\n>>\n>> 2. <paths> is marked as optional in SYNOPSIS, but <pathspec> is not.\n>>\n>> I'm not submitting a patch now, as I'm not sure which is correct.\n>\n> If I'm not mistaken, \"git checkout\" takes pathspec in all cases.\n\nCorrect.\n\nAnd I think -p form (which I do not use myself so please double\ncheck) can be run with an empty pathspec.\n\nIt looks somewhat idiotic that\n\n\tgit checkout master\n        git checout -p next\n\nwill finish on the 'master' branch, with random selected bits of\ndifferences for 'master' to go to 'next' applied to the index and\nthe working tree, but that seems to be how it works.\n"}]}