{"thread":{"id":"31555","subject":"[PATCH 3/8] Doc: Improve shallow depth wording","startedAt":"2012-09-16T10:57:58Z","lastAt":"2012-09-18T21:54:26Z","messageCount":6,"participants":["Philip Oakley","Junio C Hamano"],"isPatch":true,"patchVersion":1,"patchTotal":8},"messages":[{"id":"199156","messageId":"1347793083-4136-4-git-send-email-philipoakley@iee.org","threadId":"31555","inReplyTo":null,"subject":"[PATCH 3/8] Doc: Improve shallow depth wording","fromName":"Philip Oakley","fromEmail":"philipoakley@iee.org","sentAt":"2012-09-16T10:57:58Z","receivedAt":"2012-09-16T10:57:58Z","isPatch":true,"sender":{"key":"philipoakley@iee.email","avatar":"https://avatars.githubusercontent.com/u/914343?v=4"},"body":"Avoid confusion in compound sentence about the start of the commit set\nand the depth measure. Use two sentences.\n\nSigned-off-by: Philip Oakley <philipoakley@iee.org>\n\ndiff --git a/Documentation/technical/pack-protocol.txt b/Documentation/technical/pack-protocol.txt\nindex 49cdc57..fa4acab 100644\n--- a/Documentation/technical/pack-protocol.txt\n+++ b/Documentation/technical/pack-protocol.txt\n@@ -258,9 +258,11 @@ a positive depth, this step is skipped.\n   unshallow-line   =  PKT-LINE(\"unshallow\" SP obj-id)\n ----\n \n-If the client has requested a positive depth, the server will compute\n-the set of commits which are no deeper than the desired depth, starting\n-at the client's wants. The server writes 'shallow' lines for each\n+If the client has requested a positive depth the server will compute\n+the set of commits which are no deeper than the desired depth. The set\n+of commits start at the client's wants.\n+\n+The server writes 'shallow' lines for each\n commit whose parents will not be sent as a result. The server writes\n an 'unshallow' line for each commit which the client has indicated is\n shallow, but is no longer shallow at the currently requested depth\n-- \n1.7.8.msysgit.0\n"},{"id":"199190","messageId":"7vlig9w6a7.fsf@alter.siamese.dyndns.org","threadId":"31555","inReplyTo":"1347793083-4136-4-git-send-email-philipoakley@iee.org","subject":"Re: [PATCH 3/8] Doc: Improve shallow depth wording","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-09-17T05:46:24Z","receivedAt":"2012-09-17T05:46:24Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Philip Oakley <philipoakley@iee.org> writes:\n\n> Avoid confusion in compound sentence about the start of the commit set\n> and the depth measure. Use two sentences.\n\nDropping the first ',' after \"positive depth\" does not seem to make\nit any easier to read (I personally think it makes it a lot harder\nto read).  Splitting the tail-end of the sentence into a separate\nsentence does make it easier to read, though.\n\n>\n> Signed-off-by: Philip Oakley <philipoakley@iee.org>\n>\n> diff --git a/Documentation/technical/pack-protocol.txt b/Documentation/technical/pack-protocol.txt\n> index 49cdc57..fa4acab 100644\n> --- a/Documentation/technical/pack-protocol.txt\n> +++ b/Documentation/technical/pack-protocol.txt\n> @@ -258,9 +258,11 @@ a positive depth, this step is skipped.\n>    unshallow-line   =  PKT-LINE(\"unshallow\" SP obj-id)\n>  ----\n>  \n> -If the client has requested a positive depth, the server will compute\n> -the set of commits which are no deeper than the desired depth, starting\n> -at the client's wants. The server writes 'shallow' lines for each\n> +If the client has requested a positive depth the server will compute\n> +the set of commits which are no deeper than the desired depth. The set\n> +of commits start at the client's wants.\n> +\n> +The server writes 'shallow' lines for each\n>  commit whose parents will not be sent as a result. The server writes\n>  an 'unshallow' line for each commit which the client has indicated is\n>  shallow, but is no longer shallow at the currently requested depth\n"},{"id":"199298","messageId":"F4AAD7C9987D4985AAB6D3F5810ED6C3@PhilipOakley","threadId":"31555","inReplyTo":"7vlig9w6a7.fsf@alter.siamese.dyndns.org","subject":"Re: [PATCH 3/8] Doc: Improve shallow depth wording","fromName":"Philip Oakley","fromEmail":"philipoakley@iee.org","sentAt":"2012-09-17T21:56:11Z","receivedAt":"2012-09-17T21:56:11Z","isPatch":true,"sender":{"key":"philipoakley@iee.email","avatar":"https://avatars.githubusercontent.com/u/914343?v=4"},"body":"From: \"Junio C Hamano\" <gitster@pobox.com>\n> Philip Oakley <philipoakley@iee.org> writes:\n>\n>> Avoid confusion in compound sentence about the start of the commit \n>> set\n>> and the depth measure. Use two sentences.\n>\n> Dropping the first ',' after \"positive depth\" does not seem to make\n> it any easier to read (I personally think it makes it a lot harder\n> to read).\n\nAccepted. My mistake - will correct.\n\n>             Splitting the tail-end of the sentence into a separate\n> sentence does make it easier to read, though.\n>\n\nPhilip \n"},{"id":"199406","messageId":"7vmx0nkr06.fsf@alter.siamese.dyndns.org","threadId":"31555","inReplyTo":"7vlig9w6a7.fsf@alter.siamese.dyndns.org","subject":"Re: [PATCH 3/8] Doc: Improve shallow depth wording","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-09-18T20:36:25Z","receivedAt":"2012-09-18T20:36:25Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Junio C Hamano <gitster@pobox.com> writes:\n\n> Philip Oakley <philipoakley@iee.org> writes:\n>\n>> Avoid confusion in compound sentence about the start of the commit set\n>> and the depth measure. Use two sentences.\n>\n> Dropping the first ',' after \"positive depth\" does not seem to make\n> it any easier to read (I personally think it makes it a lot harder\n> to read).  Splitting the tail-end of the sentence into a separate\n> sentence does make it easier to read, though.\n\nWill add ',' locally and queue; no need to resend.\n\nThanks.\n"},{"id":"199414","messageId":"060D2B93282044BBB6189F04CB34E828@PhilipOakley","threadId":"31555","inReplyTo":"7vmx0nkr06.fsf@alter.siamese.dyndns.org","subject":"Re: [PATCH 3/8] Doc: Improve shallow depth wording","fromName":"Philip Oakley","fromEmail":"philipoakley@iee.org","sentAt":"2012-09-18T21:30:07Z","receivedAt":"2012-09-18T21:30:07Z","isPatch":true,"sender":{"key":"philipoakley@iee.email","avatar":"https://avatars.githubusercontent.com/u/914343?v=4"},"body":"From: \"Junio C Hamano\" <gitster@pobox.com>\n> Junio C Hamano <gitster@pobox.com> writes:\n>\n>> Philip Oakley <philipoakley@iee.org> writes:\n>>\n>>> Avoid confusion in compound sentence about the start of the commit \n>>> set\n>>> and the depth measure. Use two sentences.\n>>\n>> Dropping the first ',' after \"positive depth\" does not seem to make\n>> it any easier to read (I personally think it makes it a lot harder\n>> to read).  Splitting the tail-end of the sentence into a separate\n>> sentence does make it easier to read, though.\n>\n> Will add ',' locally and queue; no need to resend.\n>\n> Thanks.\n\nAnd the simple corrections to patches 5/6/7 ? Shall I send?\nPhilip \n"},{"id":"199417","messageId":"7vwqzrj8tp.fsf@alter.siamese.dyndns.org","threadId":"31555","inReplyTo":"060D2B93282044BBB6189F04CB34E828@PhilipOakley","subject":"Re: [PATCH 3/8] Doc: Improve shallow depth wording","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-09-18T21:54:26Z","receivedAt":"2012-09-18T21:54:26Z","isPatch":true,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"\"Philip Oakley\" <philipoakley@iee.org> writes:\n\n> And the simple corrections to patches 5/6/7 ? Shall I send?\n\nJuggling topics from many people, it is hard to keep track of how\nmany out of how many patches in the original series are still\nrelevant, so I would appreciate [PATCH vn N/M] with revamped values\nfor n, N and M as appropriate ;-)\n"}]}