{"thread":{"id":"31133","subject":"What's cooking in git.git (Jul 2012, #09; Sun, 29)","startedAt":"2012-07-30T03:06:58Z","lastAt":"2012-07-30T03:06:58Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"196102","messageId":"7v8ve2t0a5.fsf@alter.siamese.dyndns.org","threadId":"31133","inReplyTo":null,"subject":"What's cooking in git.git (Jul 2012, #09; Sun, 29)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-07-30T03:06:58Z","receivedAt":"2012-07-30T03:06:58Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' (proposed updates) while commits prefixed with '+' are in 'next'.\n\nWe are getting closer to 1.7.12-rc1; I do not see any topic in\n'next' (let alnoe 'pu') right now that is so urgent that cannot wait\nuntil the next release.\n\nYou can find the changes described here in the integration branches of the\nrepositories listed at\n\n    http://git-blame.blogspot.com/p/git-public-repositories.html\n\n--------------------------------------------------\n[New Topics]\n\n* mz/cherry-code-cleanup (2012-07-29) 3 commits\n - cherry: remove redundant check for merge commit\n - cherry: don't set ignored rev_info options\n - remove unnecessary parameter from get_patch_ids()\n\nMinor code clean-up on the cherry-pick codepath.\nNot urgent.\n\n* nd/maint-i18n-diffstat (2012-07-26) 1 commit\n - i18n: leave \\n out of translated diffstat\n\nWill merge to 'next' and then down to 'master' by 1.7.2-rc1.\n\n* hv/link-alt-odb-entry (2012-07-29) 1 commit\n - link_alt_odb_entry: fix read over array bounds reported by valgrind\n\nThe code to avoid mistaken attempt to add the object directory\nitself as its own alternate could read beyond end of a string while\ncomparison.  The patch is different from what was posted by Heiko.\n\nWaiting for comments.\n\n* jc/maint-config-exit-status (2012-07-29) 1 commit\n - config: \"git config baa\" should exit with status 1\n\nThe exit status code from \"git config\" was way overspecified while\nbeing incorrect.  Update the implementation to give the documented\nstatus for a case that was documented, and introduce a new code for\n\"all other errors\".\n\n* jk/maint-null-in-trees (2012-07-29) 3 commits\n - fsck: detect null sha1 in tree entries\n - do not write null sha1s to on-disk index\n - diff: do not use null sha1 as a sentinel value\n\n\"git diff\" used incorrectly an all-NUL object name as sentinel.\n\n* rj/maint-grep-remove-redundant-test (2012-07-29) 1 commit\n - t7810-*.sh: Remove redundant test\n\n\"git grep\" stopped spawning an external \"grep\" long time ago, but a\nduplicated test to check internal and external \"grep\" was left\nbehind.\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* dg/submodule-in-dismembered-working-tree (2012-07-25) 1 commit\n  (merged to 'next' on 2012-07-26 at cfa16c4)\n + git-submodule: work with GIT_DIR/GIT_WORK_TREE\n\nIn a superproject that has repository outside of its working tree,\n\"git submodule add\" failed to clone a new submodule, as GIT_DIR and\nGIT_WORK_TREE environment variables necessary to work in such a\nsuperproject interfered with access to the submodule repository.\n\n* jk/autoident-test (2012-07-26) 6 commits\n  (merged to 'next' on 2012-07-26 at f358a28)\n + t7502: test early quit from commit with bad ident\n + t7502: handle systems where auto-identity is broken\n + t7502: drop confusing test_might_fail call\n + t7502: narrow checks for author/committer name in template\n + t7502: properly quote GIT_EDITOR\n + t7502: clean up fake_editor tests\n\nFix test breakages by a builder who does not have a valid user name\nin his /etc/password entry.\n\n* jk/help-plug-memleak (2012-07-25) 2 commits\n  (merged to 'next' on 2012-07-26 at bd57cb8)\n + help.c::exclude_cmds(): plug a leak\n + help.c::uniq: plug a leak\n\nPlug a few trivial memory leaks.\n\n* jk/maint-checkout-orphan-check-fix (2012-07-25) 1 commit\n  (merged to 'next' on 2012-07-26 at a513c5a)\n + checkout: don't confuse ref and object flags\n\n\"git checkout <branchname>\" to come back from a detached HEAD state\nincorrectly computed reachability of the detached HEAD, resulting in\nunnecessary warnings.\n\n--------------------------------------------------\n[Stalled]\n\n* mz/rebase-range (2012-07-18) 7 commits\n - rebase (without -p): correctly calculate patches to rebase\n - rebase -p: don't request --left-right only to ignore left side\n - rebase -p: use --cherry-mark for todo file\n - git-rebase--interactive.sh: look up subject in add_pick_line\n - git-rebase--interactive: group all $preserve_merges code\n - git-rebase--interactive.sh: extract function for adding \"pick\" line\n - git-rebase--am.sh: avoid special-casing --keep-empty\n\nExpecting a reroll.\n\nPerformance concerns from Windows folks.  Also the series lacks\nproper sign-offs.\n\n* jl/submodule-rm (2012-07-05) 2 commits\n - rm: remove submodules from the index and the .gitmodules file\n - rm: don't fail when removing populated submodules\n\nExpecting a reroll.\n\n* ph/stash-rerere (2012-07-08) 2 commits\n - stash: invoke rerere in case of conflict\n - test: git-stash conflict sets up rerere\n\nWill be rerolled but is going in the right direction.\n\n* lt/commit-tree-guess-utf-8 (2012-06-28) 1 commit\n - commit/commit-tree: correct latin1 to utf-8\n\nTeaches \"git commit\" and \"git commit-tree\" the \"we are told to use\nutf-8 in log message, but this does not look like utf-8---attempt to\npass it through convert-from-latin1-to-utf8 and see if it makes\nsense\" heuristics \"git mailinfo\" already uses.\n\nA draft from Linus received privately without a log message.\nExpecting a reroll.\n\n* mb/remote-default-nn-origin (2012-07-11) 6 commits\n - Teach get_default_remote to respect remote.default.\n - Test that plain \"git fetch\" uses remote.default when on a detached HEAD.\n - Teach clone to set remote.default.\n - Teach \"git remote\" about remote.default.\n - Teach remote.c about the remote.default configuration setting.\n - Rename remote.c's default_remote_name static variables.\n\nWhen the user does not specify what remote to interact with, we\noften attempt to use 'origin'.  This can now be customized via a\nconfiguration variable.\n\nExpecting a reroll.\n\"The first remote becomes the default\" bit is better done as a\nseparate step.\n\n* jc/maint-push-refs-all (2012-05-04) 2 commits\n - get_fetch_map(): tighten checks on dest refs\n - fetch/push: allow refs/*:refs/*\n\nAllows pushing and fetching refs/stash.\nThere still seem to be other bugs hiding (e.g. try pushing twice).\n\nNot ready.\n\n* jc/split-blob (2012-04-03) 6 commits\n - chunked-object: streaming checkout\n - chunked-object: fallback checkout codepaths\n - bulk-checkin: support chunked-object encoding\n - bulk-checkin: allow the same data to be multiply hashed\n - new representation types in the packstream\n - packfile: use varint functions\n\nNot ready.\n\nI finished the streaming checkout codepath, but as explained in\n127b177 (bulk-checkin: support chunked-object encoding, 2011-11-30),\nthese are still early steps of a long and painful journey. At least\npack-objects and fsck need to learn the new encoding for the series\nto be usable locally, and then index-pack/unpack-objects needs to\nlearn it to be used remotely.\n\nGiven that I heard a lot of noise that people want large files, and\nthat I was asked by somebody at GitTogether'11 privately for an\nadvice on how to pay developers (not me) to help adding necessary\nsupport, I am somewhat dissapointed that the original patch series\nthat was sent long time ago still remains here without much comments\nand updates from the developer community. I even made the interface\nto the logic that decides where to split chunks easily replaceable,\nand I deliberately made the logic in the original patch extremely\nstupid to entice others, especially the \"bup\" fanbois, to come up\nwith a better logic, thinking that giving people an easy target to\nshoot for, they may be encouraged to help out. The plan is not\nworking :-<.\n\n--------------------------------------------------\n[Cooking]\n\n* sz/submodule-force-update (2012-07-25) 1 commit\n  (merged to 'next' on 2012-07-26 at 3bda2be)\n + Make 'git submodule update --force' always check out submodules.\n\nWe may want a documentation update and a few tests on top.\nNot urgent.\n\n* jc/test-prereq (2012-07-27) 6 commits\n  (merged to 'next' on 2012-07-27 at 448cbbc)\n + test-lib: provide UTF8 behaviour as a prerequisite\n + t0050: use the SYMLINKS test prereq\n + t0050: use the CASE_INSENSITIVE_FS test prereq\n + test-lib: provide case insensitivity as a prerequisite\n + test: allow prerequisite to be evaluated lazily\n + test: rename $satisfied to $satisfied_prereq\n\nTeaches the test framework to probe rarely used prerequistes lazily,\nand make use of it for detecting SYMLINKS, CASE_INSENSITIVE_FS and\nNKD/NKC MacOS x gotcha.\n\nNot urgent.\n\n* da/difftool-updates (2012-07-26) 10 commits\n  (merged to 'next' on 2012-07-26 at 3263461)\n + difftool: Disable --symlinks on cygwin\n + difftool: Handle compare() returning -1\n + difftool: Wrap long lines for readability\n + difftool: Check all return codes from compare()\n + difftool: Handle finding mergetools/ in a path with spaces\n  (merged to 'next' on 2012-07-23 at 96528a7)\n + difftool: Use symlinks when diffing against the worktree\n + difftool: Call the temp directory \"git-difftool\"\n + difftool: Move option values into a hash\n + difftool: Eliminate global variables\n + difftool: Simplify print_tool_help()\n\n\"git difftool --dir-diff\" learned to use symbolic links to prepare\ntemporary copy of the working tree when available.\n\nNot urgent.\n\n* jx/i18n-1.7.11 (2012-07-26) 7 commits\n - i18n: merge-recursive: mark strings for translation\n - Remove dead code which contains bad gettext block\n - i18n: am: mark more strings for translation\n - rebase: remove obsolete and unused LONG_USAGE which breaks xgettext\n - i18n: Rewrite gettext messages start with dash\n - i18n: rebase: mark messages for translation\n - i18n: New keywords for xgettext extraction from sh\n\nIs this ready for 'next'?\nNot urgent.\n\n* jk/no-more-pre-exec-callback (2012-06-05) 1 commit\n  (merged to 'next' on 2012-07-23 at fe59cb6)\n + pager: drop \"wait for output to run less\" hack\n\nWill defer for 6 months until ancient \"less\" goes extinct.\n\n* mm/push-default-switch-warning (2012-06-24) 1 commit\n  (merged to 'next' on 2012-06-26 at fea512a)\n + push: start warning upcoming default change for push.default\n\nWill defer for another cycle.\n\n--------------------------------------------------\n[Discarded]\n\n* jk/maint-commit-abandoned-message (2012-07-23) 2 commits\n . commit: give a hint when a commit message has been abandoned\n . Merge commit 'b2eda9b' into jk/maint-commit-abandoned-message\n\n* ms/git-svn-pm (2012-07-26) 4 commits\n . Move initialization of Git::SVN variables into Git::SVN.\n . Extract Git::SVN from git-svn into its own .pm file.\n . Prepare Git::SVN for extraction into its own file.\n . Extract some utilities from git-svn to allow extracting Git::SVN.\n (this branch uses ms/makefile-pl.)\n\nAlready in 'master' via Eric's git-svn tree.\n\n* ms/makefile-pl (2012-07-25) 3 commits\n . The Makefile.PL will now find .pm files itself.\n . Don't lose Error.pm if $@ gets clobbered.\n . Quiet warning if Makefile.PL is run with -w and no --localedir\n (this branch is used by ms/git-svn-pm.)\n\nAlready in 'master' via Eric's git-svn tree.\n"}]}