{"thread":{"id":"31113","subject":"What's cooking in git.git (Jul 2012, #08; Thu, 26)","startedAt":"2012-07-27T06:09:18Z","lastAt":"2012-07-27T16:10:51Z","messageCount":2,"participants":["Junio C Hamano","Martin von Zweigbergk"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"195928","messageId":"7vy5m520s1.fsf@alter.siamese.dyndns.org","threadId":"31113","inReplyTo":null,"subject":"What's cooking in git.git (Jul 2012, #08; Thu, 26)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-07-27T06:09:18Z","receivedAt":"2012-07-27T06:09:18Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' (proposed updates) while commits prefixed with '+' are in 'next'.\n\nPlease consider that the tip of 'master' is more or less feature\ncomplete.  Topics that are not in 'next' by the time I tag -rc1\nsometime early next week will not likely to be part of upcoming\n1.7.12 release.\n\nYou can find the changes described here in the integration branches of the\nrepositories listed at\n\n    http://git-blame.blogspot.com/p/git-public-repositories.html\n\n--------------------------------------------------\n[New Topics]\n\n* dg/submodule-in-dismembered-working-tree (2012-07-25) 1 commit\n  (merged to 'next' on 2012-07-26 at cfa16c4)\n + git-submodule: work with GIT_DIR/GIT_WORK_TREE\n\nWill merge to 'master'.\n\n* jk/help-plug-memleak (2012-07-25) 2 commits\n  (merged to 'next' on 2012-07-26 at bd57cb8)\n + help.c::exclude_cmds(): plug a leak\n + help.c::uniq: plug a leak\n\nWill merge to 'master'.\n\n* jk/maint-checkout-orphan-check-fix (2012-07-25) 1 commit\n  (merged to 'next' on 2012-07-26 at a513c5a)\n + checkout: don't confuse ref and object flags\n\nWill merge to 'master', later down to older maintenance releases.\n\n* ms/makefile-pl (2012-07-25) 3 commits\n - The Makefile.PL will now find .pm files itself.\n - Don't lose Error.pm if $@ gets clobbered.\n - Quiet warning if Makefile.PL is run with -w and no --localedir\n (this branch is used by ms/git-svn-pm.)\n\nWill be part of larger series around git-svn, so I'll most likely\ndrop this copy and wait for Eric to feed it to me later.\n\n* ms/git-svn-pm (2012-07-26) 4 commits\n - Move initialization of Git::SVN variables into Git::SVN.\n - Extract Git::SVN from git-svn into its own .pm file.\n - Prepare Git::SVN for extraction into its own file.\n - Extract some utilities from git-svn to allow extracting Git::SVN.\n (this branch uses ms/makefile-pl.)\n\nWill be part of larger series around git-svn, so I'll most likely\ndrop this copy and wait for Eric to feed it to me later.\n\n* sz/submodule-force-update (2012-07-25) 1 commit\n  (merged to 'next' on 2012-07-26 at 3bda2be)\n + Make 'git submodule update --force' always check out submodules.\n\nWe may want a documentation update and a few tests on top.\nNot urgent.\n\n* jk/autoident-test (2012-07-26) 6 commits\n  (merged to 'next' on 2012-07-26 at f358a28)\n + t7502: test early quit from commit with bad ident\n + t7502: handle systems where auto-identity is broken\n + t7502: drop confusing test_might_fail call\n + t7502: narrow checks for author/committer name in template\n + t7502: properly quote GIT_EDITOR\n + t7502: clean up fake_editor tests\n\nWill merge to 'master'.\n\n* jc/test-prereq (2012-07-26) 6 commits\n  (merged to 'next' on 2012-07-26 at 0e21c36)\n + test-lib: provide UTF8 behaviour as a prerequisite\n + t0050: use the SYMLINKS test prereq\n + t0050: use the CASE_INSENSITIVE_FS test prereq\n + test-lib: provide case insensitivity as a prerequisite\n + test: allow prerequisite to be evaluated lazily\n + test: rename $satisfied to $satisfied_prereq\n\nTeaches the test framework to probe rarely used prerequistes lazily,\nand make use of it for detecting SYMLINKS, CASE_INSENSITIVE_FS and\nNKD/NKC MacOS x gotcha.\n\nNot urgent.\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* cw/rebase-i-root (2012-07-24) 1 commit\n  (merged to 'next' on 2012-07-24 at 01b7c29)\n + rebase -i: handle fixup of root commit correctly\n\nFinishing touches to the \"rebase -i --root\" (new feature for\n1.7.12).\n\n* jc/mergetool-tool-help (2012-07-23) 1 commit\n  (merged to 'next' on 2012-07-23 at ef256fc)\n + mergetool: support --tool-help option like difftool does\n\n\"git mergetool\" did not support --tool-help option to give the list\nof supported backends, like \"git difftool\" does.\n\n* jc/test-lib-source-build-options-early (2012-06-24) 1 commit\n  (merged to 'next' on 2012-07-24 at 97078b5)\n + test-lib: reorder and include GIT-BUILD-OPTIONS a lot earlier\n\nReorders t/test-lib.sh so that we dot-source GIT-BUILD-OPTIONS that\nrecords the shell and Perl the user told us to use with Git a lot\nearly, so that test-lib.sh script itself can use \"$PERL_PATH\" in\none of its early operations.\n\n* jk/maint-advise-vaddf (2012-07-23) 1 commit\n  (merged to 'next' on 2012-07-23 at 5b13a77)\n + advice: pass varargs to strbuf_vaddf, not strbuf_addf\n (this branch is used by jk/maint-commit-abandoned-message.)\n\nThe advise() function did not use varargs correctly to format\nits message.\n\n* jk/maint-commit-check-committer-early (2012-07-23) 1 commit\n  (merged to 'next' on 2012-07-23 at a2c7133)\n + commit: check committer identity more strictly\n\n\"git commit --amend\" let the user edit the log message and then died\nwhen the human-readable committer name was given insufficiently by\ngetpwent(3).\n\n* jk/maint-commit-document-editmsg (2012-07-23) 1 commit\n  (merged to 'next' on 2012-07-23 at 06307fb)\n + commit: document the temporary commit message file\n\nDocument $GIT_DIR/COMMIT_EDITMSG file.\n\n* mh/maint-revisions-doc (2012-07-24) 2 commits\n  (merged to 'next' on 2012-07-24 at d5e286e)\n + Enumerate revision range specifiers in the documentation\n + Make <refname> documentation more consistent.\n\n* mm/config-xdg (2012-07-24) 4 commits\n  (merged to 'next' on 2012-07-24 at 6ab5783)\n + t1306: check that XDG_CONFIG_HOME works\n + ignore: make sure we have an xdg path before using it\n + attr: make sure we have an xdg path before using it\n + test-lib.sh: unset XDG_CONFIG_HOME\n\nFinishing touches to the XDG support (new feature for 1.7.12) and\ntests.\n\n--------------------------------------------------\n[Stalled]\n\n* mz/rebase-range (2012-07-18) 7 commits\n - rebase (without -p): correctly calculate patches to rebase\n - rebase -p: don't request --left-right only to ignore left side\n - rebase -p: use --cherry-mark for todo file\n - git-rebase--interactive.sh: look up subject in add_pick_line\n - git-rebase--interactive: group all $preserve_merges code\n - git-rebase--interactive.sh: extract function for adding \"pick\" line\n - git-rebase--am.sh: avoid special-casing --keep-empty\n\nExpecting a reroll.\n\nPerformance concerns from Windows folks.  Also the series lacks\nproper sign-offs.\n\n* jl/submodule-rm (2012-07-05) 2 commits\n - rm: remove submodules from the index and the .gitmodules file\n - rm: don't fail when removing populated submodules\n\nExpecting a reroll.\n\n* ph/stash-rerere (2012-07-08) 2 commits\n - stash: invoke rerere in case of conflict\n - test: git-stash conflict sets up rerere\n\nWill be rerolled but is going in the right direction.\n\n* lt/commit-tree-guess-utf-8 (2012-06-28) 1 commit\n - commit/commit-tree: correct latin1 to utf-8\n\nTeaches \"git commit\" and \"git commit-tree\" the \"we are told to use\nutf-8 in log message, but this does not look like utf-8---attempt to\npass it through convert-from-latin1-to-utf8 and see if it makes\nsense\" heuristics \"git mailinfo\" already uses.\n\nA draft from Linus received privately without a log message.\nExpecting a reroll.\n\n* mb/remote-default-nn-origin (2012-07-11) 6 commits\n - Teach get_default_remote to respect remote.default.\n - Test that plain \"git fetch\" uses remote.default when on a detached HEAD.\n - Teach clone to set remote.default.\n - Teach \"git remote\" about remote.default.\n - Teach remote.c about the remote.default configuration setting.\n - Rename remote.c's default_remote_name static variables.\n\nWhen the user does not specify what remote to interact with, we\noften attempt to use 'origin'.  This can now be customized via a\nconfiguration variable.\n\nExpecting a reroll.\n\"The first remote becomes the default\" bit is better done as a\nseparate step.\n\n* jc/maint-push-refs-all (2012-05-04) 2 commits\n - get_fetch_map(): tighten checks on dest refs\n - fetch/push: allow refs/*:refs/*\n\nAllows pushing and fetching refs/stash.\nThere still seem to be other bugs hiding (e.g. try pushing twice).\n\nNot ready.\n\n* jc/split-blob (2012-04-03) 6 commits\n - chunked-object: streaming checkout\n - chunked-object: fallback checkout codepaths\n - bulk-checkin: support chunked-object encoding\n - bulk-checkin: allow the same data to be multiply hashed\n - new representation types in the packstream\n - packfile: use varint functions\n\nNot ready.\n\nI finished the streaming checkout codepath, but as explained in\n127b177 (bulk-checkin: support chunked-object encoding, 2011-11-30),\nthese are still early steps of a long and painful journey. At least\npack-objects and fsck need to learn the new encoding for the series\nto be usable locally, and then index-pack/unpack-objects needs to\nlearn it to be used remotely.\n\nGiven that I heard a lot of noise that people want large files, and\nthat I was asked by somebody at GitTogether'11 privately for an\nadvice on how to pay developers (not me) to help adding necessary\nsupport, I am somewhat dissapointed that the original patch series\nthat was sent long time ago still remains here without much comments\nand updates from the developer community. I even made the interface\nto the logic that decides where to split chunks easily replaceable,\nand I deliberately made the logic in the original patch extremely\nstupid to entice others, especially the \"bup\" fanbois, to come up\nwith a better logic, thinking that giving people an easy target to\nshoot for, they may be encouraged to help out. The plan is not\nworking :-<.\n\n--------------------------------------------------\n[Cooking]\n\n* da/difftool-updates (2012-07-26) 10 commits\n  (merged to 'next' on 2012-07-26 at 3263461)\n + difftool: Disable --symlinks on cygwin\n + difftool: Handle compare() returning -1\n + difftool: Wrap long lines for readability\n + difftool: Check all return codes from compare()\n + difftool: Handle finding mergetools/ in a path with spaces\n  (merged to 'next' on 2012-07-23 at 96528a7)\n + difftool: Use symlinks when diffing against the worktree\n + difftool: Call the temp directory \"git-difftool\"\n + difftool: Move option values into a hash\n + difftool: Eliminate global variables\n + difftool: Simplify print_tool_help()\n\n\"git difftool --dir-diff\" learned to use symbolic links to prepare\ntemporary copy of the working tree when available.\n\nNot urgent.\n\n* jx/i18n-1.7.11 (2012-07-26) 7 commits\n - i18n: merge-recursive: mark strings for translation\n - Remove dead code which contains bad gettext block\n - i18n: am: mark more strings for translation\n - rebase: remove obsolete and unused LONG_USAGE which breaks xgettext\n - i18n: Rewrite gettext messages start with dash\n - i18n: rebase: mark messages for translation\n - i18n: New keywords for xgettext extraction from sh\n\nIs this ready for 'next'?\nNot urgent.\n\n* jk/no-more-pre-exec-callback (2012-06-05) 1 commit\n  (merged to 'next' on 2012-07-23 at fe59cb6)\n + pager: drop \"wait for output to run less\" hack\n\nWill defer for 6 months until ancient \"less\" goes extinct.\n\n* mm/push-default-switch-warning (2012-06-24) 1 commit\n  (merged to 'next' on 2012-06-26 at fea512a)\n + push: start warning upcoming default change for push.default\n\nWill defer for another cycle.\n\n--------------------------------------------------\n[Discarded]\n\n* jk/maint-commit-abandoned-message (2012-07-23) 2 commits\n . commit: give a hint when a commit message has been abandoned\n . Merge commit 'b2eda9b' into jk/maint-commit-abandoned-message\n"},{"id":"195947","messageId":"CAOeW2eFy__AaPWBBST3rj4FTAzvew7-BWPLhnAM7UxtcbBspLQ@mail.gmail.com","threadId":"31113","inReplyTo":"7vy5m520s1.fsf@alter.siamese.dyndns.org","subject":"Re: What's cooking in git.git (Jul 2012, #08; Thu, 26)","fromName":"Martin von Zweigbergk","fromEmail":"martin.von.zweigbergk@gmail.com","sentAt":"2012-07-27T16:10:51Z","receivedAt":"2012-07-27T16:10:51Z","isPatch":false,"sender":{"key":"martinvonz@gmail.com","avatar":"https://avatars.githubusercontent.com/u/891642?v=4"},"body":"On Thu, Jul 26, 2012 at 11:09 PM, Junio C Hamano <gitster@pobox.com> wrote:\n> * mz/rebase-range (2012-07-18) 7 commits\n>  - rebase (without -p): correctly calculate patches to rebase\n>  - rebase -p: don't request --left-right only to ignore left side\n>  - rebase -p: use --cherry-mark for todo file\n>  - git-rebase--interactive.sh: look up subject in add_pick_line\n>  - git-rebase--interactive: group all $preserve_merges code\n>  - git-rebase--interactive.sh: extract function for adding \"pick\" line\n>  - git-rebase--am.sh: avoid special-casing --keep-empty\n>\n> Expecting a reroll.\n\nYep, will try to get some time for this soon. Will probably try using\npatch-id as you suggested.\n"}]}