{"thread":{"id":"31068","subject":"What's cooking in git.git (Jul 2012, #06; Sun, 22)","startedAt":"2012-07-22T21:38:22Z","lastAt":"2012-07-22T21:38:22Z","messageCount":1,"participants":["Junio C Hamano"],"isPatch":false,"patchVersion":null,"patchTotal":null},"messages":[{"id":"195463","messageId":"7vfw8jpjch.fsf@alter.siamese.dyndns.org","threadId":"31068","inReplyTo":null,"subject":"What's cooking in git.git (Jul 2012, #06; Sun, 22)","fromName":"Junio C Hamano","fromEmail":"gitster@pobox.com","sentAt":"2012-07-22T21:38:22Z","receivedAt":"2012-07-22T21:38:22Z","isPatch":false,"sender":{"key":"gitster@pobox.com","avatar":"https://avatars.githubusercontent.com/u/54884?v=4"},"body":"Here are the topics that have been cooking.  Commits prefixed with '-' are\nonly in 'pu' (proposed updates) while commits prefixed with '+' are in 'next'.\n\nI think we are more or less done for this cycle except for a handful\nof topics that are to be rerolled, even though I haven't tagged the\ntip of the 'master' with 1.7.12-rc0 yet.\n\nYou can find the changes described here in the integration branches of the\nrepositories listed at\n\n    http://git-blame.blogspot.com/p/git-public-repositories.html\n\n--------------------------------------------------\n[Graduated to \"master\"]\n\n* as/t4012-style-updates (2012-07-16) 8 commits\n  (merged to 'next' on 2012-07-16 at 86c14f6)\n + t4012: Use test_must_fail instead of if-else\n + t4012: use 'printf' instead of 'dd' to generate a binary file\n + t4012: Re-indent test snippets\n + t4012: Make --shortstat test more robust\n + t4012: Break up pipe into serial redirections\n + t4012: Actually quote the sed script\n + t4012: Unquote git command fragment in test title\n + t4012: modernize style for quoting\n\n* jc/maint-filter-branch-epoch-date (2012-07-12) 3 commits\n  (merged to 'next' on 2012-07-13 at d144342)\n + t7003: add test to filter a branch with a commit at epoch\n + date.c: Fix off by one error in object-header date parsing\n  (merged to 'next' on 2012-07-10 at f9774ca)\n + filter-branch: do not forget the '@' prefix to force git-timestamp\n\nIn 1.7.9 era, we taught \"git rebase\" about the raw timestamp format\nbut we did not teach the same trick to \"filter-branch\", which rolled\na similar logic on its own.\n\n* jc/sha1-name-more (2012-07-13) 27 commits\n  (merged to 'next' on 2012-07-13 at 534e6fe)\n + t1512: match the \"other\" object names\n  (merged to 'next' on 2012-07-11 at d30ef51)\n + t1512: ignore whitespaces in wc -l output\n  (merged to 'next' on 2012-07-10 at 669dd92)\n + rev-parse --disambiguate=<prefix>\n + rev-parse: A and B in \"rev-parse A..B\" refer to committish\n + reset: the command takes committish\n + commit-tree: the command wants a tree and commits\n + apply: --build-fake-ancestor expects blobs\n + sha1_name.c: add support for disambiguating other types\n + revision.c: the \"log\" family, except for \"show\", takes committish\n + revision.c: allow handle_revision_arg() to take other flags\n + sha1_name.c: introduce get_sha1_committish()\n + sha1_name.c: teach lookup context to get_sha1_with_context()\n + sha1_name.c: many short names can only be committish\n + sha1_name.c: get_sha1_1() takes lookup flags\n + sha1_name.c: get_describe_name() by definition groks only commits\n + sha1_name.c: teach get_short_sha1() a commit-only option\n + sha1_name.c: allow get_short_sha1() to take other flags\n + get_sha1(): fix error status regression\n + sha1_name.c: restructure disambiguation of short names\n + sha1_name.c: correct misnamed \"canonical\" and \"res\"\n + sha1_name.c: refactor find_short_packed_object()\n + sha1_name.c: rename \"now\" to \"current\"\n + sha1_name.c: clarify what \"fake\" is for in find_short_object_filename()\n + sha1_name.c: get rid of get_sha1_with_mode()\n + sha1_name.c: get rid of get_sha1_with_mode_1()\n + sha1_name.c: hide get_sha1_with_context_1() ugliness\n + sha1_name.c: indentation fix\n\nLogic to disambiguate abbreviated object names have been taught to\ntake advantage of object types that are expected in the context,\ne.g. XXXXXX in the \"git describe\" output v1.2.3-gXXXXXX must be a\ncommit object, not a blob nor a tree.  This will help us prolong the\nlifetime of abbreviated object names.\n\n* jk/revision-walk-stop-at-max-count (2012-07-13) 1 commit\n  (merged to 'next' on 2012-07-16 at 603975d)\n + revision: avoid work after --max-count is reached\n\n\"git log -n 1 -- rarely-touched-path\" was spending unnecessary\ncycles after showing the first change to find the next one, only to\ndiscard it.\n\n* jl/maint-1.7.10-recurse-submodules-with-symlink (2012-07-12) 1 commit\n  (merged to 'next' on 2012-07-16 at 2e10caf)\n + submodules: don't stumble over symbolic links when cloning recursively\n\nWhen \"git submodule add\" clones a submodule repository, it can get\nconfused where to store the resulting submodule repository in the\nsuperproject's .git/ directory when there is a symbolic link in the\npath to the current directory.\n\n* lk/more-helpful-status-hints (2012-07-16) 1 commit\n  (merged to 'next' on 2012-07-16 at 8f9b3cc)\n + status: color in-progress message like other header messages\n\nFinishing touches.\n\n* mm/config-xdg (2012-07-16) 1 commit\n  (merged to 'next' on 2012-07-16 at 1a75d75)\n + config: fix several access(NULL) calls\n\nFinishing touches.\n\n* ms/daemon-doc-typo (2012-07-16) 1 commit\n  (merged to 'next' on 2012-07-16 at 3976434)\n + Documentation/git-daemon: add missing word\n\n* pg/maint-1.7.9-am-where-is-patch (2012-07-13) 1 commit\n  (merged to 'next' on 2012-07-16 at 32f1e30)\n + am: indicate where a failed patch is to be found\n\nWhen \"git am\" failed, old timers knew to check .git/rebase-apply/patch\nto see what went wrong, but we never told the users about it.\n\n--------------------------------------------------\n[New Topics]\n\n* mm/mediawiki-usability (2012-07-17) 10 commits\n  (merged to 'next' on 2012-07-22 at fe66a95)\n + git-remote-mediawiki: allow page names with a ':'\n + git-remote-mediawiki: fix incorrect test usage in test\n + git-remote-mediawiki: properly deal with invalid remote revisions\n + git-remote-mediawiki: show progress information when getting last remote revision\n + git-remote-mediawiki: show progress information when listing pages\n + git-remote-mediawiki: use --force when adding notes\n + git-remote-mediawiki: get rid of O(N^2) loop\n + git-remote-mediawiki: make mediafiles export optional\n + git-remote-mediawiki: actually send empty comment when they're empty\n + git-remote-mediawiki: don't split namespaces with spaces\n\nWill merge to 'master'.\n\n* jk/mediawiki-credential (2012-07-18) 4 commits\n  (merged to 'next' on 2012-07-22 at 2cb99b2)\n + mw-to-git: use git-credential's URL parser\n + credential: convert \"url\" attribute into its parsed subparts\n + mw-to-git: check blank credential attributes via length\n + docs/credential: minor clarity fixups\n\nWill merge to 'master'.\n\n* jv/maint-no-ext-diff (2012-07-19) 2 commits\n  (merged to 'next' on 2012-07-22 at eefcf45)\n + diff: test precedence of external diff drivers\n + diff: correctly disable external_diff with --no-ext-diff\n\n\"git diff --no-ext-diff\" did not output anything for a typechange\nfilepair when GIT_EXTERNAL_DIFF is in effect.\n\nWill merge to 'master'.\n\n* kk/maint-1.7.9-commit-tree (2012-07-17) 1 commit\n + commit-tree: resurrect command line parsing updates\n (this branch is used by kk/maint-commit-tree.)\n\nA more natural-looking \"git commit-tree -p <parent> <tree>\" syntax\nwas introduced long time ago, but we accidentally broke it in the\n1.7.9 era.\n\n* kk/maint-commit-tree (2012-07-17) 2 commits\n  (merged to 'next' on 2012-07-22 at ab15d56)\n + Revert \"git-commit-tree(1): update synopsis\"\n + Merge branch 'kk/maint-1.7.9-commit-tree' into kk/maint-commit-tree\n (this branch uses kk/maint-1.7.9-commit-tree.)\n\nWill merge to 'master'.\n\n* mz/rebase-range (2012-07-18) 7 commits\n - rebase (without -p): correctly calculate patches to rebase\n - rebase -p: don't request --left-right only to ignore left side\n - rebase -p: use --cherry-mark for todo file\n - git-rebase--interactive.sh: look up subject in add_pick_line\n - git-rebase--interactive: group all $preserve_merges code\n - git-rebase--interactive.sh: extract function for adding \"pick\" line\n - git-rebase--am.sh: avoid special-casing --keep-empty\n\n* sl/autoconf (2012-07-19) 7 commits\n - build: reconfigure automatically if configure.ac changes\n - build: \"make clean\" should not remove configure-generated files\n - autoconf: use AC_CONFIG_COMMANDS instead of ad-hoc 'config.mak.append'\n - autoconf: remove few redundant semicolons\n - autoconf: remove some redundant shell indirections\n - autoconf: GIT_CONF_APPEND_LINE -> GIT_CONF_SUBST\n - autoconf: GIT_CONF_APPEND_LINE: change signature\n\nWill merge to 'next'.\n\n* jx/i18n-1.7.11 (2012-07-22) 7 commits\n - i18n: merge-recursive: mark strings for translation\n - Remove unused and bad gettext block from git-am\n - i18n: am: mark more strings for translation\n - Remove obsolete LONG_USAGE which breaks xgettext\n - i18n: Rewrite gettext messages start with dash\n - i18n: rebase: mark strings for translation\n - i18n: New keywords for xgettext extraction from sh\n\n* th/difftool-diffall (2012-07-19) 1 commit\n - difftool: only copy back files modified during directory diff\n\nWill merge to 'next'.\n\n--------------------------------------------------\n[Stalled]\n\n* jl/submodule-rm (2012-07-05) 2 commits\n - rm: remove submodules from the index and the .gitmodules file\n - rm: don't fail when removing populated submodules\n\nExpecting a reroll.\n\n* mh/maint-revisions-doc (2012-07-05) 2 commits\n - Document rev^! and rev^@ as revision specifiers\n - Make <refname> documentation more consistent.\n\nExpecting a reroll of the tip one.\n\n* ph/stash-rerere (2012-07-08) 2 commits\n - stash: invoke rerere in case of conflict\n - test: git-stash conflict sets up rerere\n\nWill be rerolled but is going in the right direction.\n\n* lt/commit-tree-guess-utf-8 (2012-06-28) 1 commit\n - commit/commit-tree: correct latin1 to utf-8\n\nTeaches \"git commit\" and \"git commit-tree\" the \"we are told to use\nutf-8 in log message, but this does not look like utf-8---attempt to\npass it through convert-from-latin1-to-utf8 and see if it makes\nsense\" heuristics \"git mailinfo\" already uses.\n\nA draft from Linus received privately without a log message.\nExpecting a reroll.\n\n* nk/maint-gitweb-log-by-lines (2012-07-05) 3 commits\n  (merged to 'next' on 2012-07-13 at 780e16a)\n + gitweb: Add support to Link: tag\n + gitweb: Handle other types of tag in git_print_log\n + gitweb: Cleanup git_print_log()\n\nTeach gitweb to pay attention to various forms of credits that are\nsimilar to \"Signed-off-by:\" lines.\n\nNeeds to be eyeballed for the correctness of the esc_html() in the tip one.\n\n* jc/test-lib-source-build-options-early (2012-06-24) 1 commit\n - test-lib: reorder and include GIT-BUILD-OPTIONS a lot earlier\n\nReorders t/test-lib.sh so that we dot-source GIT-BUILD-OPTIONS that\nrecords the shell and Perl the user told us to use with Git a lot\nearly, so that test-lib.sh script itself can use \"$PERL_PATH\" in\none of its early operations.\n\nNeeds to be eyeballed by people who run tests with exotic options\nlike valgrind, --root=/dev/shm/somewhere, etc.\n\n* mb/remote-default-nn-origin (2012-07-11) 6 commits\n - Teach get_default_remote to respect remote.default.\n - Test that plain \"git fetch\" uses remote.default when on a detached HEAD.\n - Teach clone to set remote.default.\n - Teach \"git remote\" about remote.default.\n - Teach remote.c about the remote.default configuration setting.\n - Rename remote.c's default_remote_name static variables.\n\nWhen the user does not specify what remote to interact with, we\noften attempt to use 'origin'.  This can now be customized via a\nconfiguration variable.\n\nExpecting a reroll.\n\"The first remote becomes the default\" bit is better done as a\nseparate step.\n\n* jc/maint-push-refs-all (2012-05-04) 2 commits\n - get_fetch_map(): tighten checks on dest refs\n - fetch/push: allow refs/*:refs/*\n\nAllows pushing and fetching refs/stash.\nThere still seem to be other bugs hiding (e.g. try pushing twice).\n\nNot ready.\n\n* jc/split-blob (2012-04-03) 6 commits\n - chunked-object: streaming checkout\n - chunked-object: fallback checkout codepaths\n - bulk-checkin: support chunked-object encoding\n - bulk-checkin: allow the same data to be multiply hashed\n - new representation types in the packstream\n - packfile: use varint functions\n\nNot ready.\n\nI finished the streaming checkout codepath, but as explained in\n127b177 (bulk-checkin: support chunked-object encoding, 2011-11-30),\nthese are still early steps of a long and painful journey. At least\npack-objects and fsck need to learn the new encoding for the series\nto be usable locally, and then index-pack/unpack-objects needs to\nlearn it to be used remotely.\n\nGiven that I heard a lot of noise that people want large files, and\nthat I was asked by somebody at GitTogether'11 privately for an\nadvice on how to pay developers (not me) to help adding necessary\nsupport, I am somewhat dissapointed that the original patch series\nthat was sent almost two months ago still remains here without much\ncomments and updates from the developer community. I even made the\ninterface to the logic that decides where to split chunks easily\nreplaceable, and I deliberately made the logic in the original patch\nextremely stupid to entice others, especially the \"bup\" fanboys, to\ncome up with a better logic, thinking that giving people an easy\ntarget to shoot for, they may be encouraged to help out. The plan is\nnot working :-(.\n\n--------------------------------------------------\n[Cooking]\n\n* sn/doc-typofix (2012-07-14) 1 commit\n  (merged to 'next' on 2012-07-22 at 168bba9)\n + doc: A few minor copy edits.\n\nWill merge to 'master'.\n\n* tg/ce-namelen-field (2012-07-11) 2 commits\n  (merged to 'next' on 2012-07-22 at 2d85b05)\n + Strip namelen out of ce_flags into a ce_namelen field\n + Merge branch 'tg/maint-cache-name-compare' into tg/ce-namelen-field\n\nSplit lower bits of ce_flags field and creates a new ce_namelen\nfield in the in-core index structure.\n\nWill merge to 'master'.\n\n* jk/no-more-pre-exec-callback (2012-06-05) 1 commit\n - pager: drop \"wait for output to run less\" hack\n\nWill defer for 6 months until ancient \"less\" goes extinct.\n\n* mm/push-default-switch-warning (2012-06-24) 1 commit\n  (merged to 'next' on 2012-06-26 at fea512a)\n + push: start warning upcoming default change for push.default\n\nWill defer for another cycle.\n"}]}